Re: CPU load on single board Linux computers with 12 bit SDR? #hardware #spyserver


Jeff Kelly
 

I am running the Asus Tinker board…one with an Airspy and one with a RTLSDR V3
It handles the 2.5 MHZ Airspy bandwidth and the 2.4 RTLSDR fine.  And I think 10 users would be fine.

It does burp a little with the 8 mhz bandwidth of the airspy. so wouldn’t recommend that.

I have 4 tinker boards stacked for projects and have pretty much put the RPI’s in the drawer! Love them.

Tinkers...




Jeff
K2SDR





On Nov 21, 2017, at 4:33 PM, weird_joe@... wrote:

Hi Everybody,

I have a few questions on the real life situation with mini computers and the Spyserver.
- I'd like to know how the CPU load of e.g. a Raspberry Pi 3 is when running the Spyserver with a device like the Airspy or Airspy Mini (more than 8 bits)?
- Do I have to reduce the FFT framerate in order to not overload the CPU? 
- What bandwidth can I practically use? Full spectrum? (full 10MHz on an Airspy?) I am really impressed how low the CPU impact on a second connected client is when running it under Windows. 
- Would you recommend a more powerful mini computer, like the Asus Tinker or Odroid octa core with twice as much RAM and much more performance?
- I believe the Asus Tinker has the exact same physical outlines of the Pi3, and there are plenty of inexpensive metal cases that should minimize the RF noise - so I guess that would be an advantage against the Odroid boards which are available with the faster memory modules than the fastest SD cards as far as I have been reading. Any recommendations on that?
- Do you have any recommendations on where to get a low RF-noise 5V 4A power supply for these more powerful boards?
- in case performance on these boards is no big issue, can I also run several Spyserver in separate directories addressing different receivers in parallel in Linux like I currently do on my Windows server?
- I have just been trying to run the Spyserver on my little Raspberry-Pi Zero W with the latest OS (slim version w/o GUI) but the only thing I get a a segmentation fault. The relatively dumb RTL-TCP server runs fine, so the dongle and driver setup works. So far I could not find out what the actual problem is. I have already been reformatting the SD card and put the latest image on.

In advance many thanks for any constructive feedback!

Join airspy@groups.io to automatically receive all group messages.