Topics

Yahoo Historical updating errors


Gordon Lackey
 

Having issues with Yahoo historical data no downloading for random ETF tickers when I refresh or open. Seems to be different tickers missing each time I refresh.
have tried to delete all data once when closing and still no luck. no formulas have been changed since the data started loading weird on Friday 3/20

Should I try deleting all data completely and starting fresh?


Leo
 

Hi Gordon

 

This has always been a problem with Yahoo, although sounds like it is a bit more frequent these days (although less so than a few weeks ago).

 

Xlq makes the request for data and works with the data it receives. If the server that handled the request indicates the symbol is invalid or does not have the most recent data what you see can occur. Sometimes it is sufficient to re-request as rarely the same server would handle the request. If you re-request all you may get the data for the symbol that had the issue but have a new problem with another.

 

You can try a delete all data on exit – once from xlq preferences to start with clean data, and then delete the specific symbol you have problem with in the stock manager so only that one is re-requested.

 

Alternatively use a different source. Non dividend adjusted ETF data is available from different sources, and if you need split adjusted ETF data use Tiingo.

 

Regards

 

Leo


On Tue, Mar 24, 2020 at 02:35 PM, Gordon Lackey wrote:
Having issues with Yahoo historical data no downloading for random ETF tickers when I refresh or open. Seems to be different tickers missing each time I refresh.
have tried to delete all data once when closing and still no luck. no formulas have been changed since the data started loading weird on Friday 3/20

Should I try deleting all data completely and starting fresh?


Gordon Lackey
 

Thank you Leo.  I appreciate the reply, I will work through these.

On Wednesday, March 25, 2020, 07:00:26 AM EDT, Leo <leov@...> wrote:


Hi Gordon

 

This has always been a problem with Yahoo, although sounds like it is a bit more frequent these days (although less so than a few weeks ago).

 

Xlq makes the request for data and works with the data it receives. If the server that handled the request indicates the symbol is invalid or does not have the most recent data what you see can occur. Sometimes it is sufficient to re-request as rarely the same server would handle the request. If you re-request all you may get the data for the symbol that had the issue but have a new problem with another.

 

You can try a delete all data on exit – once from xlq preferences to start with clean data, and then delete the specific symbol you have problem with in the stock manager so only that one is re-requested.

 

Alternatively use a different source. Non dividend adjusted ETF data is available from different sources, and if you need split adjusted ETF data use Tiingo.

 

Regards

 

Leo


On Tue, Mar 24, 2020 at 02:35 PM, Gordon Lackey wrote:
Having issues with Yahoo historical data no downloading for random ETF tickers when I refresh or open. Seems to be different tickers missing each time I refresh.
have tried to delete all data once when closing and still no luck. no formulas have been changed since the data started loading weird on Friday 3/20

Should I try deleting all data completely and starting fresh?