Topics

TDA inputs not working


dwstewart3@...
 

For the past few days, I'm getting nothing from TD Ameritrade, despite verifying my login information is correct.  Every field that relies on TDA data just continuously shows "Busy...".  I am using YAHOO for the time being, but YAHOO does not provide dividend information, so I am eager to get TDA working again.  Any suggestions?


Leo
 

Hi

 

I am not aware of any issues with TDAmeritrade. Send me a direct email with info on what is shown in the xlq status view under TDAmeritrade day and we can try work through the problem, including trying the latest beta if needed which uses a different login process.

 

Regards

 

 

Leo

 


dwstewart3@...
 

Leo,

I reapplied my TDA username and password in xlq preferences for this account, to no avail.  But as luck would have it, I just did that again, and it worked.  Third time's a charm!  Problem solved.

Thanks,
David


Bill Holton
 

This doesn’t make sense, but what works for me sometime is to have a single formula at the top of my spread sheet, when TDA doesn’t work I change the source on that one cell to Yahoo, then,, when I get a result, change it back to TDA.  Then suddenly all of the  quotes pop up.

 

 

From: XLQ@groups.io <XLQ@groups.io> On Behalf Of dwstewart3@...
Sent: Thursday, November 21, 2019 8:01 AM
To: XLQ@groups.io
Subject: Re: [XLQ Users] TDA inputs not working

 

Leo,

I reapplied my TDA username and password in xlq preferences for this account, to no avail.  But as luck would have it, I just did that again, and it worked.  Third time's a charm!  Problem solved.

Thanks,
David


dwstewart3@...
 

Thanks, Bill.  That's worked for me in the past, as well.  I can't explain how or why my login information stored in xlq got corrupted, but it must have.  I also can't explain why I tried to correct it twice, and still got the error, but later, on the third try, it worked.  Operator error, I suppose!  I've been working with Yahoo data for several days, but they don't supply dividend info, so I'm just happy to have TDA data working again.


dwstewart3@...
 

Here we go again.  I renewed my TDA login credentials on 2/20/2020, which is only good for 90 days.  Today, when I open my file, I get the "missing TDA authorization" error, so I go into preferences and get to the login screen and re-enter the data.  I get a data confirmation, but the old login date does not update, and I still can't get any data.  I've done this 5 times now, and it still shows my authorization expiring yesterday.  ???


Leo
 

Hi David

 

The problem you mention I have only heard of over the last couple of days but I am still trying to determine what it is. I have tried to replicate it without success, and most who indicated having it, including all who mentioned it first, said they tried again and it worked. I assume TDA has a problem or more likely, given that it seems to work with the ‘confirmation received’  have changed something causing the issue or is intermittent. As it is not occurring for me I am working with some people to try and understand what the problem is so  hopefully will know more soon.

 

Whatever the problem is it has nothing to do with your prior messages which refer to the old TDA login process.

 

When I have more info I will let you know.

 

Regards

 

Leo

 


On Thu, May 21, 2020 at 12:23 AM, <dwstewart3@...> wrote:
Here we go again.  I renewed my TDA login credentials on 2/20/2020, which is only good for 90 days.  Today, when I open my file, I get the "missing TDA authorization" error, so I go into preferences and get to the login screen and re-enter the data.  I get a data confirmation, but the old login date does not update, and I still can't get any data.  I've done this 5 times now, and it still shows my authorization expiring yesterday.  ???


James Heiman
 

I've had a similar issue several times over the last week.  My system requested TDA pre-authorization despite the fact that my expiration date hadn't yet arrived.  I tried to re-authorize and ran into a similar scripting error from earlier this year.  The message box about " do you want to continue running scripts on this page " popped up I said yes and continued the process successfully re-authorizing to get a later expiration date.  
Then last night the xlq error box popped up saying I needed to authorize TDA.  I went to that preference and looked at the date which is in the future and suddenly the system pop up box showed TDA activity and everything worked properly after I closed the xlq pop up message box.  
It seems like somewhere there is still some lingering debris from the issue causing the scripting error message or more likely maybe TDA is messing around with their  end of it. 

I hope that maybe something I said here can help locate the issue.  My system is generally running fine. I think the 2-3 times the problem happened were all after regular NY market hours or on the weekend.  Yesterday it was well after the close that the issue happened. 

On Thu, May 21, 2020, 4:27 AM Leo <leov@...> wrote:

Hi David

 

The problem you mention I have only heard of over the last couple of days but I am still trying to determine what it is. I have tried to replicate it without success, and most who indicated having it, including all who mentioned it first, said they tried again and it worked. I assume TDA has a problem or more likely, given that it seems to work with the ‘confirmation received’  have changed something causing the issue or is intermittent. As it is not occurring for me I am working with some people to try and understand what the problem is so  hopefully will know more soon.

 

Whatever the problem is it has nothing to do with your prior messages which refer to the old TDA login process.

 

When I have more info I will let you know.

 

Regards

 

Leo

 


On Thu, May 21, 2020 at 12:23 AM, <dwstewart3@...> wrote:
Here we go again.  I renewed my TDA login credentials on 2/20/2020, which is only good for 90 days.  Today, when I open my file, I get the "missing TDA authorization" error, so I go into preferences and get to the login screen and re-enter the data.  I get a data confirmation, but the old login date does not update, and I still can't get any data.  I've done this 5 times now, and it still shows my authorization expiring yesterday.  ???


Leo
 

Hi James

 

Thanks for your input.

 

The scripting error is a known issue and is completely unrelated. Xlq uses edge /explorer to connect with TDAmeritrade, and without a registry setting windows defaults to running a version compatible with the early days of the internet causing the scripting errors. As apparently  the setting can be removed by windows updates, since xlq 6.61a xlq checks for it and adds it again on startup which in general has eliminated the problem. But for some users the registry setting is still not there which is probably due to security software, but after adding it there is no problem logging in.

 

With the scripting error you cannot sign into TDAmeritrade. This new problem it is possible to sign in and authorize and the confirmation received message is returned but it does not work, as if there was no new code.

 

I have been trying on different computers, versions etc etc to try and replicate the problem and I think I finally have, and was due to the response being an error from TDAmeritrade instead of a new code.

Once I re-authorized I later got an error again when connecting as if I needed to re-authorize confirming what you mention.

 

I have sent all the details to TDAmeritrade and am now waiting for their response and hopefully a return to normal.

 

Regards

 

Leo


On Thu, May 21, 2020 at 05:07 AM, James Heiman wrote:
I've had a similar issue several times over the last week.  My system requested TDA pre-authorization despite the fact that my expiration date hadn't yet arrived.  I tried to re-authorize and ran into a similar scripting error from earlier this year.  The message box about " do you want to continue running scripts on this page " popped up I said yes and continued the process successfully re-authorizing to get a later expiration date.  
Then last night the xlq error box popped up saying I needed to authorize TDA.  I went to that preference and looked at the date which is in the future and suddenly the system pop up box showed TDA activity and everything worked properly after I closed the xlq pop up message box.  
It seems like somewhere there is still some lingering debris from the issue causing the scripting error message or more likely maybe TDA is messing around with their  end of it. 
 
I hope that maybe something I said here can help locate the issue.  My system is generally running fine. I think the 2-3 times the problem happened were all after regular NY market hours or on the weekend.  Yesterday it was well after the close that the issue happened. 

On Thu, May 21, 2020, 4:27 AM Leo <leov@...> wrote:

Hi David

 

The problem you mention I have only heard of over the last couple of days but I am still trying to determine what it is. I have tried to replicate it without success, and most who indicated having it, including all who mentioned it first, said they tried again and it worked. I assume TDA has a problem or more likely, given that it seems to work with the ‘confirmation received’  have changed something causing the issue or is intermittent. As it is not occurring for me I am working with some people to try and understand what the problem is so  hopefully will know more soon.

 

Whatever the problem is it has nothing to do with your prior messages which refer to the old TDA login process.

 

When I have more info I will let you know.

 

Regards

 

Leo

 


On Thu, May 21, 2020 at 12:23 AM, <dwstewart3@...> wrote:
Here we go again.  I renewed my TDA login credentials on 2/20/2020, which is only good for 90 days.  Today, when I open my file, I get the "missing TDA authorization" error, so I go into preferences and get to the login screen and re-enter the data.  I get a data confirmation, but the old login date does not update, and I still can't get any data.  I've done this 5 times now, and it still shows my authorization expiring yesterday.  ???


Vijay Singal
 

I have had to reauthorize my TDA account well before the expiration date.  It just stopped working and I did not know why - tried several things and it was the re-authorization that worked. 

Vijay


On Thu, May 21, 2020 at 8:07 AM James Heiman <jrheiman@...> wrote:
I've had a similar issue several times over the last week.  My system requested TDA pre-authorization despite the fact that my expiration date hadn't yet arrived.  I tried to re-authorize and ran into a similar scripting error from earlier this year.  The message box about " do you want to continue running scripts on this page " popped up I said yes and continued the process successfully re-authorizing to get a later expiration date.  
Then last night the xlq error box popped up saying I needed to authorize TDA.  I went to that preference and looked at the date which is in the future and suddenly the system pop up box showed TDA activity and everything worked properly after I closed the xlq pop up message box.  
It seems like somewhere there is still some lingering debris from the issue causing the scripting error message or more likely maybe TDA is messing around with their  end of it. 

I hope that maybe something I said here can help locate the issue.  My system is generally running fine. I think the 2-3 times the problem happened were all after regular NY market hours or on the weekend.  Yesterday it was well after the close that the issue happened. 

On Thu, May 21, 2020, 4:27 AM Leo <leov@...> wrote:

Hi David

 

The problem you mention I have only heard of over the last couple of days but I am still trying to determine what it is. I have tried to replicate it without success, and most who indicated having it, including all who mentioned it first, said they tried again and it worked. I assume TDA has a problem or more likely, given that it seems to work with the ‘confirmation received’  have changed something causing the issue or is intermittent. As it is not occurring for me I am working with some people to try and understand what the problem is so  hopefully will know more soon.

 

Whatever the problem is it has nothing to do with your prior messages which refer to the old TDA login process.

 

When I have more info I will let you know.

 

Regards

 

Leo

 


On Thu, May 21, 2020 at 12:23 AM, <dwstewart3@...> wrote:
Here we go again.  I renewed my TDA login credentials on 2/20/2020, which is only good for 90 days.  Today, when I open my file, I get the "missing TDA authorization" error, so I go into preferences and get to the login screen and re-enter the data.  I get a data confirmation, but the old login date does not update, and I still can't get any data.  I've done this 5 times now, and it still shows my authorization expiring yesterday.  ???


Tom McDaniel
 

I had a similar problem a couple of weeks ago.  I got a message that I needed to reloginto TDA.  My expiration date was in the future.  I don't remember what I did, if anything, but the data started to flow.

-Tom

On 5/21/2020 2:58 AM, James Heiman wrote:
I've had a similar issue several times over the last week.  My system requested TDA pre-authorization despite the fact that my expiration date hadn't yet arrived.  I tried to re-authorize and ran into a similar scripting error from earlier this year.  The message box about " do you want to continue running scripts on this page " popped up I said yes and continued the process successfully re-authorizing to get a later expiration date.  
Then last night the xlq error box popped up saying I needed to authorize TDA.  I went to that preference and looked at the date which is in the future and suddenly the system pop up box showed TDA activity and everything worked properly after I closed the xlq pop up message box.  
It seems like somewhere there is still some lingering debris from the issue causing the scripting error message or more likely maybe TDA is messing around with their  end of it. 

I hope that maybe something I said here can help locate the issue.  My system is generally running fine. I think the 2-3 times the problem happened were all after regular NY market hours or on the weekend.  Yesterday it was well after the close that the issue happened. 

On Thu, May 21, 2020, 4:27 AM Leo <leov@...> wrote:

Hi David

 

The problem you mention I have only heard of over the last couple of days but I am still trying to determine what it is. I have tried to replicate it without success, and most who indicated having it, including all who mentioned it first, said they tried again and it worked. I assume TDA has a problem or more likely, given that it seems to work with the ‘confirmation received’  have changed something causing the issue or is intermittent. As it is not occurring for me I am working with some people to try and understand what the problem is so  hopefully will know more soon.

 

Whatever the problem is it has nothing to do with your prior messages which refer to the old TDA login process.

 

When I have more info I will let you know.

 

Regards

 

Leo

 


On Thu, May 21, 2020 at 12:23 AM, <dwstewart3@...> wrote:
Here we go again.  I renewed my TDA login credentials on 2/20/2020, which is only good for 90 days.  Today, when I open my file, I get the "missing TDA authorization" error, so I go into preferences and get to the login screen and re-enter the data.  I get a data confirmation, but the old login date does not update, and I still can't get any data.  I've done this 5 times now, and it still shows my authorization expiring yesterday.  ???


dwstewart3@...
 

Still no change.  It takes my login info, but still shows the last authorization as 2/20 and expiring 5/19. 


orion316@...
 

I have been having this exact problem for the last four days.


dwstewart3@...
 

Leo,

Thank you for continuing to work this on our behalf.  I have switched all my inputs to YAHOO for the time being, so I'm not dead in the water, but it will be good when TDA finally resolves their issue.

David


Leo
 

Hi David

 

I have contacted TDAmeritrade a few times now but still do not have a reply.

 

The problem is intermittent, but they clearly have made a change this week that they need to look into.

 

Hopefully I will get an answer soon.

 

Regards

 

 

Leo


On Fri, May 22, 2020 at 08:27 AM, <dwstewart3@...> wrote:
Leo,

Thank you for continuing to work this on our behalf.  I have switched all my inputs to YAHOO for the time being, so I'm not dead in the water, but it will be good when TDA finally resolves their issue.

David


ROBINJHOOD
 

my tda work fine
what part is not working
robin

------ Original Message ------
From: "Leo" <leov@...>
Sent: 5/22/2020 10:58:30 AM
Subject: Re: [XLQ Users] TDA inputs not working

Hi David

 

I have contacted TDAmeritrade a few times now but still do not have a reply.

 

The problem is intermittent, but they clearly have made a change this week that they need to look into.

 

Hopefully I will get an answer soon.

 

Regards

 

 

Leo

On Fri, May 22, 2020 at 08:27 AM, <dwstewart3@...> wrote:
Leo,

Thank you for continuing to work this on our behalf.  I have switched all my inputs to YAHOO for the time being, so I'm not dead in the water, but it will be good when TDA finally resolves their issue.

David


Leo
 

Hi Robin

 

Certain requests fail, in particular connecting and authorizing.

 

Regards

 

Leo

On Fri, May 22, 2020 at 09:06 AM, ROBINJHOOD wrote:
my tda work fine
what part is not working
robin


Garry Grove
 

I am getting no Historical Data from about 10% of my Tickers in Yahoo and it's different Tickers each day. Are you having any problems with Yahoo's data?

Thanks,

Garry
~~~~~~~ 



On Fri, May 22, 2020 at 10:27 AM <dwstewart3@...> wrote:
Leo,

Thank you for continuing to work this on our behalf.  I have switched all my inputs to YAHOO for the time being, so I'm not dead in the water, but it will be good when TDA finally resolves their issue.

David


dwstewart3@...
 

Hi Leo,

Continuing to attempt to update TDA Authentication.  Getting the same results: "Confirmation received" but no update to authentication date.

YAHOO is working for prices, but I sure hope TDA gets this resolved soon.

Thanks,
David


Leo
 

Hi

 

I still have had no luck getting an answer from TDAmeritrade and will keep trying. They usually do respond but I guess these are not usual times.

 

For information, I have been working with TDAmeritrade for a large part of the last 6 months as they will be ending their current interface later this year replacing it with a new, and I have been integrating this into xlq for the next version. The problems you are seeing also occur in the new i.e. the old now uses the same new authentication and connect. I have spent the last couple of days accelerating the release of the next beta as it now checks for the connection problem, working with it as best possible,  e.g. retrying authentication until it is processed etc. so not just stuck at "Confirmation received”. Same when processing data, so even though the problem is intermittent this allows for some normality until it is fixed.

 

This is using the new TDA system which up till now has been tested and working well. I am preparing the build and will begin providing it to some users maybe later today or tomorrow, and expand its usage from there based on feedback. This I will be doing with direct communication so if anyone wishes to use the beta send me an email.

 

In addition to the new TDA interface and the changes due to these problems it also addresses the issue where yahoo is returning valid symbols as not available / delisted. Xlq2 has more, the xlq2 source now works with a totally new updating process. In addition to quarterly, historic yearly earnings are now also available, as is historic market data for some European countries (Belgium, Germany, France, UK, Ireland, Netherlands and Portugal).

 

I will respond to emails as I can.

 

Regards

 

 

Leo


On Tue, May 26, 2020 at 09:30 AM, <dwstewart3@...> wrote:
Hi Leo,

Continuing to attempt to update TDA Authentication.  Getting the same results: "Confirmation received" but no update to authentication date.

YAHOO is working for prices, but I sure hope TDA gets this resolved soon.

Thanks,
David