G1M not switching on


Dave_C_ M7DTC
 

My G1M has stopped powering on, I can hear a click when it’s switched on and off, but nothing on the screen. I’ve tried unplugging everything else and switching it on but no luck. I’ve checked the power supply output, that’s ok. Any help much appreciated. 

Dave


yue.fei1971
 

This has happened to me.  For my specific case, I had to unplug the CAT cable from the radio, turn the radio off, then back on with the CAT cable unplugged.  After it fully booted, I plugged the CAT cable back in and it was back to digital comms.  I hope this helps.


On Fri, Sep 10, 2021 at 9:14 AM Dave_C_ via groups.io <dc320=btinternet.com@groups.io> wrote:

My G1M has stopped powering on, I can hear a click when it’s switched on and off, but nothing on the screen. I’ve tried unplugging everything else and switching it on but no luck. I’ve checked the power supply output, that’s ok. Any help much appreciated. 

Dave


AndyH KK6VHP
 

Sorry this has happened to you.  It is a common problem for G1M owners.  Often we inadvertently "zap" the firmware in the process of using the CAT cable.  The symptoms you outline suggest that this may have happened, though I do hope it is something more simple..  There are copies of the G1M firmware available; I believe it's been filed with this particular user group.  You should have a back-up copy, in any case.  The procedure for re-loading the firmware is not especially user friendly, but there is also a discussion of this process in the archived group messages that can greatly assist you.  Basically, it's the same as doing firmware updates with the G90.  There are other nagging quirks with the G1M, e.g., mic/headphone female sockets detaching from PCB solders, etc.  Good luck, and welcome to the Xiegu learning experience.

Andy kk6vhp




-----Original Message-----
From: yue.fei1971 <yue.fei1971@...>
To: XIEGU-G1M@groups.io
Sent: Fri, Sep 10, 2021 11:29 am
Subject: Re: [XIEGU-G1M] G1M not switching on

This has happened to me.  For my specific case, I had to unplug the CAT cable from the radio, turn the radio off, then back on with the CAT cable unplugged.  After it fully booted, I plugged the CAT cable back in and it was back to digital comms.  I hope this helps.

On Fri, Sep 10, 2021 at 9:14 AM Dave_C_ via groups.io <dc320=btinternet.com@groups.io> wrote:
My G1M has stopped powering on, I can hear a click when it’s switched on and off, but nothing on the screen. I’ve tried unplugging everything else and switching it on but no luck. I’ve checked the power supply output, that’s ok. Any help much appreciated. 
Dave


Dave_C_ M7DTC
 

Thanks all. I’d suspected firmware after reading this http://www.cares.club/amateur-radio/one-g1m-black-screen-issue-repair-report/ 
I’ll look into it. 


Dave_C_ M7DTC
 

Also I forgot to mention I’d had times when it wouldn’t boot up, but it always came back, except not this time. 


Dave_C_ M7DTC
 

I loaded the firmware following the advice on here and elsewhere, it all went well and worked first time. 

Thanks for everyone’s help
Dave 


Jeff L
 

I had the same issue of the G1M not powering on. It was caused by the voltage dropping way down (maybe 5 volts) while powered on. A firmware flash brought it back to life. Even though I used firmware 1.07, the version shows 1.06 on the radio, but it's working fine again.

Jeff