Topics

Troubleshoot 577D1 IV curve offset problem


DW
 

Previously you might have noticed I have an issue with the 577 curve tracer where the IV curve has an offset problem, click the link below to see a picture that demonstrates the problem

https://groups.io/g/TekScopes/photo/255355/1?p=Created,,,20,2,0,0

Using a oscilloscope and the STEP AMPLIFIER schematic to probe around the OFFSET MULTI of the circuit. I found when I probe pin 3 and pin 1 of 350A with the OFFSET MULTI disabled I see 0V. Probing pins 1 and 3 of 350A withe the OUT OFFSET and OUT OPPOSE buttons OUT I see -500mV with the OFFSET knob set to 1 - 0 (1 outer ring 0 inner). With OUT OPPOSE button in I see +500mV.
U350A seems to be working.

With OFFSET MULTI disabled probing pin 7 of 350B I see a clean 11 step staircase pattern which is offset in the negative region on the scope screen, I get the same exact result probing pin 6 on U360.

Using OFFSET MULTI to correct the offset on the IV curve I set OUT OFFSET and OUT OPPOSE buttons out with the knob set to 2 - 5 (Outer ring 2 inner 5) to park the first horizontal line at the bottom where the trace begins at the dot, I looked at various pictures of other 577's and the first horizontal line of the IV curves begins at about 0 amps. After making this correction I probe TP360 which is the output of U360, I now find the first top step of the stair case pattern is at +1V and the next immediate step is just at 0V.

These are my results so far, more details will come later.


DW
 

Probing Q384 and Q386 the staircase pattern now appears to have anomalies as the link below shows

https://groups.io/g/TekScopes/photo/255355/7?p=Created,,,20,2,0,0

If anyone is willing to probe Q384 and Q386 to see how your measurements differ from mine, be careful with the ground lead on the probe. I have a feeling the vertical distortion I am seeing with each of the first few lower steps on the staircase pattern explain the offset problem on the IV curve, the problems seems to occur after U360.


DW
 

In the attempt to find the reason for the distortion at Q384 and Q386 it seems things have changed after taking a break, Q384 and Q386 staircase patterns appear normal however I notice a offset imbalance. Q384 has a slight positive offset of its stair pattern meanwhile Q386 has quite a negative offset on its stair pattern, I have to adjust the oscilloscope sensitivity otherwise Q386 trace clips off the negative side of the screen . I been moving switches, dials, and knobs around, perhaps some kind of contact issue.


DW
 

I found that the STEP OFFSET AMPL selector can be set between current or voltage, in voltage mode I probed right at the base of the test fixture and found a clean staircase pattern so I believe no concern there that I can see.

The display has now developed an issue where the trace flashes brightly. Using the D1 storage feature I was able to capture how exactly the trace is affected by the flash, it appears vertically the trace just becomes wider but only briefly and with intensity.