Topics

(Solved) Re: 7854 - No RO in SCOPE + WF modulates RO in STORED


Ram
 

I managed to understand the working and schematics of the 7854's digital section since I last reported this issue, and fixed the problem. For posterity and for the benefit of anyone who is trying to troubleshoot problems with the 7854 I thought I'd document what I understood. Hope it turns out useful to someone!
- There are several test points of the 7854 accessible from the top side where the digital board get plugged in. These are exceedingly useful. Some waveforms described in the manual are, however, not accessible from these test points. An easy way to create access is to pull out the respective board and solder a header pin to the point in question. Then you can simply plug in a receptacle pin onto the header whenever you need to make an observation. (You need to bend the header pin so it points upwards.)
- The scope display alternates between XY mode (not to be confused with the X vs Y displays for obtaining Lissajous figures) and YT mode. YT mainly handles real-time waveforms and XY mainly handles digitized data and readouts. The two kinds of signals meet at the Vertical Amplifier (and Horizontal Amplifier for horiz signals). One of them is suppressed by the XYINH signal (which is not TTL).
- In this particular case since both signals were getting mixed up, the investigation quickly narrowed down to a few signals including the XYINH signal. This signal is generated in schematic 34 in the Display D/A and Amplifier section, using !DSYOFF, by a few transistors including Q1830 (CA3046). Turned out that one of the transistors in the CA3046 had gone bad and so the XYINH was not able to go positive. Replacing the chip has solved this problem - my scope which was apparently not able to store any waveforms earlier now does so!
It still stops acquisition with an error beep because it is not able to store the readout information (which is missing in the SCOPE mode) and I believe that is due to a bad XY signal. If and when I get round to solving that I'll post my findings here.
Best - Ram


Ram
 

And, finally, here is the solution to the missing readout in SCOPE mode and the acquisition warning which were tied to the same cause. I am documenting some insights for posterity and for the benefit of anyone who may want to troubleshoot a readout issue with the 7854 at some point.
In sch 34, the RO-WFMX/Y signals were present in all modes. However, while the WFMZON signal was present, allowing stored waveforms to be displayed, the CHRZON signal was high, inhibiting the RO display n SCOPE mode. The latter is from sch 33, and available off TP2400-12. This implied that the characters that were attempted to be displayed were invalid and so there was no dot pattern to be generated by the dot timer stage. Since the readout was OK in the STORE mode the source of the bad characters had to be in the readout acquisition stage, sch 31.
In sch 31, TP2400-26 and 28 indicated that the plugins were sending row and column pulses so U2520 and U2530 were probably OK. To check the A/D converters U1220 and U1520 (the row and columnn decoders) I tapped Row 3 and Column 10 of the outputs of these ICs (the IDENTIFY signal). Pressing the Identify button on the plugin caused a reaction on Column 10 but no reaction on Row 3. That pointed to U1220. I found that both these A/D converters were socketed indicating a prior repair attempt. Sure enough, interchanging them reversed the problem and also led to a much-desired readout appearing on the screen though it was not meaningful because of a bad column decoder.
Ordered a new A/D converter off ePray - these things are hard to find and I had to pay a good $18 for one. They do look prone to failure going by the earlier repair attempts on these same chips in my 7854.
Best - Ram
-