Extraneous question marks


Harvey White
 

Many word processors use 8 bit data (ASCII is 7), that 8th bit gives them 128 characters that are generally used as control and formatting characters when set.  Normal characters do not have the 8th bit set.

If a message is composed in any kind of word processor that uses those characters, and that's directly sent, you get the 128 control characters (possibly) mixed in with the normal text.

Depending on how the email program handles things, you could see those 8th bit set characters mapped to "extra" characters (extended character set used in some applications, the PC/windows use that).

You'll see garbage, or extra characters depending on how the software interacts.

Harvey

On 2/22/2021 5:43 PM, Jim Ford wrote:
Uh, I  didn't see any weird question marks I your last 2 messages.  Apologizing for the format mangling my ancient (2015) smartphone does.....        Jim Ford Sent from my Verizon, Samsung Galaxy smartphone
-------- Original message --------From: Dave Wise <david_wise@phoenix.com> Date: 2/22/21 1:59 PM (GMT-08:00) To: TekScopes@groups.io Subject: Re: [TekScopes] Extraneous question marks It didn't help.  Sorry group, I guess from now on I'll have unintended question marks here and there.  Bear with me.Dave Wise________________________________From: TekScopes@groups.io <TekScopes@groups.io> on behalf of Dave Wise via groups.io <david_wise=phoenix.com@groups.io>Sent: Monday, February 22, 2021 1:55 PMTo: TekScopes@groups.ioSubject: Re: [TekScopes] Extraneous question marksI forgot to say I'm using Outlook Web App.?I changed Settings|Options|Settings|Message Format from HTML to Plain Text. Let's see if it helped.Dave Wise________________________________From: TekScopes@groups.io <TekScopes@groups.io> on behalf of John Ferguson via groups.io <jferg977=aol.com@groups.io>Sent: Monday, February 22, 2021 12:29 PMTo: TekScopes@groups.ioSubject: Re: [TekScopes] Extraneous question marksi had this problem. I cannot remember which way to switch the "text"mode in my mail program but it should be either text of html. you'llhave to experiment.On 2/22/21 2:43 PM, Dave Wise wrote:> ?Does anyone know a fix for the question marks that keep being randomly inserted in my posts? <--- That one is intentional :)>>> Dave Wise>> Safari under MacOS>>>>>
i


Jim Ford
 

Uh, I  didn't see any weird question marks I your last 2 messages.  Apologizing for the format mangling my ancient (2015) smartphone does.....        Jim Ford Sent from my Verizon, Samsung Galaxy smartphone

-------- Original message --------From: Dave Wise <david_wise@phoenix.com> Date: 2/22/21 1:59 PM (GMT-08:00) To: TekScopes@groups.io Subject: Re: [TekScopes] Extraneous question marks It didn't help.  Sorry group, I guess from now on I'll have unintended question marks here and there.  Bear with me.Dave Wise________________________________From: TekScopes@groups.io <TekScopes@groups.io> on behalf of Dave Wise via groups.io <david_wise=phoenix.com@groups.io>Sent: Monday, February 22, 2021 1:55 PMTo: TekScopes@groups.ioSubject: Re: [TekScopes] Extraneous question marksI forgot to say I'm using Outlook Web App.?I changed Settings|Options|Settings|Message Format from HTML to Plain Text. Let's see if it helped.Dave Wise________________________________From: TekScopes@groups.io <TekScopes@groups.io> on behalf of John Ferguson via groups.io <jferg977=aol.com@groups.io>Sent: Monday, February 22, 2021 12:29 PMTo: TekScopes@groups.ioSubject: Re: [TekScopes] Extraneous question marksi had this problem. I cannot remember which way to switch the "text"mode in my mail program but it should be either text of html. you'llhave to experiment.On 2/22/21 2:43 PM, Dave Wise wrote:> ?Does anyone know a fix for the question marks that keep being randomly inserted in my posts? <--- That one is intentional :)>>> Dave Wise>> Safari under MacOS>>>>>


Vince Vielhaber
 

I forgot to offer a solution. Try changing the character set your browser or email program (whichever you're using) to a different one. There should be something in your settings for that. Perhaps a default
to use if it doesn't have the set that's called for, change the default.

That make sense? <-- that one's intentional too.

Vince.

On 02/22/2021 05:27 PM, Vince Vielhaber wrote:
They're usually control or unprintable characters. Someone's computer
using smart quotes or other non-ascii characters, your program will give
you a question mark instead of the character that it can't print.

Vince.



On 02/22/2021 04:59 PM, Dave Wise wrote:
It didn't help. Sorry group, I guess from now on I'll have unintended
question marks here and there. Bear with me.


Dave Wise

________________________________
From: TekScopes@groups.io <TekScopes@groups.io> on behalf of Dave Wise
via groups.io <david_wise=phoenix.com@groups.io>
Sent: Monday, February 22, 2021 1:55 PM
To: TekScopes@groups.io
Subject: Re: [TekScopes] Extraneous question marks

I forgot to say I'm using Outlook Web App.?

I changed Settings|Options|Settings|Message Format from HTML to Plain
Text. Let's see if it helped.


Dave Wise

________________________________
From: TekScopes@groups.io <TekScopes@groups.io> on behalf of John
Ferguson via groups.io <jferg977=aol.com@groups.io>
Sent: Monday, February 22, 2021 12:29 PM
To: TekScopes@groups.io
Subject: Re: [TekScopes] Extraneous question marks

i had this problem. I cannot remember which way to switch the "text"
mode in my mail program but it should be either text of html. you'll
have to experiment.

On 2/22/21 2:43 PM, Dave Wise wrote:
?Does anyone know a fix for the question marks that keep being
randomly inserted in my posts? <--- That one is intentional :)


Dave Wise

Safari under MacOS

















Vince Vielhaber
 

They're usually control or unprintable characters. Someone's computer using smart quotes or other non-ascii characters, your program will give you a question mark instead of the character that it can't print.

Vince.

On 02/22/2021 04:59 PM, Dave Wise wrote:
It didn't help. Sorry group, I guess from now on I'll have unintended question marks here and there. Bear with me.


Dave Wise

________________________________
From: TekScopes@groups.io <TekScopes@groups.io> on behalf of Dave Wise via groups.io <david_wise=phoenix.com@groups.io>
Sent: Monday, February 22, 2021 1:55 PM
To: TekScopes@groups.io
Subject: Re: [TekScopes] Extraneous question marks

I forgot to say I'm using Outlook Web App.?

I changed Settings|Options|Settings|Message Format from HTML to Plain Text. Let's see if it helped.


Dave Wise

________________________________
From: TekScopes@groups.io <TekScopes@groups.io> on behalf of John Ferguson via groups.io <jferg977=aol.com@groups.io>
Sent: Monday, February 22, 2021 12:29 PM
To: TekScopes@groups.io
Subject: Re: [TekScopes] Extraneous question marks

i had this problem. I cannot remember which way to switch the "text"
mode in my mail program but it should be either text of html. you'll
have to experiment.

On 2/22/21 2:43 PM, Dave Wise wrote:
?Does anyone know a fix for the question marks that keep being randomly inserted in my posts? <--- That one is intentional :)


Dave Wise

Safari under MacOS
















n4buq
 

Hi Dave,

I don't see any unintended question marks in your last two posts.

Thanks,
Barry - N4BUQ

----- Original Message -----
From: "Dave Wise" <david_wise@phoenix.com>
To: TekScopes@groups.io
Sent: Monday, February 22, 2021 3:59:02 PM
Subject: Re: [TekScopes] Extraneous question marks

It didn't help. Sorry group, I guess from now on I'll have unintended
question marks here and there. Bear with me.


Dave Wise

________________________________
From: TekScopes@groups.io <TekScopes@groups.io> on behalf of Dave Wise via
groups.io <david_wise=phoenix.com@groups.io>
Sent: Monday, February 22, 2021 1:55 PM
To: TekScopes@groups.io
Subject: Re: [TekScopes] Extraneous question marks

I forgot to say I'm using Outlook Web App.?

I changed Settings|Options|Settings|Message Format from HTML to Plain Text.
Let's see if it helped.


Dave Wise

________________________________
From: TekScopes@groups.io <TekScopes@groups.io> on behalf of John Ferguson
via groups.io <jferg977=aol.com@groups.io>
Sent: Monday, February 22, 2021 12:29 PM
To: TekScopes@groups.io
Subject: Re: [TekScopes] Extraneous question marks

i had this problem. I cannot remember which way to switch the "text"
mode in my mail program but it should be either text of html. you'll
have to experiment.

On 2/22/21 2:43 PM, Dave Wise wrote:
?Does anyone know a fix for the question marks that keep being randomly
inserted in my posts? <--- That one is intentional :)


Dave Wise

Safari under MacOS


















Dave Wise
 

It didn't help. Sorry group, I guess from now on I'll have unintended question marks here and there. Bear with me.


Dave Wise

________________________________
From: TekScopes@groups.io <TekScopes@groups.io> on behalf of Dave Wise via groups.io <david_wise=phoenix.com@groups.io>
Sent: Monday, February 22, 2021 1:55 PM
To: TekScopes@groups.io
Subject: Re: [TekScopes] Extraneous question marks

I forgot to say I'm using Outlook Web App.?

I changed Settings|Options|Settings|Message Format from HTML to Plain Text. Let's see if it helped.


Dave Wise

________________________________
From: TekScopes@groups.io <TekScopes@groups.io> on behalf of John Ferguson via groups.io <jferg977=aol.com@groups.io>
Sent: Monday, February 22, 2021 12:29 PM
To: TekScopes@groups.io
Subject: Re: [TekScopes] Extraneous question marks

i had this problem. I cannot remember which way to switch the "text"
mode in my mail program but it should be either text of html. you'll
have to experiment.

On 2/22/21 2:43 PM, Dave Wise wrote:
?Does anyone know a fix for the question marks that keep being randomly inserted in my posts? <--- That one is intentional :)


Dave Wise

Safari under MacOS