Topics

Need 067-1051-00 right angle extender for 7D20


Dallas Smith
 

Did the swap, now I'm confused, same problem but the trace offset is less, comes up with failure error but no numbers.. Will put this project on hold until l get my third flexible extender.and right angle extender. Not sure where I'll get the RA extender from, hope I do not have to make one.. Someone said these are temperamental, they were right

Thanks everyone for all your suggestions, any more suggestions, feel free to comment.

Dallas


Dallas Smith
 

Thank you Håkan,
I see what you are saying now. Since my other 7D20 has only has attenuator problems I'm going yo swap the repaired 7D20 preamp board to it and see what happens.
Dallas


 

On Mon, Jul 13, 2020 at 02:08 AM, Dallas Smith wrote:


are your saying that the ROM;s have gone bad?
No the ROM's haven't gone bad. The problem I described concerns only these diagnostics errors
when nothing else seem wrong. So, since you have the right F/W versions and obvious malfunction
the F/W is not your problem.

Here's the original message from Wizards Workshop 1984:

//
7D20 ERROR CODES 654321 & 65432

REF: 7D20 Instruction Manual
P/N 070-3858-01

There have been several instances where the above mentioned error codes
have appeared and nothing can be found to be defective. What these two self-tests
are doing is checking pre-amp balances and positioning capabilities. Any small error,
even though in specification, will be checked by the CCD Multiplexer and A/D Converter.
The accumulation of these small errors may be outside the firmware window that has been
set-up for the self-tests. When the firmware is next updated, this window will probably
be opened up. For the present, here are a few hints that may help clear the self-test error.

1. Check both channels gain, atten balance, position offset, and position gain.
2. A9R626, 1.05 Mohm, P/N 321-0483-00, should be selected for the lowest value you have
available. i.e. 1.0395 Mohm.

A permanent cure is being generated and will be published when ready.
//

The permanent cure was if all ROM's were -02 to update U500 and U700 to -03.
For earlier versions all ROM's had to be updated.

/Håkan


Dallas Smith
 

Thank you Håkan,

Read your post, but this post: https://groups.io/g/TekScopes/message/106914
is exactly the same problem, the trace offset is triggering the wrong errors. I believe the large trace offset is the root cause of the problem. Both channels position will just show on the screen at full CW control position.

Checked my ROM versions: U500 & U700 Ver 03 all the others Ver 02.
The unit work for two years, how could a bug now be the problem, are your saying that the ROM;s have gone bad?
If a ROM lost a bit or two, that is a problem. These ROM's can only hold the data so long but can be freshened up by erasing and re-programming them.. Didn't find any firmware at 'KO04BB' or our files, anyone have these firmware bin's if needed?




Dallas


 

On Sun, Jul 12, 2020 at 07:35 PM, Dallas Smith wrote:


but now have self test errors 65432 & 654321
Those exact error codes are the ones known to be possibly false due to F/W bugs I mentioned
in your previous post. If your F/W is lower than 1.03, (last numbers of the P/N -03) on U500 and
U700 it could be the cause.

/Håkan


Dallas Smith
 

Thanks Egge for the heads up,

Didn't fine any on Ebay.
Maybe Le-Fong Lin could work one up if he is listening. :-)
Not sure if its possible to service without one.
Maybe solder a test point wire accessible after plugged in.

Dallas


Egge Siert
 

Hi Dallas,

The same RA Extender is used in the 067-1112-00 Service Kit for the 7A42.

Greetings,

Egge Siert


Dallas Smith
 

Hi all,
Still working on my 7D20, successfully repaired the attenuator problem but now have self test errors 65432 & 654321.
Anyone design one of these, have the PCB Gerber files or a link to someones PCB project?
These seem to be unattainable on Ebay.

Dallas