Tektronix 2246 flickering screen, ch2 not working.


This is my first post on this forum so hello to everyone!
I apologize in advance for my bad english. (I am from Poland)
My friend gave me this scope for free few days ago. (It was thrown out of company where he works). Don't know its history.
I am trying to troubleshoot it. I am newbie to scopes repair. I have experience in tube amp build and repair, also in electronics in general.
Everything is on video.


What I've done so far:
Voltages within specs. 122V on +130V AC, others less than 5mv. (tested with voltmeter and another scope) (PSU recaped - didn't solve the problem)
Also after recapping I can run self callibration only when readout intensity i is turned full ccw. Otherwise it loops and start from beginning, and after self cal, uncal lights permanently on both channels and time base. (Before recaping, after self cal they weren't) Self test from service menu shows no errors.
Scope is responsive. All things seems to work fine but it burns my eyes with this flickering. Everything is ripped and cuted. Traces are not continous.
Maybe U1001 faulty?

About dead channel 2:
Trace is somewhere but very weak and very distorted. Position seems to do nothing. No trace visible. (It can be spotted on beam find)
Trace (I input 1kHz square) is ok at input of AT127. At input of U122 there is very distorted triangle(looks like triangle), also on output. (on ch1 there is nice square at those points).

Many thanks for any hint where to start with. :)

I use this service manual: https://www.tek.com/manual/2246-service-manual (it's not 100% identical with my scope but i think it's close enough)

Mine is very early model: 1Y 2246 B045340 it's from 1986 - the year i was born :-)


With the uncal lights, those come on when the “var” knobs aren’t all the way into their divet. Turn them clockwise in every channel to turn those off. There’s an adjustment procedure for that “jittering” on the screen, look in the adjustment section of the service manual. I’m not sure about the other issues, though. Good luck!


Var knobs are locked in full cw position. Checked that before first post. On mine there is no pot for jitter adjustment. R724 not existing. I don't see any evidence of past service in this scope. I am 100% sure this is stock.

Wallace Gasiewicz

About Channel 2 not working. A frequent problem in any scope is someone blowing up the input on one channel. Usually the input transistor or FET gets burned. These are usually dual FETS. You can check the FETS (and everything else) in one input and compare to the good input. With the usual dual FETs input, one of the matched FETs amplifies the signal while the other will control the horizontal position.
Sometimes the attenuator is burned. Some Tek scopes were prone to this failure.
Measure resistance on bad input compare to good input .
I have seen this many times.

About flickering. It is possible there is a portion of the power supply on another board. Probably the board that supplies the characters. Maybe a cap or volt regulator problem.
The information for the characters is applied to the trace separately from the signal trace.
I suppose you have cleaned all the potentiometers and connections,.

I am not familiar with this particular unit so I cannot be more specific, sorry about that.

Wally KC9INK


Schematic is on page 298 of service manual.
Look there:
Trace (I input 1kHz square) is ok at input of AT127. At input of U122 there is very distorted triangle(looks like triangle), also on output. (on ch1 there is nice square at those points).
I don't see there any extra FET's. Must check C124 if it is not pulling down if case it is wrong.

I am going to change all electrolytics. There is one on logic board and many more on mainboard. I just don't want to remove mainboard many times beacuse it's very long procedure.
Flickering also is on traces itself. Not only on redouts. Alse there are gaps/cuts/ripple in traces. Turning ccw redouts helps a little but not much.
Also i noticed today that when i switch to B traces are visible only from left to center of the screen. Moving lef/right moves traces but they only take half of the screen. On A there is no problem.
Pots and cons cleaned.

Many thanks for tips.
If you have experience in scope repairs and have some free time, please check schematics in service manual. I will be very gratefull. :-)

Wallace Gasiewicz

U 122 is the signal amplifier. The entire circuit is in there. The AT 127 is part of attenuation circuit. when you use smaller signals does this change the trace? Have you tried the adjustments on the attenuator (not the other adjusts)? Together they attenuate (or just not amplify) the signal.
The AT 127 would come into play with every signal coming into channel two. It is probably blown, it is the first thing a high power signal would get to. It looks like a propriatary part.
Unfortunately your flickering could be anywhere, It is hard to measure the extremely high voltage of the CRT for ripple (13.3 KV), need a high volt probe.
They also just list the HV rectifying circuit as another "box" , maybe one of the extremely high volt diodes inside is blown.. Would account for the steady flicker that would get smaller with slower horizontal trace.
Unfortunately, I do not know where to get these parts. Maybe someone else more familiar with this model of scope could help.


Sorry for late reply, but I run out of time to test this scope.
Propably you are right, AT127 is propably blown. Tried adjustment - did nothing. at127 is making waveform look terrible. Distorted sawtooth/triangle instead of square wave.

I have change all electrolitics on all boards, and checked other caps against shorts.
I think the HV is not the problem.
I was checking all test points with another scope and found something interesting.
Schematic on page 323, Waveforms on page 319. - I will refer to them in my post.

TP 6A and 6B looks fine. (pins 3&5 of U802)
Pin 1 is readout input. Looks like 6A but with lots of garbage. Its shaking also. I think it should looks like 6A
On the output of U802 Pins 12&13 +8,8V's are spot on. However 6D is square with lots of garbage but very low amplitude (many times less than it should be) and 6E is more like square also but higher amplitude than 6D.
6H&6I -58V and -88V. And also like square wave. They Don't even looks like they should.

Any sugestions where to look next rather than changing U802? ( tek234-0401-21)
Also does anybody know where I can get it from along with at127? Maybe some direct replacement's?

Wallace Gasiewicz

Good job finding the problem. Sounds like it is somewhere on that page. I would check the transistors with an ohmeter as they are, in place. That may show you something. Another thing to do would be to replace U 801, I did not look it up but it seem to be an op amp. Maybe it is the problem.? Anyway, something to try. Replace C 819, if you have not done that already. That cap and the op amp would make the ramps on the traces for 6D and 6 E.


Thanks Wallydoc.
I will check it tomorrow.
I checked only q809& q810 and resistors around. They seems good.
U801 is some kind of feedback and logically if it is bad it is pulling everything down. I overlooked that.
Many thanks. :-)


I made some photos of traces.
V/div and time base like in service manual.
6A: https://photos.app.goo.gl/3JPDuHeFoFpadMsQA
6B: https://photos.app.goo.gl/Qw58roiYCzeScTVQ7
When I go from A sweep to B sweep I see this:
Trace is on left half of screen.(that was from time I get the scope)
When I turn sec/div 1 position ccw i get this:
6B then is: https://photos.app.goo.gl/nkmv5ZFTY3fGdKAP9
Turn sec/div back one position cw I get this:
6B Looks this: https://photos.app.goo.gl/JAdj8BHENuPWcrm26
I think that is not a normal behaviour.

6C: https://photos.app.goo.gl/zTbj4Fm3LGL17TYu7
6D: https://photos.app.goo.gl/UNecEuXAGtQXzjSR7
6E: https://photos.app.goo.gl/yiykE79w3CnfjKah9
6F: https://photos.app.goo.gl/4Z1engjbXPfp5hzM8
6G: https://photos.app.goo.gl/RjmTHAermev4fa9r6
6H: https://photos.app.goo.gl/XJtnovY3V2vqp9TV7
6I: https://photos.app.goo.gl/NaW8gZc32HAAKFuX8

Scope behaves like this (previous video was before recap):

I am wondering why holdoff is influenciing traces the way they cuts, and also readouts flickers more or less with different position of holdoff. Also scale ilumination has influence on overall flicker.
Other thing I noticed: There should be grid with dots all over crt when readout is turned on (seen on others video). Here they are present but they are jumping/floating around from left to right very quick.

Other thing is Pin1 of U 802 is Readout horizontal input and looks like this:

Output of U801A Pin1 is:

I am wondering if there is some timing issue, considering strange behavior in b sweep and no stable matrix of dots with readout. Maybe it is influencing also a sweep and overall performance. Where to look for it?
As I said, I am noob in scope reapirs, trying to learn from people who are much better than me. This is for my personal use. Any help like "look in baseline stabilizer" or similar will be apreciated.
Many can say buy a working scope. There are two things: Money (good scopes cost a lot) and It is nice to use equipement that you have reapired yourself.:-)

Also scope behaves very odd when it is cold. It must run for 5 minutes and is operational as on video in this post. For first 5 minutes uncal are blinking, brightness of crt varies. and eventualy it gets as bright as it shold be. There are random brights up during first 5 minutes.


For any who is curious of resuts, topic is continuated here: https://www.eevblog.com/forum/repair/tektronix-2246-flickering-screen-ch2-not-working/

At this moment, ch2 is fixed. Stil troubleshooting flicker.


Usually slight waveform flicker seen on these scopes (2245, 46, 47A, 52) is normal as the display is multiplexed.


I know.
Hovewer on this one it is many times worse, as on others that I have seen and compared to. Something is not right for sure. I have paused with repair for now, because I am waiting for parts to finally fix this not working channel (they will arrive tommorrow) Then I will go again and check everything. For now i suspect DAC's for readout (U2412&U2413). I have no Vref on pins 14,but on other side of R2413&R2415 I have + 2,5V,


After swapping tlc271 all channels are working fine. So this issue can be called fixed.


I just found more proper service manual for my scope. There are some minor differences between scope and schematics (no RO jitter adj) - other else looks exactly the same. Processor board matches. Also there are some differences in schematic 7 compared to previous SM (z axis, ctrl mux) that matches my scope.


From now, I suggest to reffer to this new SM.

Anyone have any hints and clues where to search for fault? I went through schematics many times, tested and I think i went into some kind of loop. Need some fresh look on this problem. If someone have knowledge, and will be kind enough to look into schematics in posted SM and give me some hint i will be greatfull. I think problem might be in digital part of scope - As those "blankings and jitter looks digital to me, not analog - but maybe I am wrong. On the EEVblog forum (link obove) there are many measurements done.


After taking some break in troubleshooting this scope, I got back to it.

After analysing service manual I got to the point that sth is messed up with clock/timing.

I think this is corelated with visible retrace.

Checked clock signal around U2409, U2508, U2507 - all seems fine. I am little concern about timer reset signal (+1VDC, no ac - only 8Mhz ripple from main clock - I don't know how it should look like), and INTR signal - also only dc no ac.

Today I made small experiment and dissconnected RO BLANK (R2419). Readouts are much brighter, grid dot is fully present, readouts are less blurry and more stable.
On Video I am connecting and dissconneting R2419.


That is why I am almost certain that there is some timing/interrupt/clock issue in this scope. It blanks when it shouldn't,

Can anybody give a hint what to check next? How to address this problem?

Jon Harrison-Hughes


Did you find a solution to the blanking issue? I think I have a scope with the same problem.