485 Power Supply Problems


I am trying to bring a 485 scope back to life and I've been trying to find a problem in the scope power supply. When turning on the scope, I get the dreaded "clicking". However, it will power up occasionally. When it is working, all voltages are dead on, and I get a trace on the CRT. I've checked the resistance of all the supplies and see no indications of shorted caps. If I look at TP1951 (BAL) with another scope, I see about a 700mV pulse during the startup time. If I ground TP1951 while the scope is trying to come up (clicking), it will usually start up, and again, all the voltages are correct. I can then remove the jumper, and the scope continues to run fine. I've followed Reed Dickinson's excellent checklist without finding any problems. I've noted that the -5V and -9V supplies seem to be slow in coming up when the scope is in clicking mode. (The fact that the Balance Node is going positive is an indication that a negative supply could be out.) In fact, they never get close to their correct values during the startup period. I've checked the tantalum caps in their regulator outputs and they are ok. I've also looked at the current sense (pin 13) of U1910 at it is staying below 0.5V. I've also tried swapping out U2072 and U2086, with no change noted.

I'm hoping someone here could give me some ideas of what to look for next.
Howard Neal

Kevin Oconnor

Surprised no response yet. This is likely one of the common ps faults in the interlock system. Many years since I worked on one, but shorted tantalum caps are often the cause. Search the archives, as this has been discussed before.