Topics

2430A oscilloscope error code 4000

Gary Robert Bosworth
 

I have a Tek 2430A oscilloscope. Upon boot-up, it gives me an error code 4000 which is for the Front Panel. It says to check in the Service Manual for the cause, but the Service Manual does not give a reason for this error. I suspect that this error is common, and I wonder if any other users have seen this before and know what causes it. If I press Menu Off, and then press Auto Setup, then the scope functions perfect in every way and is completely usable. It is interesting to note that this model never had a backup battery, and there is a bus wire soldered in its place from the factory.

Dewey Wyatt
 

The 4430a has a battery in side the dallas  ram chip. If it goes out you loose all the cal info stored there. Then its recal time with a new chip. I made a backup once it was recalibrated and now mine are in zif sockets.

Sent from Mail ( https://go.microsoft.com/fwlink/?LinkId=550986 ) for Windows 10

*From:* Gary Robert Bosworth ( @grbosworth )
*Sent:* Saturday, March 14, 2020 10:02 PM
*To:* TekScopes@groups.io
*Subject:* [TekScopes] 2430A oscilloscope error code 4000

I have a Tek 2430A oscilloscope.  Upon boot-up, it gives me an error code 4000 which is for the Front Panel.  It says to check in the Service Manual for the cause, but the Service Manual does not give a reason for this error.  I suspect that this error is common, and I wonder if any other users have seen this before and know what causes it.  If I press Menu Off, and then press Auto Setup, then the scope functions perfect in every way and is completely usable.  It is interesting to note that this model never had a backup battery, and there is a bus wire soldered in its place from the factory.

( http://www.avg.com/email-signature?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=emailclient ) Virus-free. www.avg.com ( http://www.avg.com/email-signature?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=emailclient )

( #DAB4FAD8-2DD7-40BB-A1B8-4E2AA1F9FDF2 )

Dewey Wyatt
 

When you get the code 4000 what is passing and what is failing?Below the
code it throughs you get a pass and fail on error checks.

On Sat, Mar 14, 2020, 10:02 PM Gary Robert Bosworth <@grbosworth>
wrote:

I have a Tek 2430A oscilloscope. Upon boot-up, it gives me an error code
4000 which is for the Front Panel. It says to check in the Service Manual
for the cause, but the Service Manual does not give a reason for this
error. I suspect that this error is common, and I wonder if any other
users have seen this before and know what causes it. If I press Menu Off,
and then press Auto Setup, then the scope functions perfect in every way
and is completely usable. It is interesting to note that this model never
had a backup battery, and there is a bus wire soldered in its place from
the factory.



Szabolcs Szigeti
 

Hi,

There was a change sometime, when Tek changed from external battery to
internal, built into the nvram.
It is actully quite easy to patch en external battery into it. See my
earlier post on this: https://groups.io/g/TekScopes/message/136993

Szabolcs

Gary Robert Bosworth <@grbosworth> ezt írta (időpont: 2020. márc.
15., Vas 3:02):

I have a Tek 2430A oscilloscope. Upon boot-up, it gives me an error code
4000 which is for the Front Panel. It says to check in the Service Manual
for the cause, but the Service Manual does not give a reason for this
error. I suspect that this error is common, and I wonder if any other
users have seen this before and know what causes it. If I press Menu Off,
and then press Auto Setup, then the scope functions perfect in every way
and is completely usable. It is interesting to note that this model never
had a backup battery, and there is a bus wire soldered in its place from
the factory.