Date   

Re: Persuading a 7S12 to play nice with a 7934.

Albert Otten
 

Hi Richard,
W.r.t. to your final question: Which manual are you using? In my paper manual (rev. March 1984) the labels Q690 and Q694 at <7> are wrong (interchanged). The internet pdf (Rev. March 1985) is correct and also shows P600 for interdot enable/disable. Albert


Re: 2230 PSU Replacement Component Choices

alastair.knights@...
 

Hi Bert,

Thanks for supplying your experience. Yes, I may be going overboard, but the long repair stories on the EEV Blog bring out the preventative engineer in me!

The RIFAs capacitors in my input filter already have cracks (are will be replaced), and an open-circuit focus chain resistor was the original fault when I got the scope.

Thanks again,

Alastair


Re: 2230 PSU Replacement Component Choices

Bert Haskins
 

On 3/24/2021 12:18 PM, alastair.knights@gmail.com wrote:
I’d be grateful for comments on my component choices below, which are for an upgrade of my 2230 PSU as per Tek’s Product Modification 060-2239-03 (‘Q935…Q9070 Replacement’). Although my scope works, I’m wary given some of the cautionary tales told in this group and the early SMPS design concepts used and improved on by Tek over the years.

The Tek modification involves replacing most of the critical semiconductors in the pre-regulator, crowbar and inverter, so correct component choice is vital. Your comments and the reasons behind the advice would be welcome. NB In the UK the mains can be up to 245Vac, which affects component voltage ratings in the pre-regulator.

Circuit Ref, ‘Tek description’, originally specified (as fitted in italics) part, my suggested replacement, followed by my reasons for selection:

Q935, ‘Thyristor, SCR 8A, 200V sens gate, TO-220’, C10682X283 (GE C10682), ST Micro TS820-600T – An old GE datasheet for the C106 series lists the ‘On’ condition with 1mA of gate current and the TS820-600T has Ig and Vg as 0.2mA and 0.8V respectively, together with higher voltage and current ratings. NB R935 will shunt the first 6mA of any leakage in VR935 and CR948 before Vg reaches 0.8V.
Ref. - https://www.st.com/resource/en/datasheet/ts820.pdf

Q946 and Q947, ‘Transistor NPN, 50V, 150mA, 200mW, inverter’, SJE389, On Semi MJE15032G – The manual shows 80Vp-p swings at Q947c and the later TIP31C fitted was rated at 100V and 3A. The MJE1503G is rated at 250V for extra margin and has a greater SOR (safe operating area) than the TIP31C (some obvious replacements don’t). The hFE is a bit higher at 100 rather than 40 for the TIP31C but as close as I could find while having the higher voltage and SOR rating. It’s not obvious how or if a higher hFE would affect operation of the inverter and I can’t model it, hence my caution. Ft is higher at 30MHz but hopefully that won’t be a problem.
Ref. - https://www.onsemi.com/pdf/datasheet/mje15032-d.pdf

Q9070, ‘MOSFET, N-channel, TO-220’, STP3000 (Motorola 8630), Toshiba TK10E60W – The Toshiba TK10E60W has higher voltage and current ratings, while keeping the Rds On, gate capacitance and gate charge below that of the IRF730 Tek suggest as a replacement. The gate threshold voltage is within range and modelling in LTSpice suggests it should work well.
Ref. - https://toshiba.semicon-storage.com/info/docget.jsp?did=13500&prodName=TK10E60W

VR935, ‘Zener, 51V, 5%’, SZG35009K7 (1N978B), Nexperia BZX79-C51, 143 - It is not obvious why the original is being replaced, but the mod sheet says all listed components should be replaced. A low power 500mW Zener is indicated to ensure that the full 51V develops when a few mA passes through it. My PSU already has a 1N978B fitted, so I’m strongly tempted to leave it in, given that it shouldn’t be under stress and the available replacements don’t appear to offer an advantage in performance or reliability.
Ref. - https://assets.nexperia.com/documents/data-sheet/BZX79.pdf

CR907 (and CR906), ‘Rectifier diode, silicon, 400V, 1.5A, 50ns’, DSR3400X (BDY73), Vishay MUR460 – The Tek modification sheet recommends 2 x BYD73G in parallel, which makes sense given their rating. LTSpice modelling shows currents of around 1.7A ave and 1.8A rms in CR907. I have a single BDY73G fitted which sounds unhealthy, so the MUR460 looks better with its 4A and 600V ratings, together with a short 50ns recovery time.
Ref. - https://www.vishay.com/docs/88686/mur440-e3.pdf

Finally, I’m reluctantly replacing all the electrolytics in the PSU for safety. While the existing capacitors all read okay in terms of value, leakage and ESR, I’d rather not take the risk given the early nature of the design and known component stress in places. I’m also replacing C907 (1uF non-polarised) as modelling shows that this takes a lot of punishment – 1.2A during the ‘on’ period with 245Vac mains – and failure would break a lot of expensive parts!

Everything else is being kept original. I also have a parts list for Mouser is this is of use to anyone.

Sorry for the long post and thanks in advance for your comments.

Alastair Knights
Hi Alastair
FWIW
I have 2221A 2230, 2232 2235 versions 0f the 22 series Teks.
The only PS failure in any of these has been the line input filter, three so far and counting.
These scopes have only been used on US power.

The only other chronic problem that I've had with these is the focus resistors.


In the past I have had many! PS problems in the 2213, 2215, and the 'A' versions of these models.

YMMV.

Bert


Re: 485 super weak brightness control

Ondrej Pavelka
 

I did lot of measurements and there are two steps where the gate timing
goes wrong. These are associated with relay. I am trying to find some
relays to buy but the guy in the UK I used before now brexited and doesn't
deliver to EU. I hope I can persuade him.

Sadly I forgot them at the workshop so it'll have to wait until tomorrow.

I measured A sweep A Gate B sweep B gate

In the long times all the A sweep A gate and B gate are exactly the same
length and correct but there is no B sweep at all.

As the things go to the ns range the zeroed B offset starts to show so it's
slightly delayed but more importantly the B sweep at one point doubles on
its amplitude and starts having a flat top (saturation) from then on its
hard to tell how long the sweep is but generally speaking its similar to A
sweep but gate is much shorter.

I'm wondering if its best to wait for the relays and continue
troubleshooting after that it if there is something we can tackle in the
meantime while I source needed parts

All the best
Ondrej

On Wed, 24 Mar 2021, 02:07 Ozan, <ozan_g@erdogan.us> wrote:



Tomorrow I'm going to make a table with gate times both A and B at each
setting.

I observed today the gate width was same as 1ns on 10ns and 100ns, there
must be some logical explanation for that?
Can't think of an easy explanation. When you are making the table could
you also mark down both A gate width and B gate width while you are
measuring B sweep timing? Also please observe if you really see a fast
sweep when gate is shorter than expected or if the gate is cut short. If
you apply a signal you can tell from the screen whether sweep is complete
but fast or if it is truncated.

Ozan







Re: S-1 transient response problems

Ed Breya
 

I looked up the part and see there is no C-V curve, only the max C at 0 bias. So, that's the max C to expect. What you don't know then is what the actual C will be when biased up properly - it must be less than that, but who knows how much. So, you won't be able to paper-compare the various combinations without more spec info, or possibly testing the parts, which may be difficult without the right facilities. It may be possible to find some app notes or such on these diode types or families, that include more info.

I also looked at the S-1 manual, and the sampler diodes are described as a GaAs matched pair, with no C or other info to go by. The new diodes are Si Schottkys, and likely already have higher Vf than the original parts, so using series pairs would push the bias conditions even further from the original design. Do you have any more info about the original parts, or still have them?

So, I still think the most straightforward approach boils down to figuring a way to hook it up with single diodes. From the series pair SOT picture, it looks like a thin wire tacked over to jump out one diode in each should be doable, if the parts are accessible. Also, which end of R13 limits out for sure - the hot end or the ground end? It could be that the diode C is too small rather than too large compared to the original parts. It may be worth a close look at the circuit layout to be sure which direction the pot actually goes, and whether the blow-by compensation needs more or less gain. Is the tilt rising or falling at the limit?

Ed


Re: Recapping the 535 HV (was Re: 535A HV issue)

Dave Wise
 

UPDATE 20210324: Murata DHR series is EOL, Vishay 615R150GATD10 is ~ $5, and the Russian surplus has dried up.

SUGGESTED PART NUMBERS
Nominal specs from 545
In stock at Mouser

There is about 22mm vertical space between the baseplate and the tubes.
Box film caps fit just fine provided the three lower-voltage
parts are skinny so you can stack them.

Grid/Feedback/Cathode: 6.8nF 3kV, use 10nF 3kV box film, Wima MKP1W021005B00JSSD $0.89 6x15x27mm
If you allow 2kV, you can use Kemet F463DB103K2K0Z, R76UN2100SE30J or R76UI182050H4J,
or Epcos/TDK B32672L8682 or B32672L8822, or Nichicon PPB2201680KGL.

Tripler 1: 6.8nF 5kV, use 10nF 6kV box film, Wima FKP1Y021006F00KYSD $1.83 15x26x32mm
Or 10nF 6kV Z5U ceramic, Vishay 564R60GAS10, $5.86 ouch

Tripler 2/3: 470pF 10kV, use 1nF 15kV Z5U ceramic, Vishay/Roederstein HVCC153Y6P102MEAX $2.44 8x15mm


PLACEMENT/ASSEMBLY
Between the two rows of ceramic strips except as noted.

On the left, place Grid flat with leads facing left.
On top of Grid, place Feedback with leads facing right.
Place the feedback resistor string to the right of Feedback.
On top of Feedback, place Cathode flat with leads facing right.
At the lower right, place T1 flat with leads facing left.
At the upper right, hang T3 vertically against the strips.
Below the lower right strips, hang T2 at an angle, head down/leads up,
avoiding the ground lug and straddling the filament wires.

Dave Wise
Not a Component Engineer but I like playing one


Persuading a 7S12 to play nice with a 7934.

Richard Steedman
 

I've encountered a rather annoying issue when trying to use my 7S12 in tandem with other vertical and horizonal plugins in a 7934 mainframe. The dot blanking signal which drives the mainframe Z axis is leaking out of the 7S12 during those times when it shouldn't be driving the display.

I've posted some pictures here to illustrate the problem. The 7S12 is in the middle two slots of the mainframe (obviously) and the other two slots are occupied by a 7A26 and a 7B92A. When the ALT horizontal mode is selected, everything is fine but when CHOP or LEFT horizontal mode is selected, the 7A26's trace intensity is modulated by the dot-blanking signal of the 7S12. The 7S12's Q694 is not shutting off the dot-blanking signal completely.

(In case you're wondering, the top trace is looking at the trigger out of a S-54 pulse generator in the 7S12. The trace is too dim and the pulse too narrow to be seen. The fact that the 7A26/7B92A are triggering off this pulse (which is generated by the 7S12 to align with its sweep) is the reason why the Z-axis modulation of the top trace is stationary.)

I've also posted some shots of the Z-axis signal in the ALT and LEFT horizontal mode. I've traced three signals: The top trace is the Sweep Out provided on the front panel of the 7S12. The middle trace is the Z-axis voltage. The bottom trace is the 7934's "Display Right" signal which drives pin B7 (MF chan switch) on the edge connectors of the vertical plug-ins. Photo Z-blanking_Alt.jpg shows the dot blanking being shut off nicely when it is the left slot's turn to drive the display (just before the 7S12's sweep flies back). Photo Z-blanking_Alt_Mag.jpg shows the same thing with the Z-axis signal magified to 20mV/div. The Z-axis is at 10mV when the left vertical plug-in is active. Photo Z-blanking_Left.jpg shows what happens when LEFT vertical mode is selected on the mainframe. The 7S12's dot blanking output leak through Q694, swinging from 10mV to 30mV.

I've taken a look at the voltage at the base of Q694 and it swings nicely between 0 and 5V in ALT mode but oscillates between 4V and 5V in LEFT mode. Why a steady low voltage (-0.4V) coming in on the B7 input to the 7S12 (together with 0V on A16) should be causing the 4V/5V at the base of Q694 is a mystery. I can make the issue go away by strengthening the pull-up resistor R693 (reducing it from 15kΩ to 6kΩ). See photo 7934_Horiz_Chop_fixed.jpg. I'm wondering, however, whether there is an issue with the circuit driving the B7 control (i.e. Q4382 and Q4382 on the mainframe's logic board)? I've yet to try probing around there.


Re: S-1 transient response problems

 

Thanks! Feel free to keep sharing your knowledge ;) I have never played with varactors so that C-V curve didn't even occur to me... so what happens to the junction capacitance under forward bias?

But the data sheet does not show a curve- the only entry is:
Total Capacitance (Ct ) Vr = 0 V, F = 1 MHz, 1.2 pF max.

That leads me to believe that my 0.6 pF conjecture is not so far off, if the capacitance is maximum at 0 (as you said, and where the data sheet figure was measured). I'll take a closer look when I get a chance, and revisit the strobe adjustments too. Possibly I adjusted it into a corner where everything is working except the transient response?


Re: S-1 transient response problems

Ed Breya
 

Charles, the reverse-biased capacitance of two diodes in series is not necessarily one-half of the nominal C (from the spec) of either one. The capacitance is nonlinear, and is maximum near zero bias. So, putting two in series not only changes the DC bridge voltage and balance and strobe requirement, but may also (counter-intuitively) actually increase the capacitance. There's not all that much reverse bias on the bridge in the first place, so the diodes operate possibly in the steep part of the C-V curve. Since you are using a known part that hopefully has specs available, check the C-V curves in the data sheet, and estimate the C you would get for one diode only, from the actual bias conditions on the bridge. Now consider how much C each diode would have at half the voltage, assuming they each share the total reverse bias equally, if you have two in series. Then divide that C by two for the series C estimate for the pair. Depending on the curves, you may find one diode is better than two. Ideally, you want the bias to land it in the flatter part of the C-V curve, where the C is low, and fairly constant. This is optimized at the maximum possible reverse, but of course, that means more strobe is needed. It's all in the trade-offs. Also note that all the adjustments tend to interact, and the diode C-V characteristic is a big part.

The easiest thing conceptually, is to just go back to single diodes and see what happens, where the system was intended to operate. Yes, I understand it may be physically difficult to make the mod, but consider that you may end up doing it anyway, after studying the situation.

Ed


Re: Recapping Tektronix 2465

iv3ddm
 

I had already considered the option of Condor Audio a few months ago, when looking directly at the site, the cost was lower than the current offer but we know that the cost of living goes up continuously.

But I also need other parts for other jobs, which alone would not justify the € 20 shipping cost from Mouser. In this way I exceed 50 € of goods and the shipping is free.

I am retired, sure that for those who do not want to waste some time, Yachad's offer is interesting.

Giorgio


Re: Type 106

Stephen
 

I « didn’t » pay attention...


Re: Type 106

Stephen
 

On Wed, Mar 24, 2021 at 05:30 AM, Albert Otten wrote:

The earth pin is screwed to the mounting plate, which is chassis GND. Or did
you install that pin?
Albert
Good catch Albert! I did pay enough attention.
Thanks for correcting me.


Re: Repairing broken pots

Paul Amaranth
 

Pricing info would be interesting. They say no minimum order and 2 week lead time on custom assemblies.

On Wed, Mar 24, 2021 at 09:19:55AM -0700, Jim Adney wrote:
The current owner of the Allen-Bradley mod pot line is State Electronics in East Hanover, NJ. I found their design guide pdf file to the mod pot line and just uploaded it to the files section.

--
Paul Amaranth, GCIH | Manchester MI, USA
Aurora Group of Michigan, LLC | Security, Systems & Software
paul@AuroraGrp.Com | Unix/Linux - We don't do windows


Re: Type 106

Albert Otten
 

On Wed, Mar 24, 2021 at 03:40 PM, Stephen wrote:


Also, although the plug is a 3-prong, no earth connection is made inside.
The earth pin is screwed to the mounting plate, which is chassis GND. Or did you install that pin?
Albert


Re: Repairing broken pots

Jim Adney
 

The current owner of the Allen-Bradley mod pot line is State Electronics in East Hanover, NJ. I found their design guide pdf file to the mod pot line and just uploaded it to the files section.


2230 PSU Replacement Component Choices

alastair.knights@...
 

I’d be grateful for comments on my component choices below, which are for an upgrade of my 2230 PSU as per Tek’s Product Modification 060-2239-03 (‘Q935…Q9070 Replacement’). Although my scope works, I’m wary given some of the cautionary tales told in this group and the early SMPS design concepts used and improved on by Tek over the years.

The Tek modification involves replacing most of the critical semiconductors in the pre-regulator, crowbar and inverter, so correct component choice is vital. Your comments and the reasons behind the advice would be welcome. NB In the UK the mains can be up to 245Vac, which affects component voltage ratings in the pre-regulator.

Circuit Ref, ‘Tek description’, originally specified (as fitted in italics) part, my suggested replacement, followed by my reasons for selection:

Q935, ‘Thyristor, SCR 8A, 200V sens gate, TO-220’, C10682X283 (GE C10682), ST Micro TS820-600T – An old GE datasheet for the C106 series lists the ‘On’ condition with 1mA of gate current and the TS820-600T has Ig and Vg as 0.2mA and 0.8V respectively, together with higher voltage and current ratings. NB R935 will shunt the first 6mA of any leakage in VR935 and CR948 before Vg reaches 0.8V.
Ref. - https://www.st.com/resource/en/datasheet/ts820.pdf

Q946 and Q947, ‘Transistor NPN, 50V, 150mA, 200mW, inverter’, SJE389, On Semi MJE15032G – The manual shows 80Vp-p swings at Q947c and the later TIP31C fitted was rated at 100V and 3A. The MJE1503G is rated at 250V for extra margin and has a greater SOR (safe operating area) than the TIP31C (some obvious replacements don’t). The hFE is a bit higher at 100 rather than 40 for the TIP31C but as close as I could find while having the higher voltage and SOR rating. It’s not obvious how or if a higher hFE would affect operation of the inverter and I can’t model it, hence my caution. Ft is higher at 30MHz but hopefully that won’t be a problem.
Ref. - https://www.onsemi.com/pdf/datasheet/mje15032-d.pdf

Q9070, ‘MOSFET, N-channel, TO-220’, STP3000 (Motorola 8630), Toshiba TK10E60W – The Toshiba TK10E60W has higher voltage and current ratings, while keeping the Rds On, gate capacitance and gate charge below that of the IRF730 Tek suggest as a replacement. The gate threshold voltage is within range and modelling in LTSpice suggests it should work well.
Ref. - https://toshiba.semicon-storage.com/info/docget.jsp?did=13500&prodName=TK10E60W

VR935, ‘Zener, 51V, 5%’, SZG35009K7 (1N978B), Nexperia BZX79-C51, 143 - It is not obvious why the original is being replaced, but the mod sheet says all listed components should be replaced. A low power 500mW Zener is indicated to ensure that the full 51V develops when a few mA passes through it. My PSU already has a 1N978B fitted, so I’m strongly tempted to leave it in, given that it shouldn’t be under stress and the available replacements don’t appear to offer an advantage in performance or reliability.
Ref. - https://assets.nexperia.com/documents/data-sheet/BZX79.pdf

CR907 (and CR906), ‘Rectifier diode, silicon, 400V, 1.5A, 50ns’, DSR3400X (BDY73), Vishay MUR460 – The Tek modification sheet recommends 2 x BYD73G in parallel, which makes sense given their rating. LTSpice modelling shows currents of around 1.7A ave and 1.8A rms in CR907. I have a single BDY73G fitted which sounds unhealthy, so the MUR460 looks better with its 4A and 600V ratings, together with a short 50ns recovery time.
Ref. - https://www.vishay.com/docs/88686/mur440-e3.pdf

Finally, I’m reluctantly replacing all the electrolytics in the PSU for safety. While the existing capacitors all read okay in terms of value, leakage and ESR, I’d rather not take the risk given the early nature of the design and known component stress in places. I’m also replacing C907 (1uF non-polarised) as modelling shows that this takes a lot of punishment – 1.2A during the ‘on’ period with 245Vac mains – and failure would break a lot of expensive parts!

Everything else is being kept original. I also have a parts list for Mouser is this is of use to anyone.

Sorry for the long post and thanks in advance for your comments.

Alastair Knights


Re: Repairing broken pots

Jim Adney
 

I recently went thru hell fixing a 4-module Allen-Bradley mod pot in an HP counter. I ended up repairing some fractured plastic with epoxy and moto-tooling it to final shape. It took me weeks to get a workable unit again. In the meantime, I tracked down the current owner of the Allen-Bradley mod pot line, but they weren't interested in selling me just the pushbutton momentary switch module I needed. They made it clear that whatever I needed would have to be replaced in whole and would cost an arm and a leg.

The Allen-Bradley mod pots are black, and I understand that the Bourns are blue.

So, did Bourns duplicate the Allen-Bradley line, so that this might be a second source for those pots?


Re: Recapping Tektronix 2465

Jim Adney
 

On Wed, Mar 24, 2021 at 02:06 AM, M Yachad wrote:

I do have kits available, which I custom assemble, to suit your EXACT machine.
I'll need CLEAR photos of your A1 A2 A3 A4 A5 A9 A14 PCB's

Saves you the time and hassle of sorting and sourcing, and wondering if you
made the correct choices.

Here's the ebay ad
https://www.ebay.com/itm/252865418970

Forum members who buy via my contact directly here (NOT via ebay), get a 15%
discount.
That's a VERY well thought-out, well-written ebay ad. Anyone here who's trying to recap one of those scopes should just take advantage of the 15% discount for TekScopes members and buy one of these kits directly.

One question: The caps in the grey and red rectangular boxes, I thought those were film caps. Why would they need to be replaced? Do those have a history of failint? I have some boards from the '60s with Wima film caps like those. Those Wima caps are al still good.

Or did Tek use something less reliable than Wima?


Re: Type 106

Stephen
 

New pictures available for those interested in my modest restoration of this unit.
You’ll notice that this units, unlike some that I’ve seen, doesn’t have a fixed line cord.
Probably intended for export so different models can be used. Also has a switchable voltage switch 115-220V.
Also, although the plug is a 3-prong, no earth connection is made inside.
I’ve installed a piece of old Fender amp grill cloth in place of the decayed filter, in front of the fan.
It has worked very well for me on other projects (RTM506 for example), and I know it will not decay anytime soon.

New pictures here:
https://groups.io/g/TekScopes/album?id=261997&p=Created,,,50,2,0,0


Re: Type 106

Stephen
 

Spelling errors as well. Sorry for my terrible iPhone... 🙃😬🙃

4141 - 4160 of 184722