Date   

Re: Tektronix 7D13 and 7A42 wanted

John Gord
 

Tom,
I also had a summer job that included making a 1702 EPROM programmer. I resorted to using at least one genuine electromechanical relay to switch the HV.
(Carver Mead was my undergraduate advisor and had received some 1702 via former students at Intel.)
--John Gord

On Tue, Nov 17, 2020 at 06:40 PM, Tom Lee wrote:


Yes, thanks to Moore's law, life is quite different, for engineers and
everyone else.

One of my earliest college summer jobs was building a programmer for
1702 EPROMs. I thought I was being set up for a newhire hazing gag --
negative 48 volts on address and data lines?? Surely that had to be a
joke. But that was what it took to program those mighty bits.

Tom

--
Prof. Thomas H. Lee
Allen Ctr., Rm. 205
350 Jane Stanford Way
Stanford University
Stanford, CA 94305-4070
http://www-smirc.stanford.edu

On 11/17/2020 18:33, Stephen Bell wrote:
EEPROM type devices were around at the time but they were quite difficult to
use. Some required -30V supplies, had awkward logic levels and were
incredibly slow.

The performance and ease of use of modern non-volatile memory devices is
incredible when you look back at what was available to designers back in the
80's.





Re: Tektronix 7D13 and 7A42 wanted

 

DM5010 was the worst POS Tek ever made because of the calibration constants. Once the battery dies and the constants go POOF there is no way to calibrate it again. I worked on four of them and never got one of them to accept constants because of dead batteries.
On the other hand the way the front end was optically isolated from the rest of the plugin was very sophisticated. They passed the measurements to the rest of the plugin serially through an optical LED phototransistor pair if I remember correctly. That meant total isolation up to 1KV at least.

-----Original Message-----
From: TekScopes@groups.io [mailto:TekScopes@groups.io] On Behalf Of Harvey White
Sent: Tuesday, November 17, 2020 5:56 PM
To: TekScopes@groups.io
Subject: Re: [TekScopes] Tektronix 7D13 and 7A42 wanted

Suspect anything TM5000 or anything that has a microprocessor. For anything from that period where Tek decided to keep some calibration constants (do NOT ask about the DM5010), you're likely to have some batteries keeping RAM alive. EEPROM hadn't necessarily happened yet.

Harvey


On 11/17/2020 8:48 PM, Dave Daniel wrote:
I just did the same - pulled out my 7A42, removed the cover and found that the battery has leaked down to the PCB terminals. I guess I’ll have to clear some bench space and get things cleaned up.

I wonder how many other olugins have “surprise” batteries.

DaveD

On Nov 17, 2020, at 20:30, Dennis Tillman W7pF <dennis@ridesoft.com> wrote:

Hi Ed,
YIKES! Thanks for that very important heads up. I have gotten so used to everything automatically remembering settings that I never thought this had a battery in it. Mine too has corrosion. Fortunately it hasn't gone past the battery tabs and where they are soldered to the PC board.

I'm pretty pissed about this. Tek engineers SHOULD HAVE ANTICIPATED THIS and put these batteries into a sacrificial plastic battery holder with leads that went to the PC board so worse case the battery and the holder would contain the corrosion. The leads running between the battery holder and the PC board would block any corrosion getting to the PCB. That way if you ever found any damage you would replace the battery holder and the leads at the same time whenever there was any sign of corrosion.

One final thing Tek SHOULD HAVE DONE is put a warning label on the side cover which indicated in bold letters there was a battery underneath this spot. This label would have a place to indicate the date the battery was installed, the date the battery should be replaced and several blank date fields and voltage fields so service people could note the date the battery was last checked visually and note the voltage measured at that time.

If there was anyone at Tek that still cared I would call them and let them know how annoyed I am by this.

Ed, you need to be careful when you repair the damage. The corrosion can act on your soldering iron and gradually eat into the tip. Whenever I have to fix corrosion I always use a tip I can spare just in case it starts to get eaten up afterwards.

Dennis Tillman W7pF

-----Original Message-----
From: TekScopes@groups.io [mailto:TekScopes@groups.io] On Behalf Of
Ed Breya via groups.io
Sent: Tuesday, November 17, 2020 4:14 PM
To: TekScopes@groups.io
Subject: Re: [TekScopes] Tektronix 7D13 and 7A42 wanted

Tangential to this short discussion - thanks for talking about it, Sparky and Dennis. When Dennis mentioned the 7A42 is very rare, I remembered that I have one I picked up years ago. When I first got it, I looked at it briefly, and it seemed to work just fine, and it's pretty cool with four channels of 350 MHz capability. But, since it's mostly for logic signal use, not general purpose, I set it aside for some time when needed for logic - especially high speed ECL stuff..

This recent talk led me to think about it, and I studied tekwiki and the manuals to see what's so special and rare about it. It is quite a machine, with a helluva lot going on in there. Then I noticed the references to the built in backup battery. Uh-oh. I didn't know there was a battery in there. Sure enough, the original battery is there, and both leads and their board pads are badly corroded after sitting for decades. I will begin surgery soon to get it out and clean everything up, and hopefully no further damage has occurred. This plug-in is one of my best ones, cosmetically-speaking. It looks brand new, pristine outside and inside (except the battery stuff) - there's not even any cal or ID stickers added anywhere. I'd of course like to keep it working and looking good, and hope it's not too late to easily take care of the problem. I don't plan to put in a new battery, unless some day I end up using it a lot and want it to recall setups.

Ed







--
Dennis Tillman W7pF
TekScopes Moderator













--
Dennis Tillman W7pF
TekScopes Moderator


Re: Tektronix 7D13 and 7A42 wanted

Stephen Hanselman
 

If it’s a three battery pack in our area we go to batteries+ and pick up a three cell portable phone battery. Then solder the leads to existing wires and use double sided sticky tape. Works fine.

Regards,

Stephen Hanselman
Datagate Systems, LLC

On Nov 17, 2020, at 21:03, Jim Ford <james.ford@cox.net> wrote:

Speaking of NiCads in HP gear, I just closed up my 8350B sweep oscillator after replacing a slightly melted power inlet and the suspect Rifa cap soldered to it. I remembered somebody on the HPAK group mentioning NiCads in that very model, so I poked around and found them against the wall of the plug-in compartment with a pop-off lid. Pretty easy to check, certainly a lot easier than soldering and unsoldering 12 wires connecting to the power inlet with no service loop to speak of!
No leaks in my NiCads, but the voltage read really low. Still keeps its front panel settings, even when disconnecting the AC power cable. I'll write up the full repair on HP-Agilent-Keysight-equipment@groups.io.

And a couple years ago I designed a breakout box at work. It needed 2 AA batteries inside for powering a keep-alive interface. So I put 2 tip jacks on the box so that the keep-alive battery voltage could be measured with DMM probes without opening the box, which was secured with 4 screws. Well, the guys using the box gave me crap about using tip jacks instead of banana jacks so they could hook up a bench power supply. Well, you could always remove the tip jacks and replace them with banana jacks, after drilling the holes out a bit, I told them. You could do the same on your instrument, if you don't mind the aesthetics.

Jim Ford

------ Original Message ------
From: "Stephen Bell" <s.r.bell@snap.net.nz>
To: TekScopes@groups.io
Sent: 11/17/2020 6:54:00 PM
Subject: Re: [TekScopes] Tektronix 7D13 and 7A42 wanted

Dennis,

I fully agree with your comments that the battery leakage problem should have been anticipated by the design engineers.

Not only should they have put warning labels on the equipment they should have also provided an easy way to check the battery voltage. I check the batteries in my equipment on an annual basis but this usually involves considerable effort removing covers to get access. It would be so much easier if the design engineers had the forethought to provide easily accessible battery test points on the rear panel, or better still, provided a function whereby the battery status could be indicated from the front panel.

While you are complaining to Tek about their poor design decisions perhaps you could also complain to HP. In my opinion they were far worse with the widespread use of leaky NiCd batteries in their equipment.

Stephen Bell









Re: Tektronix 7D13 and 7A42 wanted

Jim Ford
 

Speaking of NiCads in HP gear, I just closed up my 8350B sweep oscillator after replacing a slightly melted power inlet and the suspect Rifa cap soldered to it. I remembered somebody on the HPAK group mentioning NiCads in that very model, so I poked around and found them against the wall of the plug-in compartment with a pop-off lid. Pretty easy to check, certainly a lot easier than soldering and unsoldering 12 wires connecting to the power inlet with no service loop to speak of!
No leaks in my NiCads, but the voltage read really low. Still keeps its front panel settings, even when disconnecting the AC power cable. I'll write up the full repair on HP-Agilent-Keysight-equipment@groups.io.

And a couple years ago I designed a breakout box at work. It needed 2 AA batteries inside for powering a keep-alive interface. So I put 2 tip jacks on the box so that the keep-alive battery voltage could be measured with DMM probes without opening the box, which was secured with 4 screws. Well, the guys using the box gave me crap about using tip jacks instead of banana jacks so they could hook up a bench power supply. Well, you could always remove the tip jacks and replace them with banana jacks, after drilling the holes out a bit, I told them. You could do the same on your instrument, if you don't mind the aesthetics.

Jim Ford

------ Original Message ------
From: "Stephen Bell" <s.r.bell@snap.net.nz>
To: TekScopes@groups.io
Sent: 11/17/2020 6:54:00 PM
Subject: Re: [TekScopes] Tektronix 7D13 and 7A42 wanted

Dennis,

I fully agree with your comments that the battery leakage problem should have been anticipated by the design engineers.

Not only should they have put warning labels on the equipment they should have also provided an easy way to check the battery voltage. I check the batteries in my equipment on an annual basis but this usually involves considerable effort removing covers to get access. It would be so much easier if the design engineers had the forethought to provide easily accessible battery test points on the rear panel, or better still, provided a function whereby the battery status could be indicated from the front panel.

While you are complaining to Tek about their poor design decisions perhaps you could also complain to HP. In my opinion they were far worse with the widespread use of leaky NiCd batteries in their equipment.

Stephen Bell





Re: Tektronix 7D13 and 7A42 wanted

Ed Breya
 

Well, it's back in business so far, and appears to be OK. It has been burning in since last I spoke here. I may let it go overnight, but I dislike wasting mainframe CRT life (even turned down, it still uses up the heater) while cooking plug-ins for long times.

I also rediscovered why I shelved it before - it's a PITA to use and set up, if your eyesight isn't what it used to be. I'd need a magnifier or much stronger glasses to read all the panel labels, and also remember the syntax. It is still cool though, if you're needing to look at logic signals, but forget about it for general purpose use. Another thing is that the three range settings in each (TTL/ECL) mode aren't that useful for direct input - it's really geared for 10X probes, whether 1 meg for TTL/CMOS, or 500 ohms for ECL. I like that P6320 probe for ECL, with offsetting capability, but I suppose those are hard to find, and expensive, too. When you work in ECL though, a probe isn't that big a deal, since you can usually add tap-offs and test points for 50 ohm cable anyway, including DC offsetting.

So anyway, I think I'm done for now. Also, I see I'm not the only one who didn't know there's a battery in these puppies. Good luck to all of you with fixing them back up.

Ed


Re: Tektronix 7D13 and 7A42 wanted

Stephen Bell
 

Dennis,

I fully agree with your comments that the battery leakage problem should have been anticipated by the design engineers.

Not only should they have put warning labels on the equipment they should have also provided an easy way to check the battery voltage. I check the batteries in my equipment on an annual basis but this usually involves considerable effort removing covers to get access. It would be so much easier if the design engineers had the forethought to provide easily accessible battery test points on the rear panel, or better still, provided a function whereby the battery status could be indicated from the front panel.

While you are complaining to Tek about their poor design decisions perhaps you could also complain to HP. In my opinion they were far worse with the widespread use of leaky NiCd batteries in their equipment.

Stephen Bell


Re: Tektronix 7D13 and 7A42 wanted

Tom Lee
 

Yes, thanks to Moore's law, life is quite different, for engineers and everyone else.

One of my earliest college summer jobs was building a programmer for 1702 EPROMs. I thought I was being set up for a newhire hazing gag --
negative 48 volts on address and data lines?? Surely that had to be a joke. But that was what it took to program those mighty bits.

Tom

--
Prof. Thomas H. Lee
Allen Ctr., Rm. 205
350 Jane Stanford Way
Stanford University
Stanford, CA 94305-4070
http://www-smirc.stanford.edu

On 11/17/2020 18:33, Stephen Bell wrote:
EEPROM type devices were around at the time but they were quite difficult to use. Some required -30V supplies, had awkward logic levels and were incredibly slow.

The performance and ease of use of modern non-volatile memory devices is incredible when you look back at what was available to designers back in the 80's.




Re: Tektronix 7D13 and 7A42 wanted

Stephen Bell
 

EEPROM type devices were around at the time but they were quite difficult to use. Some required -30V supplies, had awkward logic levels and were incredibly slow.

The performance and ease of use of modern non-volatile memory devices is incredible when you look back at what was available to designers back in the 80's.


Re: Tektronix 7D13 and 7A42 wanted

Harvey White
 

On 11/17/2020 8:29 PM, Ed Breya via groups.io wrote:
Harvey, it's not a logic analyzer except in a rudimentary sense. It's a scope, so you can see what the analog waveform that represents a digital signal actually looks like in time domain. Of course, you sometimes need this when the digital doesn't quite work as expected. I haven't needed it yet, even though I've built a lot of ECL stuff since, that worked just fine. I picture it being useful more in the design of interfacing in ECL/RF circuits, rather than logic fault diagnosis. It's nice to have, just in case.
It's a plugin with "logical" triggering, and variable thresholds.  Then four channels.  Yep, not a logic analyzer, I use one of those whenever I need to look at a reasonably complex digital stream.  Sadly, most logic analyzers of that era don't do well at decoding serial streams.

Let alone a tektronix plugin.



Speaking of which, I just finished battery removal and cleanup. The electrolyte had traveled quite a way, and gotten through to the other side of the board. It's ugly in the affected areas from Cu-blue and corrosion textures on parts and runs, but does not appear to have rotted anything open or shorted. It's drying now and will be fired up shortly. My main worry is that since this looks to be a four-layer board, some vias to the inner layers could rot out - difficult to locate and fix. The electrolyte clearly managed to leak right through some of them.
Not sure about that.  It varies per board and damage, of course. Mine worked well enough with about 15 jumpers, and led me to the relay problems in the front end.  Haven't fixed that yet.

Harvey


Ed





Re: Tektronix 7D13 and 7A42 wanted

Harvey White
 

Suspect anything TM5000 or anything that has a microprocessor. For anything from that period where Tek decided to keep some calibration constants (do NOT ask about the DM5010), you're likely to have some batteries keeping RAM alive.  EEPROM hadn't necessarily happened yet.

Harvey

On 11/17/2020 8:48 PM, Dave Daniel wrote:
I just did the same - pulled out my 7A42, removed the cover and found that the battery has leaked down to the PCB terminals. I guess I’ll have to clear some bench space and get things cleaned up.

I wonder how many other olugins have “surprise” batteries.

DaveD

On Nov 17, 2020, at 20:30, Dennis Tillman W7pF <dennis@ridesoft.com> wrote:

Hi Ed,
YIKES! Thanks for that very important heads up. I have gotten so used to everything automatically remembering settings that I never thought this had a battery in it. Mine too has corrosion. Fortunately it hasn't gone past the battery tabs and where they are soldered to the PC board.

I'm pretty pissed about this. Tek engineers SHOULD HAVE ANTICIPATED THIS and put these batteries into a sacrificial plastic battery holder with leads that went to the PC board so worse case the battery and the holder would contain the corrosion. The leads running between the battery holder and the PC board would block any corrosion getting to the PCB. That way if you ever found any damage you would replace the battery holder and the leads at the same time whenever there was any sign of corrosion.

One final thing Tek SHOULD HAVE DONE is put a warning label on the side cover which indicated in bold letters there was a battery underneath this spot. This label would have a place to indicate the date the battery was installed, the date the battery should be replaced and several blank date fields and voltage fields so service people could note the date the battery was last checked visually and note the voltage measured at that time.

If there was anyone at Tek that still cared I would call them and let them know how annoyed I am by this.

Ed, you need to be careful when you repair the damage. The corrosion can act on your soldering iron and gradually eat into the tip. Whenever I have to fix corrosion I always use a tip I can spare just in case it starts to get eaten up afterwards.

Dennis Tillman W7pF

-----Original Message-----
From: TekScopes@groups.io [mailto:TekScopes@groups.io] On Behalf Of Ed Breya via groups.io
Sent: Tuesday, November 17, 2020 4:14 PM
To: TekScopes@groups.io
Subject: Re: [TekScopes] Tektronix 7D13 and 7A42 wanted

Tangential to this short discussion - thanks for talking about it, Sparky and Dennis. When Dennis mentioned the 7A42 is very rare, I remembered that I have one I picked up years ago. When I first got it, I looked at it briefly, and it seemed to work just fine, and it's pretty cool with four channels of 350 MHz capability. But, since it's mostly for logic signal use, not general purpose, I set it aside for some time when needed for logic - especially high speed ECL stuff..

This recent talk led me to think about it, and I studied tekwiki and the manuals to see what's so special and rare about it. It is quite a machine, with a helluva lot going on in there. Then I noticed the references to the built in backup battery. Uh-oh. I didn't know there was a battery in there. Sure enough, the original battery is there, and both leads and their board pads are badly corroded after sitting for decades. I will begin surgery soon to get it out and clean everything up, and hopefully no further damage has occurred. This plug-in is one of my best ones, cosmetically-speaking. It looks brand new, pristine outside and inside (except the battery stuff) - there's not even any cal or ID stickers added anywhere. I'd of course like to keep it working and looking good, and hope it's not too late to easily take care of the problem. I don't plan to put in a new battery, unless some day I end up using it a lot and want it to recall setups.

Ed







--
Dennis Tillman W7pF
TekScopes Moderator







Re: Tektronix 7D13 and 7A42 wanted

Tom Lee
 

I agree COMPLETELY with you, Dennis. I have encountered far too many pieces of gear that were ruined by battery leakage. Leaky electrolytic caps are bad enough, but leaking batteries are a whole 'nuther level of bad.

Tom

--
Prof. Thomas H. Lee
Allen Ctr., Rm. 205
350 Jane Stanford Way
Stanford University
Stanford, CA 94305-4070
http://www-smirc.stanford.edu

On 11/17/2020 17:30, Dennis Tillman W7pF wrote:
Hi Ed,
YIKES! Thanks for that very important heads up. I have gotten so used to everything automatically remembering settings that I never thought this had a battery in it. Mine too has corrosion. Fortunately it hasn't gone past the battery tabs and where they are soldered to the PC board.

I'm pretty pissed about this. Tek engineers SHOULD HAVE ANTICIPATED THIS and put these batteries into a sacrificial plastic battery holder with leads that went to the PC board so worse case the battery and the holder would contain the corrosion. The leads running between the battery holder and the PC board would block any corrosion getting to the PCB. That way if you ever found any damage you would replace the battery holder and the leads at the same time whenever there was any sign of corrosion.

One final thing Tek SHOULD HAVE DONE is put a warning label on the side cover which indicated in bold letters there was a battery underneath this spot. This label would have a place to indicate the date the battery was installed, the date the battery should be replaced and several blank date fields and voltage fields so service people could note the date the battery was last checked visually and note the voltage measured at that time.

If there was anyone at Tek that still cared I would call them and let them know how annoyed I am by this.

Ed, you need to be careful when you repair the damage. The corrosion can act on your soldering iron and gradually eat into the tip. Whenever I have to fix corrosion I always use a tip I can spare just in case it starts to get eaten up afterwards.

Dennis Tillman W7pF

-----Original Message-----
From: TekScopes@groups.io [mailto:TekScopes@groups.io] On Behalf Of Ed Breya via groups.io
Sent: Tuesday, November 17, 2020 4:14 PM
To: TekScopes@groups.io
Subject: Re: [TekScopes] Tektronix 7D13 and 7A42 wanted

Tangential to this short discussion - thanks for talking about it, Sparky and Dennis. When Dennis mentioned the 7A42 is very rare, I remembered that I have one I picked up years ago. When I first got it, I looked at it briefly, and it seemed to work just fine, and it's pretty cool with four channels of 350 MHz capability. But, since it's mostly for logic signal use, not general purpose, I set it aside for some time when needed for logic - especially high speed ECL stuff..

This recent talk led me to think about it, and I studied tekwiki and the manuals to see what's so special and rare about it. It is quite a machine, with a helluva lot going on in there. Then I noticed the references to the built in backup battery. Uh-oh. I didn't know there was a battery in there. Sure enough, the original battery is there, and both leads and their board pads are badly corroded after sitting for decades. I will begin surgery soon to get it out and clean everything up, and hopefully no further damage has occurred. This plug-in is one of my best ones, cosmetically-speaking. It looks brand new, pristine outside and inside (except the battery stuff) - there's not even any cal or ID stickers added anywhere. I'd of course like to keep it working and looking good, and hope it's not too late to easily take care of the problem. I don't plan to put in a new battery, unless some day I end up using it a lot and want it to recall setups.

Ed







Re: Tektronix 7D13 and 7A42 wanted

 

Now that I got my 7A42 out I am looking at it for the first time in several years.
What caught my eye immediately was the Input PC Board. It appears to contain a lot of the types of components Tek was using in their 11K scopes. It is definitely not 7K generation.

As far as I know this is the only plugin that is compatible with ECL and TTL input levels. So 350MHz is more than adequate for testing these logic families.
The 7A42 is also one of only a few plugins with selectable 1Meg Ohm and 50 Ohm input impedance. The other 1M / 50 Ohm plugins are the 7A16P (the P stands for Programmable), 7D14 512MHz Frequency Counter, and the 7L5 with the L3 Impedance Matching insert.

On a personal note I think the 7A42 is the most beautiful plugin Tek made, especially as it goes through its power up sequence. It could be easily confused for a small Christmas tree as all the LEDs light up in some elaborate sequence as Red, Yellow, and/or Green

Dennis Tillman W7pF



--
Dennis Tillman W7pF
TekScopes Moderator


Re: Tektronix 7D13 and 7A42 wanted

Dave Daniel
 

I just did the same - pulled out my 7A42, removed the cover and found that the battery has leaked down to the PCB terminals. I guess I’ll have to clear some bench space and get things cleaned up.

I wonder how many other olugins have “surprise” batteries.

DaveD

On Nov 17, 2020, at 20:30, Dennis Tillman W7pF <dennis@ridesoft.com> wrote:

Hi Ed,
YIKES! Thanks for that very important heads up. I have gotten so used to everything automatically remembering settings that I never thought this had a battery in it. Mine too has corrosion. Fortunately it hasn't gone past the battery tabs and where they are soldered to the PC board.

I'm pretty pissed about this. Tek engineers SHOULD HAVE ANTICIPATED THIS and put these batteries into a sacrificial plastic battery holder with leads that went to the PC board so worse case the battery and the holder would contain the corrosion. The leads running between the battery holder and the PC board would block any corrosion getting to the PCB. That way if you ever found any damage you would replace the battery holder and the leads at the same time whenever there was any sign of corrosion.

One final thing Tek SHOULD HAVE DONE is put a warning label on the side cover which indicated in bold letters there was a battery underneath this spot. This label would have a place to indicate the date the battery was installed, the date the battery should be replaced and several blank date fields and voltage fields so service people could note the date the battery was last checked visually and note the voltage measured at that time.

If there was anyone at Tek that still cared I would call them and let them know how annoyed I am by this.

Ed, you need to be careful when you repair the damage. The corrosion can act on your soldering iron and gradually eat into the tip. Whenever I have to fix corrosion I always use a tip I can spare just in case it starts to get eaten up afterwards.

Dennis Tillman W7pF

-----Original Message-----
From: TekScopes@groups.io [mailto:TekScopes@groups.io] On Behalf Of Ed Breya via groups.io
Sent: Tuesday, November 17, 2020 4:14 PM
To: TekScopes@groups.io
Subject: Re: [TekScopes] Tektronix 7D13 and 7A42 wanted

Tangential to this short discussion - thanks for talking about it, Sparky and Dennis. When Dennis mentioned the 7A42 is very rare, I remembered that I have one I picked up years ago. When I first got it, I looked at it briefly, and it seemed to work just fine, and it's pretty cool with four channels of 350 MHz capability. But, since it's mostly for logic signal use, not general purpose, I set it aside for some time when needed for logic - especially high speed ECL stuff..

This recent talk led me to think about it, and I studied tekwiki and the manuals to see what's so special and rare about it. It is quite a machine, with a helluva lot going on in there. Then I noticed the references to the built in backup battery. Uh-oh. I didn't know there was a battery in there. Sure enough, the original battery is there, and both leads and their board pads are badly corroded after sitting for decades. I will begin surgery soon to get it out and clean everything up, and hopefully no further damage has occurred. This plug-in is one of my best ones, cosmetically-speaking. It looks brand new, pristine outside and inside (except the battery stuff) - there's not even any cal or ID stickers added anywhere. I'd of course like to keep it working and looking good, and hope it's not too late to easily take care of the problem. I don't plan to put in a new battery, unless some day I end up using it a lot and want it to recall setups.

Ed







--
Dennis Tillman W7pF
TekScopes Moderator





Re: Tektronix 7D13 and 7A42 wanted

 

Hi Ed,
YIKES! Thanks for that very important heads up. I have gotten so used to everything automatically remembering settings that I never thought this had a battery in it. Mine too has corrosion. Fortunately it hasn't gone past the battery tabs and where they are soldered to the PC board.

I'm pretty pissed about this. Tek engineers SHOULD HAVE ANTICIPATED THIS and put these batteries into a sacrificial plastic battery holder with leads that went to the PC board so worse case the battery and the holder would contain the corrosion. The leads running between the battery holder and the PC board would block any corrosion getting to the PCB. That way if you ever found any damage you would replace the battery holder and the leads at the same time whenever there was any sign of corrosion.

One final thing Tek SHOULD HAVE DONE is put a warning label on the side cover which indicated in bold letters there was a battery underneath this spot. This label would have a place to indicate the date the battery was installed, the date the battery should be replaced and several blank date fields and voltage fields so service people could note the date the battery was last checked visually and note the voltage measured at that time.

If there was anyone at Tek that still cared I would call them and let them know how annoyed I am by this.

Ed, you need to be careful when you repair the damage. The corrosion can act on your soldering iron and gradually eat into the tip. Whenever I have to fix corrosion I always use a tip I can spare just in case it starts to get eaten up afterwards.

Dennis Tillman W7pF

-----Original Message-----
From: TekScopes@groups.io [mailto:TekScopes@groups.io] On Behalf Of Ed Breya via groups.io
Sent: Tuesday, November 17, 2020 4:14 PM
To: TekScopes@groups.io
Subject: Re: [TekScopes] Tektronix 7D13 and 7A42 wanted

Tangential to this short discussion - thanks for talking about it, Sparky and Dennis. When Dennis mentioned the 7A42 is very rare, I remembered that I have one I picked up years ago. When I first got it, I looked at it briefly, and it seemed to work just fine, and it's pretty cool with four channels of 350 MHz capability. But, since it's mostly for logic signal use, not general purpose, I set it aside for some time when needed for logic - especially high speed ECL stuff..

This recent talk led me to think about it, and I studied tekwiki and the manuals to see what's so special and rare about it. It is quite a machine, with a helluva lot going on in there. Then I noticed the references to the built in backup battery. Uh-oh. I didn't know there was a battery in there. Sure enough, the original battery is there, and both leads and their board pads are badly corroded after sitting for decades. I will begin surgery soon to get it out and clean everything up, and hopefully no further damage has occurred. This plug-in is one of my best ones, cosmetically-speaking. It looks brand new, pristine outside and inside (except the battery stuff) - there's not even any cal or ID stickers added anywhere. I'd of course like to keep it working and looking good, and hope it's not too late to easily take care of the problem. I don't plan to put in a new battery, unless some day I end up using it a lot and want it to recall setups.

Ed







--
Dennis Tillman W7pF
TekScopes Moderator


Re: Tektronix 7D13 and 7A42 wanted

Ed Breya
 

Harvey, it's not a logic analyzer except in a rudimentary sense. It's a scope, so you can see what the analog waveform that represents a digital signal actually looks like in time domain. Of course, you sometimes need this when the digital doesn't quite work as expected. I haven't needed it yet, even though I've built a lot of ECL stuff since, that worked just fine. I picture it being useful more in the design of interfacing in ECL/RF circuits, rather than logic fault diagnosis. It's nice to have, just in case.

Speaking of which, I just finished battery removal and cleanup. The electrolyte had traveled quite a way, and gotten through to the other side of the board. It's ugly in the affected areas from Cu-blue and corrosion textures on parts and runs, but does not appear to have rotted anything open or shorted. It's drying now and will be fired up shortly. My main worry is that since this looks to be a four-layer board, some vias to the inner layers could rot out - difficult to locate and fix. The electrolyte clearly managed to leak right through some of them.

Ed


Re: EZ Test for 4041

Monty McGraw
 

Gary,

I got your three tapes, removed the belts and plastic parts and put them in
my dehydrator at 135F.
Thursday I will remove them from the dehydrator and begin testing them this
weekend.

One thing I noticed, two of the tape reels showed the tapes were dropped
and the edge of the reels were up to the top of the case :(

I pushed gently on the high edge to roughly center the tapes on the reels
before putting them in the dehydrator.

I did not dehydrate those tapes before sending them to you - I'm hoping
everything will be fine after they bake for two days.

I plan to install new belts on all three tapes.

Monty

Monty

On Mon, Nov 9, 2020 at 12:33 PM Gary Robert Bosworth <grbosworth@gmail.com>
wrote:

Monty: I have 3 tapes that have gone bad. I don't understand why they
went bad. My tape drive seems to be running smooth. I will be happy to
send the failed tapes to you to see what you can do with them. Please send
me your snail mail address so I can get these in the mail as soon as
possible. Thanx.

Gary Bosworth
grbosworth@gmail.com


On Sun, Nov 8, 2020 at 2:54 PM Monty McGraw <mmcgraw74@gmail.com> wrote:

Gary,

I would like to try recovering the files on your EZ-Test tape if you
still
have it.

Monty





--
Gary Robert Bosworth
grbosworth@gmail.com
Tel: 310-317-2247






Re: Tektronix 7D13 and 7A42 wanted

Harvey White
 

I had one in similar condition.  The battery ate a number of traces.  (this was several years ago).  After restoring the traces (CPU to MEMORY, IIRC), the plugin booted, but I still have faults related to relays (IIRC, I haven't played with it in a bit).  It would work well, but it is surpassed by any decent logic analyzer.

Harvey

On 11/17/2020 7:14 PM, Ed Breya via groups.io wrote:
Tangential to this short discussion - thanks for talking about it, Sparky and Dennis. When Dennis mentioned the 7A42 is very rare, I remembered that I have one I picked up years ago. When I first got it, I looked at it briefly, and it seemed to work just fine, and it's pretty cool with four channels of 350 MHz capability. But, since it's mostly for logic signal use, not general purpose, I set it aside for some time when needed for logic - especially high speed ECL stuff..

This recent talk led me to think about it, and I studied tekwiki and the manuals to see what's so special and rare about it. It is quite a machine, with a helluva lot going on in there. Then I noticed the references to the built in backup battery. Uh-oh. I didn't know there was a battery in there. Sure enough, the original battery is there, and both leads and their board pads are badly corroded after sitting for decades. I will begin surgery soon to get it out and clean everything up, and hopefully no further damage has occurred. This plug-in is one of my best ones, cosmetically-speaking. It looks brand new, pristine outside and inside (except the battery stuff) - there's not even any cal or ID stickers added anywhere. I'd of course like to keep it working and looking good, and hope it's not too late to easily take care of the problem. I don't plan to put in a new battery, unless some day I end up using it a lot and want it to recall setups.

Ed





Re: Tektronix 7D13 and 7A42 wanted

Ed Breya
 

Tangential to this short discussion - thanks for talking about it, Sparky and Dennis. When Dennis mentioned the 7A42 is very rare, I remembered that I have one I picked up years ago. When I first got it, I looked at it briefly, and it seemed to work just fine, and it's pretty cool with four channels of 350 MHz capability. But, since it's mostly for logic signal use, not general purpose, I set it aside for some time when needed for logic - especially high speed ECL stuff..

This recent talk led me to think about it, and I studied tekwiki and the manuals to see what's so special and rare about it. It is quite a machine, with a helluva lot going on in there. Then I noticed the references to the built in backup battery. Uh-oh. I didn't know there was a battery in there. Sure enough, the original battery is there, and both leads and their board pads are badly corroded after sitting for decades. I will begin surgery soon to get it out and clean everything up, and hopefully no further damage has occurred. This plug-in is one of my best ones, cosmetically-speaking. It looks brand new, pristine outside and inside (except the battery stuff) - there's not even any cal or ID stickers added anywhere. I'd of course like to keep it working and looking good, and hope it's not too late to easily take care of the problem. I don't plan to put in a new battery, unless some day I end up using it a lot and want it to recall setups.

Ed


Re: 7L5 Res shaft encoder

Jean-Paul
 

Nenad, exactly the same symptoms, as mine has. Slightly touching the knob in 1,2,5 K res will make the 100k 200k 500k fault disappear momentarily. All other resolutions are fine.

Any TEK Spectrum Analyzer veterans out there who can assist?

Many thanks


Jon


Re: 7L5 Res shaft encoder

Nenad Filipovic
 

Today I attempted disassembly of my Resolution/Freq. Span knob and got halfway there, photos (album name "7L5 Knob Repair Attempt"):
https://groups.io/g/TekScopes/album?id=256833&p=Name,,,20,1,0,0

The resolution section of the switch is mechanical, no challenge to disassemble and easy to restore. The span section appears to feature an optical encoder, and I could not find a non-destructive way to open it up. I'm currently stuck at the third photo in the album, the white plastic base of the frequency span knob still holds tight even if the two screws are removed. The metal L shaped insert? (circled in red on the photo) appears glued to the central shaft and won't budge. Wonder if that's by design, or somebody had glued it on purpose after attempted repair? I'm suspicious as I discovered two of the span knob pins heavily bent during inept assembly, and I doubt it came like that from Tek.

Straightening the pins, tightening the sockets and cleaning everything did not make much improvement. Bit marked TJ on the schematic is persistently acting up, even the lightest touch of the span knob makes it jump from 500k->5k, 200k->2k... etc.At this point I'm out of ideas.

Best regards,
Nenad

11641 - 11660 of 184812