Re: 2235 with 360 kHz 100mV P-P ringing on +100V PSU rail [1 Attachment]


Vaugha Brewchuk
 

Hello Tom,

Thank you for your quick response! Yes, I replaced C940, but the closest I could source was a 1200uF Nichicon PW, which in the worst case scenario could fall outside of the maximum specified tolerance of 1000uF + 30%. Mind you, I had to do pretty much the same for most of the other capacitors, except all the other replacements fall within the original tolerance bands: C954 47uF vs. 33uF; C956 390uF vs. 270uF; C960 etc. 1200uF vs. 840uF; C942 & C943 15uF vs. 10uF.

I also have at the ready a United Chemi-Con 100uF, 400V (could not source 450V) KXG series capacitor, so I can easily replace C906. I got a bit of a cold feet syndrome since the KXG is 1/4 the size of the Sprague cap, and I also read elsewhere that the Sprague telephone grade caps last "forever". I found that last bit hard to believe mind you, since it is an electrolytic after all. I could not find the ripple current rating of the Sprague capacitor, but I'm guessing that the KXG will work just fine. Maybe I should jus go ahead and replace C906?

I was wondering whether replacing the original 0.01uF 3000V caps with polypropylene could have disrupted the power supply somehow? Or perhaps it could be the overall collection of slightly higher than nominal capacitance on all the output filter caps?

I realize that I am shotgunning the whole issue, but I really did not mind replacing all the electrolytics. I have been doing this for most of my other equipment at around 15 to 20 years of use as preventative maintenance. Unfortunately I do not have access to an isolation transformer.

Thank you again,
Vaugha.

--- In TekScopes@..., "Tom Miller" <tmiller@...> wrote:

Hello Vaugha,

I would replace C-906 as it is the main filter for the supply.

You can't really check the ripple on that cap without an isolation transformer.

Did you replace C-940? Without an isolation transformer you are just shotgunning for the main problem.



Tom



----- Original Message -----
From: Vaugha Brewchuk
To: TekScopes@...
Sent: Monday, May 23, 2011 11:05 AM
Subject: [TekScopes] 2235 with 360 kHz 100mV P-P ringing on +100V PSU rail [1 Attachment]



[Attachment(s) from Vaugha Brewchuk included below]

Good day,

This is my first post about my first scope that I purchased recently. I am also not an electronics technician, so please be gentle with me :-).

The scope is in excellent condition and has been recently calibrated. However, when using the scope I noticed occasional small ripples in the traces. I opened the scope and tested the power supplies and determined that the ripple on all the rails was 2 to 3 times larger than the limit quoted in the service manual. Consequently I replaced all electrolytic capacitors in the power supply, except the C906 input filter capacitor, with Nichicon PW series capacitors. I used the exact same capacity components where the originals were +/-20% and the next larger capacity where the originals were -10% to +30, +50 or +100%. I also replaced the four 0.01uF 3000V capacitors with CDE 940C30S1K-F polypropylene capacitors.

Unfortunately the occasional ripples have not completely disappeared after the overhaul even though the traces seem to be a bit sharper. The ripples on all the power supply rails have significantly reduced, with the exception of the +100V rail. Here the actual low frequency ripple seems to be in check at approximately 30mV P-P, but every second ripple peak exhibits damped high frequency ringing at approximately 350 - 360kHz with 100mV P-P amplitude. I attached an image showing the ripple and the ringing on the +100V rail.

Join TekScopes@groups.io to automatically receive all group messages.