Re: Tektronix 7D13 and 7A42 wanted


Tom Lee
 

I agree COMPLETELY with you, Dennis. I have encountered far too many pieces of gear that were ruined by battery leakage. Leaky electrolytic caps are bad enough, but leaking batteries are a whole 'nuther level of bad.

Tom

--
Prof. Thomas H. Lee
Allen Ctr., Rm. 205
350 Jane Stanford Way
Stanford University
Stanford, CA 94305-4070
http://www-smirc.stanford.edu

On 11/17/2020 17:30, Dennis Tillman W7pF wrote:
Hi Ed,
YIKES! Thanks for that very important heads up. I have gotten so used to everything automatically remembering settings that I never thought this had a battery in it. Mine too has corrosion. Fortunately it hasn't gone past the battery tabs and where they are soldered to the PC board.

I'm pretty pissed about this. Tek engineers SHOULD HAVE ANTICIPATED THIS and put these batteries into a sacrificial plastic battery holder with leads that went to the PC board so worse case the battery and the holder would contain the corrosion. The leads running between the battery holder and the PC board would block any corrosion getting to the PCB. That way if you ever found any damage you would replace the battery holder and the leads at the same time whenever there was any sign of corrosion.

One final thing Tek SHOULD HAVE DONE is put a warning label on the side cover which indicated in bold letters there was a battery underneath this spot. This label would have a place to indicate the date the battery was installed, the date the battery should be replaced and several blank date fields and voltage fields so service people could note the date the battery was last checked visually and note the voltage measured at that time.

If there was anyone at Tek that still cared I would call them and let them know how annoyed I am by this.

Ed, you need to be careful when you repair the damage. The corrosion can act on your soldering iron and gradually eat into the tip. Whenever I have to fix corrosion I always use a tip I can spare just in case it starts to get eaten up afterwards.

Dennis Tillman W7pF

-----Original Message-----
From: TekScopes@groups.io [mailto:TekScopes@groups.io] On Behalf Of Ed Breya via groups.io
Sent: Tuesday, November 17, 2020 4:14 PM
To: TekScopes@groups.io
Subject: Re: [TekScopes] Tektronix 7D13 and 7A42 wanted

Tangential to this short discussion - thanks for talking about it, Sparky and Dennis. When Dennis mentioned the 7A42 is very rare, I remembered that I have one I picked up years ago. When I first got it, I looked at it briefly, and it seemed to work just fine, and it's pretty cool with four channels of 350 MHz capability. But, since it's mostly for logic signal use, not general purpose, I set it aside for some time when needed for logic - especially high speed ECL stuff..

This recent talk led me to think about it, and I studied tekwiki and the manuals to see what's so special and rare about it. It is quite a machine, with a helluva lot going on in there. Then I noticed the references to the built in backup battery. Uh-oh. I didn't know there was a battery in there. Sure enough, the original battery is there, and both leads and their board pads are badly corroded after sitting for decades. I will begin surgery soon to get it out and clean everything up, and hopefully no further damage has occurred. This plug-in is one of my best ones, cosmetically-speaking. It looks brand new, pristine outside and inside (except the battery stuff) - there's not even any cal or ID stickers added anywhere. I'd of course like to keep it working and looking good, and hope it's not too late to easily take care of the problem. I don't plan to put in a new battery, unless some day I end up using it a lot and want it to recall setups.

Ed






Join TekScopes@groups.io to automatically receive all group messages.