Re: DC503 Not Working


Glenn Little
 

If the connector in the TM5xx has loss some of its tension and the thickness of the extender paddle is slightly thicker than the DC503 edge card connector, that would explain it.
If this is the case, the connector(s) in the TM5xx need to be replaced.

Glenn

On 8/10/2020 4:20 PM, Stephen wrote:
This is a partial copy of a post a posted while trying the extender work.

Something very unexpected and quite puzzling just happened.
As many pointed out, I forgot to connect pin 6A. I just did.
Some of you may have seen my post regarding the DC503 that is not showing more than 1 digit (0) at any one time, if at all, when I power it on. Never ever.

Now that pin 6A is finally connected, not only the DC503 power on normally with the extender, but all digits are there!!! Not when connected inside the TM506 itself!! It’s not counting anything, though.
Everything is not lost, it gives me hope that at least something is showing now...

It’s also missing some segments. If anyone knows if the individual LED’s can be replaced, that would be nice to know of a modern replacement. I found some, but the panels look too thick, I think.

--
-----------------------------------------------------------------------
Glenn Little ARRL Technical Specialist QCWA LM 28417
Amateur Callsign: WB4UIV wb4uiv@... AMSAT LM 2178
QTH: Goose Creek, SC USA (EM92xx) USSVI LM NRA LM SBE ARRL TAPR
"It is not the class of license that the Amateur holds but the class
of the Amateur that holds the license"

Join TekScopes@groups.io to automatically receive all group messages.