Re: A sick 7603 can it be restored?

Eric
 

I was able to pull apart the power supply and just hit the order button on the parts. Ill be sanity checking the parts but some of the filters are toast. I have some high quality replacements on the way so hopefully this supply will be good for the rest of my time. Ill keep everyone posted as to the progress thanks for the help so far everyone.

Eric

-----Original Message-----
From: TekScopes@groups.io <TekScopes@groups.io> On Behalf Of bobh@...
Sent: Friday, April 3, 2020 7:23 PM
To: TekScopes@groups.io
Subject: Re: [TekScopes] A sick 7603 can it be restored?

If you have a bad filter cap, with high ESR, one thing you can do to prove to yourself that you found the real issue is to parallel the questionable cap with a good one. If the unreg supply and the other supplies come back you found the problem. This was suggested to me when I was in your place and it worked.

Bob.

On 4/3/2020 6:35 AM, Eric wrote:
Well before I do anything else I have to address the capacitor issue.
Got the scope hooked up to the -50V rail and there is 260mV pk-pk of
ripple . It is a nice clean saw tooth generator at the moment. Glad I
had it on the current limited supply. The reading was on the -50V test
point on the regulator board. I guess I am tearing down the power
supply. Spec for the Ripple is only 5mV pk-pk

-----Original Message-----
From: TekScopes@groups.io <TekScopes@groups.io> On Behalf Of
bobh@...
Sent: Friday, April 3, 2020 9:04 AM
To: TekScopes@groups.io
Subject: Re: [TekScopes] A sick 7603 can it be restored?

The -50V supply depends on the +50 unregulated voltage. The 130 V
supply also depends on a good +50 V. You might want to check the caps
C808 and C809 that's where I found a bad cap when troubleshooting mine.

bob.

On 4/2/2020 9:15 AM, Eric wrote:
That is very true. I am going to get it on the bench again tonight I have a sneaking suspicion I have a massive ripple problem given what I saw on the scope last night. I was able to confirm that the plugins will generate a trace on a working 7K frame so that is good. The -50 is the main reference supply for the frame.

What I saw last night was I was getting very now intensity pulses on the z output of the main board. But it looked like they were riding on about 40mV pk-pk of ripple so I am pretty sure that is not supposed to be there. Getting to the bulk caps in these is a nightmare but hey that is where the fun is.

Eric
-----Original Message-----
From: TekScopes@groups.io <TekScopes@groups.io> On Behalf Of
Oz-in-DFW
Sent: Thursday, April 2, 2020 12:05 PM
To: TekScopes@groups.io
Subject: Re: [TekScopes] A sick 7603 can it be restored?

Its been forever since I worked on one. One dim memory I have of these is that all the supplies are interrelated. Anything dragging one down messes up all of the others. They were a pain to troubleshoot.










Join TekScopes@groups.io to automatically receive all group messages.