Re: Tektronix 7904, no horizontal trace on input B

 

Hi Henric,

The first thing I notice in your video is that when you put the time base in the B horizontal slot the 7904 recognizes it is present because it displays the on-screen readout time/div setting on the bottom right part of the CRT. That is a good sign.

The second thing I see is when you press the beam finder with the time base in the B horizontal slot the display you get shows there is no sweep present. You are just getting the vertical signals on the screen without any horizontal sweep.

There could be two reasons for this:
A) The time base is not getting a trigger signal when it is in the B horizontal slot. One test you can perform would be to feed a trigger signal into the external trigger input of the time base while in the B slot to see if this fixes the problem. If it does then that confirms the trigger signal is not getting to the B slot from the vertical amplifiers. That could be caused by a bad front panel B Trigger Source Switch or by the IC that controls the routing of this trigger signal which would be on the backplane PC board. Also on the rear of the 7904 (or maybe even on the front of it) there are several BNC connectors which bring out critical signals like trigger signals. If there is a B Trigger Signal output make sure it is present on the front or rear panel BNC connectors.

B) The time base is being triggered and generating a sweep but the sweep is not getting from the time base to the horizontal amplifier in the mainframe. Once again there are ICs on the back plane that route this sweep signal. The B Sweep signal comes out to one of the front or rear BNC connectors so you should check for it there. If it isn't there and if it isn't on the CRT the IC that switches it thru from the back plane to the horizontal amplifier may not be getting the right switching signal or it may be bad.

The most important thing you can do for your own benefit and to learn how your new scope works is to read the Theory of Operation section of the service manual. It explains everything! For the moment read the parts about how the trigger signal is routed and how the sweep signal is routed to learn the various places they go in the scope and which ICs they go through to get a better idea of exactly where to look for where it is being blocked.

Dennis Tillman W7PF

-----Original Message-----
From: @HermanssonAmplification
Sent: Monday, November 18, 2019 7:06 AM
Subject: [TekScopes] Tektronix 7904, no horizontal trace on input B

I just bought a Tektronix 7904 scope and realized that something is wrong with horizontal input B.
Horizontal input A works fine but I got no trace on input B. If I press “Beam finder” slightly I see dots for each inputs that are activated in the vertical slots and if I press the “Beam finder” harder I see bigger dots. I only see the dots when I press “Beam finder” otherwise the screen is blank when horizontal input B is activated.

Any suggestions where to start? I’ve measured the voltages on the Z axis-PCB but nothing alarming there. Since the horizontal Input A works something might be bad on the “Trigger B”-PCB? Or where should I start?

Here’s a video showing the problem:
https://youtu.be/KuPenOSkyJg

I’ve been exercising the switches and cleaned the input slots for the plugin.
Thank you in advance!

Best regards,
Henric




--
Dennis Tillman W7PF
TekScopes Moderator

Join TekScopes@groups.io to automatically receive all group messages.