Re: 7844 power supply

Peter Gottlieb
 

I looked again and one of the switcher transistors failed again so replaced that. Now back to burst operation.

The switcher shutoff is coming from the control chip. It seems to be triggered by large spikes coming in on the balance input and those seem to be coming from the current sense on the HV side. This might be caused by a shorted HV diode or the multiplier. I am hoping it is not the HV winding as that would likely mean scrapping of this otherwise mint scope, but the indication is promising (at least right now).




Peter

On Nov 18, 2019, at 12:50 AM, Ed Breya via Groups.Io <edbreya=yahoo.com@groups.io> wrote:

´╗┐The last time I fixed a 7844 PS, it was fortunately just two or so rather large (100 or 220 uF 20V) Ta caps shorted, on the pre-regulator supply board, for the +/- 15V inside the PS module - the one inside the cage, just below the outer, upper, linear regulator board. It's a PITA to get to, but doable - if you take enough stuff apart, you can run it while opened up and make measurements. The fix is fairly straightforward, but there's very little space, so you'll have to get creative with alternative cap arrangements. I manged to do all the work from the component side, avoiding having to remove the board, which is even more a PITA.

If it's not those or something else like another Ta cap in the scope circuits, it could be the dreaded HV winding failure on the main transformer. Hope for the lesser grief.

Ed


Join TekScopes@groups.io to automatically receive all group messages.