Re: 2215 problem

tom jobe <tomjobe@...>
 

Thanks Everyone,
I've been enjoying this recent 2215 discussion! I have never owned one but have wondered what they were all about. The early version of the 2215 I had seen used a scary looking power supply, and until the other day I did not realize it had later been improved with basically what was done for the 2215A, 2235, etc. scopes which probably came out slightly after the scopes such as the 2213 and 2215.
I have some of 22xx family of scopes that includes the 2215A and 2235, and have powered the primary side of the power supply with a floating external 43 volts DC using the two test points (TP940 and TP950) several times. I would imagine that you could put in the 43 volts DC at the corresponding test points on the 2215 which appear to be TP940 and TP934. Your 43 volt power supply has to be floating and not tied to chassis or earth  ground in any way. Today I was working on a 2235 and I checked the DC voltage difference between chassis ground and TP950 (the floating 43 volt ground of the 2235) and there was a 68 volt difference! One time I got a bit sloppy and momentarily shorted the chassis ground to the 43 volt floating ground when the scope was running in its normal configuration, and there were some very burnt components as a result.
My guess would be that your chassis ground and 43 volt floating ground will differ by many volts as well.
In reading about the 2215 power supply, I saw some mention of it being a one amp supply so I wonder how well your 0.5 amp supply will work.
On the later scopes such as the 2215A and the 2235, I think it takes something like 1.0 to 1.6 amps of 43 volts to run the power supply using an external 43 volt supply, but maybe the 2215 takes less amps to run.
Let's see what others have to say about all of this before you do anything with your 2215 and the external 43 volt supply.
tom jobe...

On 5/30/2019 9:56 AM, Bob Albert via Groups.Io wrote:
Thanks for your comments on repairing the unit.  I need to keep a clear head on this.  I have some spare IRF820s now but before I install I will see about supplying 43 Volts.  I have a little 0-50V 500 mA supply I can use for that once I see where to connect it.  Any help on that?
I have far too many projects, several units laying around apart and no room to work.  But I do have lots of working gear so there is still a rather complete setup available.  Even the microwave oven in the kitchen needs some attention.  I just replaced the stove top and the garbage disposer and did some yard cleanup and snaked out a couple of drains.
Life is a lot of fun and if I didn't have these repair jobs I would wonder why I have all this gear.  At this point I would like to get at least one unit working again to free up workspace.
Bob
On Thursday, May 30, 2019, 9:19:01 AM PDT, <tekscopegroup@...> wrote:
About 10+ years ago I fixed my first scope, it was a 2213A given to me "on loan" and of course the main problem as in many of these 22xx was it would not power up, just a flash of the power Led about once a second. At the time one could only find online for gratis download the 2213 service manual that does not fully match the A version, specially in regards to the PS section so troubleshooting was tougher from the start. I remember trying to make the preregulator section work, that is what generates the 43V for the actual power supply switcher, and it was frustrating, to say the least, specially if you make simple mistakes you very easily end up burning or blowing up something in that section that was good (Mosfet, resistors, the TIP3x or TIP4x (I think it was) TO-220 transistors, Regulator IC, etc). And as I can remember the preregulator will refuse to start even if perfectly ok without the load provided by the second stage of the power supply. So I used an external power supply to feed the +43V and the scope would still not power up, just the same flicker of the power led. So then I checked all the power supply outputs, rectifier diodes, capacitors, etc. Nothing. Finally since the problem seemed to start pointing towards some other part on the board for which I did not have a replacement, someone in this group (while still at Yahoo) send me a whole 2213A main board  for the cost of shipping, it was partially gutted but it still had most key parts I needed. Turns out in the end the problem was the main switching transformer T948 that apparently had developed a short in one of the secondaries and was causing the whole power supply to shut down at startup.

So before you mess around any further with the preregulator section chasing windmills and possibly causing more damage, I would suggest that your very first step should be to test the second switcher section of the power supply by feeding it around +43V and see if the scope powers up. If it does then you will know for sure the problem is not in the preregulator but somewhere else, and leave it alone until you can get the scope to power up with the external DC supply. Another possibility is that one of the power supply outputs are looking into a short or higher than expected current draw, it could be just a dried out capacitor, leaky or shorted (fast) rectifier diode, or could be it something downstream in the circuits being powered. I recall there are some jumpers that can be removed to insulate  one or more of the power supply outputs at a time from their respective loads, but you need to at least keep a proper load on one of the outputs (I think it is the +8.6V) with a adequate size/value resistor, otherwise things will not be stable and the test will lead you nowhere else but into yet another wrong rabbit hole.

Again, it is amazing how sensitive and temperamental the preregulator is to very simple mistakes specially with all the high power parts, even when you think you just removed or replaced a part only to quickly check if there might be any changes and you are sure it should be perfectly safe there is no way something will go wrong, bum! it will usually blow up that part and/or something else and/or let out the magic smoke. Welcome to switching power supply troubleshooting.

BTW, first thing should be to get an accurate service manual for your version of the scope. That makes a huge difference. And good luck, the 2215 is a nice basic scope well worth fixing.



Join TekScopes@groups.io to automatically receive all group messages.