Re: 2467B Trace flicker


Chuck Harris <cfharris@...>
 

One of the biggest gotcha's for new users of high bandwidth
scopes is noise. They look at it in the fuzziness of the
trace and assume that the scope manufacturer blew the design.
"My 400MHz bandwidth 2465B just isn't as sharp as my 50MHz
547," they say, while muttering to themselves that they just
can't get good quality anymore.

They see noise dancing on the signals they measure, and assume
it is all real and fatally harmful.

Digital circuitry from the 80's and 90's is rife with noise
emitters, as the FCC regulations of such emitters were fairly
new back then. Class A and Class B designations in Part 15 had
just come out in an attempt to recapture the RF spectrum from
digital devices.

Designers for years ignored circuit board layout, and applied
mitigation techniques involving shielded cases, RF gaskets,
filtered power cords, and tons and tons of bypass capacitors
as their principle methods of reducing emissions... Oh, and
mustn't forget ferrite beads and bracelets.

Modern day designers ignore the cases, and use transmission
lines for all signals, local shields over naughty places on
the board, ground planes, controlled rise times, and lower
voltage signaling to mitigate emissions. It is a lot easier
to control noise when you don't make it in the first place.

For a scope measurement to have any sense of fidelity in such
a noise ridden environment, the grounding connection needs to
be right at the probe tip, not 6 inches of wire away from the
probe tip. The grounding wire/clip that newbies commonly use
without a thought, is an excellent antenna for HF signals,
and a very poor "ground" for fast digital signals.

You cannot believe anything you see above about 10MHz on a
2465B scope using the stock probes and their 6 inch ground
wires.

Also, it is normal for 2465B scopes to have intensity
flickering in the main trace at some sweep speeds, display
modes, multiple trace settings, and settings of the
trigger. The display is highly multiplexed, and the beam
intensity is under the control of an overtaxed 6802 MPU.

There is a lot more going on in a 2465 than there is in a 547.

Do the next guy that owns your scope a favor and put away
your soldering iron. If you don't know why a part should be
replaced, you might want to think about it some more.

-Chuck Harris

thespin@gmail.com wrote:

I've sorta scattershot replaced the S/H opamp U2630B and the muxes U2530 and U2501, after testing the surrounding passives. No change. I see no "walking" of the flicker for various sweep speeds.

On Mon, Jan 21, 2019 at 01:02 PM, machineguy59 wrote:


In a previous post you described noise on the DIA signal and high frequency
noise on the DI signal. You have to quiet that noise before any other
intensity measurements can be meaningful. If DIA in noise free you can check
the Z-axis by putting a test scope on The Z-Axis outputs (test points 65 and
66 in the service manual). The Display sequencer and a few other parts CAN
give you screen flicker but they don't put noise on DIA and they usually

Join TekScopes@groups.io to automatically receive all group messages.