Re: Tek 7603 Followed Me Home


Kevin Wood G7BCS
 

If it helps, I had a 7603 fault due to one of those reservoir caps failing
and, when I got round to checking them, most of the caps on that rectifier
board were on their way out, so I changed them all.

That doesn't mean yours will be, of course, and I'm not generally an
advocate of "re-capping" devices en-masse, but my recollection is that it
was not that easy to get to the board and change the caps either, so it
might be a false economy to change just one or two.

Beware that several of those caps have multiple can connections to the
board and, on some, I think they are used as "jumpers" to connect traces
across the board. If replacing with caps of a different form factor, which
will probably be almost inevitable, you might need to insert jumpers
across some of the can connections. Apologies if I'm delivering lessons in
"egg-sucking"!

Kevin
G7BCS

Chuck,

C808 on the -50 v unregulated is the only cap that tests at 0.0 Ohms and
is the only one that doesn't charge up to some value using the cap test
position on my Tek DMM916.

I ordered some replacement caps although I am not sure whether to
ultimately replace all the cans in the back section.  I may use two
1000ufd 100v caps to replace the 1800 ufd 75 volt C808 on the -50
unreg.  In this case the can is connected to the -50 unregulated rather
than ground so I need to tie all those loose ends together.

I'll hit up the local electronic surplus tomorrow to see if I can find a
replacement cap for testing while waiting for the ones I ordered.

Bob.

Join TekScopes@groups.io to automatically receive all group messages.