TDS540B Power On Self Test Pass, but changing results from SPC


satbeginner
 

Hello all,

today I received an eBay (sold as is) TDS540B.
It would not power on, but that turned out to be a dirty Standby switch, also the front bezel was slightly dislocated towards the front, so the rubber of the switch could not touch the flexible circuit behind it.

The good news, after cleaning and repositioning the front it does power on and passes the Power On Selftest!
More good news: I seem to have newer boards in this machine, because there are hardly any SMD caps to be found, only a few, and these are all spotless clean, there is no sign of leakage whatsoever.

The bad news, although all 4 channels do respond to (calibration) input signals, some of them give intermittent wrong V/div readings, and these change when changing the input attenuator setting.
Sometimes at 50mV/div a channel would show a 1 div calibration signal, but when changing to 20mV/div it shows 3 div. (should be 2 1/2 div)

And sometimes when set at 5mV/div it will show the same as when set on 10mV/div, both 5 div, as if the attenuator does not change?
At the moment I am not sure, but Ch4 seems to work better then Ch1 and Ch2 and Ch3.
I can trigger the scope on all 4 channels.

When I run the SPC it does give errors like this:

Internal adjustment range ex (2@ 7012) 1.4650 ==> Balance DAC #3 (ID #146)
Internal adjustment range ex (1@ 7111) 1.1386 ==> Balance DAC #2 (ID #145)
Error: insufficient differential response (3@ 7493) 0.000 divs differential
Error: insufficient differential response (0@ 7493) 0.000 divs differential
Error: Characterized values out of b Ch3 trigger gain
Error: Characterized values out of b Ch3 trigger gain
Error:2260 Calibration Failed triggers

But: running the SPC again, or after a reboot, it might throw errors like:
Error: diagnostic test failure DDataL stuck Hi, Demux is 198
and some more.

But at power On the selftest is always Pass.

I read something about the attenuators being/getting iffy, or at least the contact sheets in between the ceramic attenuators and the PCB.
I downloaded every piece of documentation I could find from Häkan's site and everywhere else, but I did not yet find info about how to clean the attenuator contact sheets.

Any tips about how to clean these?
Any tips in general?

May thanks, un saludo,

Leo

Join TekScopes@groups.io to automatically receive all group messages.