SG502 Schematic, Component Layout


Jeff Davis
 

I apologize for the somewhat off topic question, but this group seems to be the nexus of Tektronix knowledge in general, not just oscilloscopes. I'm attempting to troubleshoot the square wave output of an SG502 sine wave generator plug in, but I'm having trouble correlating the schematic and board component layout from the manuals I have with what's actually in front of me on the board.


I have two copies of the manual, and in both, the component layout is Rev C, Nov 1976 and the schematic is Rev D, Nov 1976. The most obvious disconnect is that on the physical board I see two ICs in the lower left corner of the board, while the layout shows only one - plus lots of other differences in the details. Another disconnect is that the physical board has a 600 ohm, 1% resistor in series with the square wave output, while the schematics show it as parallelled to ground.


The date on the circuit board is around 1971 or so (don't have the board handy to look at as I write this). No serial number that I can find anywhere on the unit itself.


Now, I don't REALLY need the square wave output to work. But my OCD is driving me to fix it anyway. Would sure appreciate anyone who might have another version of the schematic / component layout or some ideas of how I might proceed.


By the way, the actual problem is that the high side of the square wave is rounded and exceeds the 5v open circuit value by a volt or two. Perhaps a bad diode? Would be a lot easier to troubleshoot if I had confidence that the schematic matched the circuit board...


Thanks,
Jeff N0DY

Join TekScopes@groups.io to automatically receive all group messages.