Re: New Member Dead 7704


Jerry Massengale <jmassen418@...>
 

Mike,

Where do you see a quick flash? Is it green on the crt? You can at least
check for the -3Kv HV primary. Your unit may have something as simple as a
deflection plate connection loose. What plugins are you using?

jerry

On Thu, Dec 29, 2016 at 3:42 PM, volvoboy242@... [TekScopes] <
TekScopes@...> wrote:



I brought my old 7704 (non A) down from the attic the other day to find
that the CRT is dead.
I see a quick flash upon power down but, other then that, there is no
display.
I am guessing that the HV power supply has kicked the bucket.
I've done no diag since I know the voltage is high and my knowledge
doesn't extend to testing deadly secondary potential.
I've never had the covers off or had any work done (in 20 years).
Is this a serviceable part or do I need to source a known good power
supply?
I'm hoping it's something as simple as a re cap but this might be a bit
beyond me.


If any of you guys would Elmer me through this resto project, I'd be much
obliged!
No rush.


The only other scope I have is an old Velleman hand held that works
occasionally. I have some basic Ham survival tools.
I planned to gear up around this old main frame for radio alignments and
things of that nature.
Overkill I know.


Off topic; Also in my attic, there is an old pre war Allen B Dumont
"oscillograph" I played with when I was a kid.
I'd like to get that one working again some day. Just for fun.


Thanks
Mike
KD2MBG





[Non-text portions of this message have been removed]

Join TekScopes@groups.io to automatically receive all group messages.