FULLDUP tnc command: How?


David Ranch
 


Hello Roy,

 
403: no such option, "Cross Band" (other options "Locked Tx: A Band", "Locked Tx: B Band"
517: no such option (500 menu is GPS settings)
529: no such option (as above)

(this is D710G)

Ok.. seems the G is quite different than the A at least in configuration.  I guess the next step would be to upgrade the radio to the current firmware to see if that helps.  Beyond that, I'd recommend to take this topic to the TM-D710_TM-V71@... list (I'm there too) to see if anyone has any direct "full duplex" experience. 


Both bands are in VFO mode so as to make doppler adjustments.

Got it.. btw, as I mentioned before, the D710A supports rig control so this can be made to work very well.  Since you're a Linux guy, Gpredict should work well though it only natively supports the FT817/857/897.  I can't imagine it would be too hard to change it to use a D710's hamlib command.


PS - Just tried a pass with DCD Sense on - and it prevents Tx whenever the squelch is open, even if there are no packets on the Rx frequency, so that wasn't it.   So it will go back to "ignore" for now.

Hmmm.. ok.  That's interesting.  I would have thought that FULL DUPLEX would have disabled that behavior.  I do know that the D710A's TNC really doesn't support open squelch properly which is a pretty big shortcoming for classic packet use. 

--David
KI6ZHD


royldean@...
 

105:  off
403: no such option, "Cross Band" (other options "Locked Tx: A Band", "Locked Tx: B Band"
517: no such option (500 menu is GPS settings)
529: no such option (as above)

(this is D710G)

Both bands are in VFO mode so as to make doppler adjustments.

--Roy
K3RLD

PS - Just tried a pass with DCD Sense on - and it prevents Tx whenever the squelch is open, even if there are no packets on the Rx frequency, so that wasn't it.   So it will go back to "ignore" for now.


---In TMD700A@..., <tmd710@...> wrote :


Hello Roy,

Just thinking outside of the box here but what do you have configured on the D710 head itself:

   - 105 (S-meter squelch) : should be OFF
   - 403 (voice repeater mode)
   - 517 (voice cross band)
   - 529 (packet cross band)

Also.. are you using BAND-A and BAND-B in VFO mode or Memory mode?  I wonder if these settings have an interaction here

--David
KI6ZHD


On 09/27/2017 08:52 AM, royldean@... [TMD700A] wrote:
 

David,


No, it's not up-to-date on firmware.   I'm going to have to find a windows machine that I can install the Kenwood software on, or tinker with installing it on one of my linux machines with WINE.... as I don't have a windows machine.

I will try switching the DCD back on, first, though.   I have not run it that way since turning on FULLDUP, so it's a worthwhile experiment.

--Roy
K3RLD


David Ranch
 


Hello Roy,

Just thinking outside of the box here but what do you have configured on the D710 head itself:

   - 105 (S-meter squelch) : should be OFF
   - 403 (voice repeater mode)
   - 517 (voice cross band)
   - 529 (packet cross band)

Also.. are you using BAND-A and BAND-B in VFO mode or Memory mode?  I wonder if these settings have an interaction here

--David
KI6ZHD


On 09/27/2017 08:52 AM, royldean@... [TMD700A] wrote:
 

David,


No, it's not up-to-date on firmware.   I'm going to have to find a windows machine that I can install the Kenwood software on, or tinker with installing it on one of my linux machines with WINE.... as I don't have a windows machine.

I will try switching the DCD back on, first, though.   I have not run it that way since turning on FULLDUP, so it's a worthwhile experiment.

--Roy
K3RLD


royldean@...
 

David,

No, it's not up-to-date on firmware.   I'm going to have to find a windows machine that I can install the Kenwood software on, or tinker with installing it on one of my linux machines with WINE.... as I don't have a windows machine.

I will try switching the DCD back on, first, though.   I have not run it that way since turning on FULLDUP, so it's a worthwhile experiment.

--Roy
K3RLD


---In TMD700A@..., <tmd710@...> wrote :


Hello Roy,

 

I responded to this last night, but for some reason it never posted:


I got this one though.


A Band (Tx) is 145.840
B Band (Rx) is 435.103

Not sure why you would suggest "just let the TNC see and ignore all those packets"?   I want the TNC to decode ALL packets on the Rx band, while simultaneously encoding and transmitting packets on the Tx band.

I had misread the line "What I have to do to FORCE the transmit is to tune the Rx band down 5 to 10 kHz so that the TNC no longer sees packets - then there will be a flurry of Tx activity, then I quickly tune Rx band back to the proper frequency to resume decoding the downlink."   From that, that's where I went with rig control, etc.  Sorry about that.  Anyway, in RE-READING that line, it sure seems like the TNC really isn't in full duplex and it's waiting for the channel to be not-busy before transmitting.  Aka.. acting like it's a vanilla TNC on one frequency using one VFO.


Also, with DCD in "ignore", it will Tx packets with the Rx squelch wide open as well, as long as it's not currently decoding packets on the downlink (which is precisely the issue - I want it to decode packets at the same time as encoding and transmitting packets on the uplink).

I'm curious if your D710 is fully updated with the newest main and TNC firmware?  It's worth checking.  Beyond that, this smacks of a possible TNC bug.  I understand that FULL DUPLEX actually inhibits the DCD detection automatically.  Just guessing but maybe if you put the DCD setting back to default, maybe the full duplex behavior will start working as expected?


--David
KI6ZHD


David Ranch
 


Hello Roy,

 

I responded to this last night, but for some reason it never posted:


I got this one though.


A Band (Tx) is 145.840
B Band (Rx) is 435.103

Not sure why you would suggest "just let the TNC see and ignore all those packets"?   I want the TNC to decode ALL packets on the Rx band, while simultaneously encoding and transmitting packets on the Tx band.

I had misread the line "What I have to do to FORCE the transmit is to tune the Rx band down 5 to 10 kHz so that the TNC no longer sees packets - then there will be a flurry of Tx activity, then I quickly tune Rx band back to the proper frequency to resume decoding the downlink."   From that, that's where I went with rig control, etc.  Sorry about that.  Anyway, in RE-READING that line, it sure seems like the TNC really isn't in full duplex and it's waiting for the channel to be not-busy before transmitting.  Aka.. acting like it's a vanilla TNC on one frequency using one VFO.


Also, with DCD in "ignore", it will Tx packets with the Rx squelch wide open as well, as long as it's not currently decoding packets on the downlink (which is precisely the issue - I want it to decode packets at the same time as encoding and transmitting packets on the uplink).

I'm curious if your D710 is fully updated with the newest main and TNC firmware?  It's worth checking.  Beyond that, this smacks of a possible TNC bug.  I understand that FULL DUPLEX actually inhibits the DCD detection automatically.  Just guessing but maybe if you put the DCD setting back to default, maybe the full duplex behavior will start working as expected?


--David
KI6ZHD


royldean@...
 

I responded to this last night, but for some reason it never posted:
A Band (Tx) is 145.840
B Band (Rx) is 435.103

Not sure why you would suggest "just let the TNC see and ignore all those packets"?   I want the TNC to decode ALL packets on the Rx band, while simultaneously encoding and transmitting packets on the Tx band.

Rig control has nothing to do with this, what I am trying to accomplish is getting the TNC to encode/transmit at the same time as decoding the B band downlink.  Falconsat, unlike the ISS and NO-84 digipeaters, is full duplex.

Not sure what you mean about setting the squelch to the noise floor - I can set the squelch wide open on the Rx band it will decode the packets perfectly.   Also, with DCD in "ignore", it will Tx packets with the Rx squelch wide open as well, as long as it's not currently decoding packets on the downlink (which is precisely the issue - I want it to decode packets at the same time as encoding and transmitting packets on the uplink).

Hope that makes sense.

--Roy
K3RLD


---In TMD700A@..., <tmd710@...> wrote :


Hello Roy,

 
Terminal successfully tells me that FULLDUP is on on, however, I cannot get full duplex TNC activity during a Falconsat pass.    While my B band is decoding packets on the downlink, I cannot send beacons or messages on the uplink A band.

What frequencies are you using on Band-A and Band-B?  They will need to be on different bands to work.


What I have to do to FORCE the transmit is to tune the Rx band down 5 to 10 kHz so that the TNC no longer sees packets - then there will be a flurry of Tx activity, then I quickly tune Rx band back to the proper frequency to resume decoding the downlink.

Not sure why you would want to do that.  Just let the TNC see and ignore all those packets.  If you really need this functionality, the D710 supports RIG control to control the two different VFOs.  I know that Hamlib support the the D710 today.


So is the only way to interface with the TNC when it is "PACKET12" mode?   I tried to switch the TNC to "APRS96" mode (which is what is needed for falconsat), and then you cannot send commands via the com port (behaves just like the TNC is off).

Packet12/96 is a classic Command TNC or KISS TNC.  If you want to support APRS traffic when in these two modes, you must have some other program to support the APRS stack communications.  This list can offer ideas here to you depending on the OS you're running (Direwolf, UIVIew32, APRSICE, Xastir, APRSSA, etc)  If you put the D710 into APRS12/APRS96, the radio's TNC handles all the APRS stack communications.  At that point, the TNC will only send APRS objects to the serial port but the TNC will no longer support regular TNC Command mode commands.


DCD sense is currently set to "Ignore".

Are you talking about Open Squelch support?  If so, it's not a supported feature (at least on the D710A) as it didn't work quite right.  As such, you'll need to set the RX VFO's squelch to the right level for the frequency's noise floor.  This is one of the big limitations of the D710's TNC vs. most modern TNCs like KPC3, PK96, Direwolf, etc.

--David
KI6ZHD


David Ranch
 


Hello Roy,

 
Terminal successfully tells me that FULLDUP is on on, however, I cannot get full duplex TNC activity during a Falconsat pass.    While my B band is decoding packets on the downlink, I cannot send beacons or messages on the uplink A band.

What frequencies are you using on Band-A and Band-B?  They will need to be on different bands to work.


What I have to do to FORCE the transmit is to tune the Rx band down 5 to 10 kHz so that the TNC no longer sees packets - then there will be a flurry of Tx activity, then I quickly tune Rx band back to the proper frequency to resume decoding the downlink.

Not sure why you would want to do that.  Just let the TNC see and ignore all those packets.  If you really need this functionality, the D710 supports RIG control to control the two different VFOs.  I know that Hamlib support the the D710 today.


So is the only way to interface with the TNC when it is "PACKET12" mode?   I tried to switch the TNC to "APRS96" mode (which is what is needed for falconsat), and then you cannot send commands via the com port (behaves just like the TNC is off).

Packet12/96 is a classic Command TNC or KISS TNC.  If you want to support APRS traffic when in these two modes, you must have some other program to support the APRS stack communications.  This list can offer ideas here to you depending on the OS you're running (Direwolf, UIVIew32, APRSICE, Xastir, APRSSA, etc)  If you put the D710 into APRS12/APRS96, the radio's TNC handles all the APRS stack communications.  At that point, the TNC will only send APRS objects to the serial port but the TNC will no longer support regular TNC Command mode commands.


DCD sense is currently set to "Ignore".

Are you talking about Open Squelch support?  If so, it's not a supported feature (at least on the D710A) as it didn't work quite right.  As such, you'll need to set the RX VFO's squelch to the right level for the frequency's noise floor.  This is one of the big limitations of the D710's TNC vs. most modern TNCs like KPC3, PK96, Direwolf, etc.

--David
KI6ZHD


royldean@...
 

Ok, I think this was a classic case of "Mission Accomplished" when it wasn't actually.

Terminal successfully tells me that FULLDUP is on on, however, I cannot get full duplex TNC activity during a Falconsat pass.    While my B band is decoding packets on the downlink, I cannot send beacons or messages on the uplink A band.

What I have to do to FORCE the transmit is to tune the Rx band down 5 to 10 kHz so that the TNC no longer sees packets - then there will be a flurry of Tx activity, then I quickly tune Rx band back to the proper frequency to resume decoding the downlink.

So is the only way to interface with the TNC when it is "PACKET12" mode?   I tried to switch the TNC to "APRS96" mode (which is what is needed for falconsat), and then you cannot send commands via the com port (behaves just like the TNC is off).

DCD sense is currently set to "Ignore".

Any suggestions?

--Roy
K3RLD


royldean@...
 

Success!   And it appears that another fundamental problem is that I wasn't in packet mode on the control head.  Once I turned it on, the terminal window came alive!


royldean@...
 

Bill -

Thanks for the clarification.  In retrospect, that seems obvious.   I'll give it a try this afternoon and report back on results.

--Roy
K3RLD


---In TMD700A@..., <williamrham@...> wrote :

Hi Roy,
  You must enter the tnc command,  then a space, then the command parameter, in this case either ON or OFF.     In other words as follows:
 
FULLDUP ON    (to turn it on)
FULLDUP OFF   (to turn it off)
 
You can also use the short form of a tnc command if you like.    In this case the short form for FULLDUP is FU (believe it or not, hi hi).     So you could enter it as follows:
 
FU ON (to turn it on)
FU OFF (to turn it off)
 
Hope this work for you.
 
                                  Bill (VA1ALW)
 
 
 
 

Sent: Sunday, September 24, 2017 4:58 PM
Subject: [TMD700A] FULLDUP tnc command: How?
 
 

Trying to get full duplex TNC functionality for use with FalconSat-3.   Manual says the TNC command is "FULLDUP".


So, I connect via rs232 terminal emulator (cable connected to the control head, NOT the RF deck), and enter command "FULLDUP".


All I get in return is the following:


"?ULLDUP"


Has it actually worked?   Or is the "?" indicating that it has no clue what I asked of it?   Note that if I type in "ID" and hit enter, it comes back with "TM-D710GA" (or something similar), so I am definately connected to something.   Any suggestions?


-Roy

K3RLD


Bill Simm
 

Hi Roy,
  You must enter the tnc command,  then a space, then the command parameter, in this case either ON or OFF.     In other words as follows:
 
FULLDUP ON    (to turn it on)
FULLDUP OFF   (to turn it off)
 
You can also use the short form of a tnc command if you like.    In this case the short form for FULLDUP is FU (believe it or not, hi hi).     So you could enter it as follows:
 
FU ON (to turn it on)
FU OFF (to turn it off)
 
Hope this work for you.
 
                                  Bill (VA1ALW)
 
 
 
 

From: royldean@... [TMD700A]
Sent: Sunday, September 24, 2017 4:58 PM
To: TMD700A@...
Subject: [TMD700A] FULLDUP tnc command: How?
 
 

Trying to get full duplex TNC functionality for use with FalconSat-3.   Manual says the TNC command is "FULLDUP".


So, I connect via rs232 terminal emulator (cable connected to the control head, NOT the RF deck), and enter command "FULLDUP".


All I get in return is the following:


"?ULLDUP"


Has it actually worked?   Or is the "?" indicating that it has no clue what I asked of it?   Note that if I type in "ID" and hit enter, it comes back with "TM-D710GA" (or something similar), so I am definately connected to something.   Any suggestions?


-Roy

K3RLD


royldean@...
 

Trying to get full duplex TNC functionality for use with FalconSat-3.   Manual says the TNC command is "FULLDUP".


So, I connect via rs232 terminal emulator (cable connected to the control head, NOT the RF deck), and enter command "FULLDUP".


All I get in return is the following:


"?ULLDUP"


Has it actually worked?   Or is the "?" indicating that it has no clue what I asked of it?   Note that if I type in "ID" and hit enter, it comes back with "TM-D710GA" (or something similar), so I am definately connected to something.   Any suggestions?


-Roy

K3RLD