Date   
Sitech must be running to connect any planetarium software besides Skyview? 7 messages By Tim ·
Initializing Alt/Az park position manually 2 messages #question By Kris ·
Servo Motor Is Faulty 8 messages By Ned Smith ·
Confused by SiTech numbers regarding Alt and Az 4 messages #question By Kris ·
Argo Navis Connection 7 messages By Ronald Price ·
Autoguiding in Firecap 5 messages #question By Stonius ·
Getting Setup with Servo II 5 messages By Gary Starkweather ·
2022 Portland XV Alt-Az Workshop announcement and agenda 3 messages By Howard Banich ·
SiTech platesolving help 2 messages #ascom #question #'s By matija.sircelj@... ·
motor noise and motor LEDs 7 messages By Frank ·
Telescope slow tracking and missing targets. 7 messages #ascom #question #tickmanagement By matija.sircelj@... ·
lost serial communication with servo I controller 17 messages By Mark Copper ·
Setting up the Mesu mount on Alpaca 5 messages #ascom By Jose Ignacio Sanchez Rodriguez ·
Sitech Servo Controller II: horizontal or vertical? 4 messages By Frank ·
Too slow tracking. 3 messages #question #ascom By matija.sircelj@... ·
First experiences with Sitech Servo Controller II (firmware version 9.7), radio handpad and Faulhaber servo motors - a few questions 5 messages By Frank ·
How to mount a pittman motor 4 messages By akira.johndoe@... ·
Local time reported? 4 messages By Che ·
Planetary Imaging with Mesu 7 messages By manos malakopoulos ·
oscillations end of travel 4 messages By Pierre ·
1 - 20 of 6166