Argo Navis not communicating with the Servo Controller II


Raphael T Vilardi
 

Dear All.

I'm not able to have the Argo Navis communicate with the Servo Controller II. I've followed the protocols: on the Servo Config: Select "Enable Argo Navis" and "Ignore Mount encoders" (as I don't have them) and selected the "Slew mode".

On the Argo Navis: I’m using the special cables supplied by Wildcard Innovations connecting Serial port 1 to the RS232 port at the Servo Controller; choose serial port 1 and STARTUP Command of sitech and a BAUD rate of 19200 in the SETUP SERIAL menu. The SETUP ALT STEPS and SETUP AZ STEPS values were put at +18000. Still when I move the telescope the reading at the Mode Encoders would not change indicating that there is no communication. Has anyone ever come across a similar problem?  Best regards

 


Don W
 

Hi Raphael,

Check your serial cable.  There are two kinds of cables: Straight-through and NULL.  The NULL cable reverses two of the connections (I think they are the R and T wires).  You can buy a Null adapter from Amazon or a computer store to use with your existing cable.
https://www.amazon.com/female-slimline-transfer-serial-adapter/dp/B075XHWVSJ/ref=sr_1_3?dchild=1&keywords=serial+NULL+adapter&qid=1620283514&sr=8-3

Don W


Roy Diffrient
 

Hi Raphael,

Have you Initiated Argo Navis communication?  So simple, so easily skipped, I often forget it – On the keypad, press the top right and top left (ESC and RTN) keys at the same time.  Then try the encoders.

Roy Diffrient


On May 5, 2021, at 10:43 PM, Raphael T Vilardi <rtvilardi@...> wrote:

Dear All.

I'm not able to have the Argo Navis communicate with the Servo Controller II. I've followed the protocols: on the Servo Config: Select "Enable Argo Navis" and "Ignore Mount encoders" (as I don't have them) and selected the "Slew mode".

On the Argo Navis: I’m using the special cables supplied by Wildcard Innovations connecting Serial port 1 to the RS232 port at the Servo Controller; choose serial port 1 and STARTUP Command of sitech and a BAUD rate of 19200 in the SETUP SERIAL menu. The SETUP ALT STEPS and SETUP AZ STEPS values were put at +18000. Still when I move the telescope the reading at the Mode Encoders would not change indicating that there is no communication. Has anyone ever come across a similar problem?  Best regards

 


Raphael T Vilardi
 

On Thu, May 6, 2021 at 10:18 AM, Roy Diffrient wrote:
Hi Roy, first of all I apologize for taking that long to thank you for the tip which I do now! You are right, it is easy to forget it but, in this case I did it (select Enable Argo Navis). However I still did not succeed in making Argo Navis communicate with the Servo. Please take a look on what I'm wrtiing to Don on the subject. Best regards, Raphael


Raphael T Vilardi
 

Hi Don. I got he follooing instroctions from Taj regarding communication between Argo Navis and Servo Cogtroller II" .....

......Then, you need to remove the Servo II enclosure cover and place the jumper on the left side of the PCB across both pins. When using the USB port, it will only be on one pin. Keep in mind that when doing this, you will lose use of the USB port until the jumper is removed again. Once the jumper is placed, turn the controller on and you should have communication with the Argo Navis."

On the top of this, should I still order the Null adaptor?I  I've checked the link you've sent but WildCard provides a special cable  which I have., with smaller RS232 jack on one end designed to communicate with the Servo II,


Don W
 

Hi Raphael,
The advice Taj gave you is very correct.  The Servo II controller can use either USB or COM, but not both at once.  You should adjust the jumper to the COM position, thten try you existing cable.  It will probably work.  If it doesn't, then the null modem might work.  But your cable was designed to work with the Argo-Navis, so try that first.
Don W