#question where is SiTechExe/Config/ChangeConfig/Misc? #question


Mark Copper
 

Hello,

I am looking in the file INDI_Instructions.txt, Step 2, Install SiTech.

I download the archive http://siderealtechnology.com/SiTechInstallerLinux.zip and unzip it and run SiTechInstaller.sh as root.

With a little help this creates a directory /root/bin/SiTech which contains a file SiTechTCPProtocol.txt. The first four lines of this file read

   Starting with version 0.92e of SiTechExe, there is a TCP/IP interface to SiTechExe.

   To get started, we have a C# project you can try:
   http://siderealtechnology.com/TestSiTechTCP02.zip

   First you set up the port number in the SiTechExe/Config/ChangeConfig/Misc.

Also in the directory /root/bin/SiTech is a directory SiTechExe, but it does not contain a directory Config.

In the archive TestSiTechTCP02.zip there is also a file SiTechTCPProtocol.txt, but it is slightly different, beginning

   Added AirMass to standard response.

   Starting with version 0.92e of SiTechExe, there is a TCP/IP interface to SiTechExe.
   First you set up the port number in the SiTechExe/Config/ChangeConfig/Misc.
   It's labeled "Indi Port Number"

How does one get the file Config/ChangeConfig/Misc?

I would like to know because when I run SiTechExe.exe on my computer, I get an Unhandled Exception:
   System.Net.Sockets.SocketException (0x80004005): Address already in use
and I'm wondering if setting the port number as above would get around this exception.

Thanks for looking.



dan adi
 

It is not a file, at least in windows. Just launch the sitechexe app, the in the menu Config you find the Change Config option 


Dan Gray
 

Hi Mark,
It could be as simple as the port number for the TCP interface.
Since you can't change it with the user interface, you'll have to edit the config file.

Go here:
/home/your user name/bin/SiTech/SiTechExe/SiTech.cfg
Find the IndiPortNum=8079
Change it to a free port, save, and then try again.

If this doesn't work,
Step 1. replace your /home/your user name/bin/SiTech/SiTechExe/SiTechExe.exe   with this one:

Step 2.
Go here:
/usr/share/SiTech/SiTechExe
Find the file named SiTechDll.cfg
If it's not there, create it.
The contents should be:
LogData=False
PortNum=8000

Change the port to a port that's available.
Let us know if this works.
Dan


On Sun, Jul 18, 2021 at 1:37 AM dan adi via groups.io <cioc.adriandan=yahoo.com@groups.io> wrote:
It is not a file, at least in windows. Just launch the sitechexe app, the in the menu Config you find the Change Config option 


Mark Copper
 

Many thanks for responses.

I don't have SiTech.cfg in /home/debian/bin/SiTech/SiTechExe.

("debian" is the built in user on the Beaglebone Debian images so I use it). If anyone else sees this, it helps to modify SiTechBinDirectory definition in SiTechInstaller.sh so that the bin directory is written under one's home directory. Otherwise SiTech gets written under /root/bin which appears to be harmless.

Luckily running SiTechExe.exe the first time causes SiTech.cfg to be written to /usr/share/SiTech/SiTechExe/ before the unhandled exception occurs. So I changed IndiPortNum to 8078 which is free according to netstat, and I re-ran SiTechExe.exe. Unfortunately the program halts with the same exception.

Next I followed steps 1 and 2 above. The file SiTechDll.cfg did not exist, so it was created anew with the same permissions as SiTech.cfg. Again SiTechExe.exe halts with the same exception.

Currently "mono -v -v SiTechExe.exe" is running with the hope of gleaning more information. But it is either taking forever or stuck in a loop.

I'd like to emphasize that this exception does not happen with all Linux boxes. My friend has reported that SiTechExe.exe ran without exception on his Intel 32 bit box under Ubuntu.

Mark


Jeff Ross
 

To troubleshoot something like this, install strace on your linux box.

Read the man page for strace, then use strace to see every step the programs takes.

In a lot of cases, strace mono -v -v SiTechExe.exe might be enough to what's really going on.

N.B.  I have much more experience with the BSDs ktrace command but the few times I've used strace it was pretty similar.

And good luck!

Jeff Ross
Townsend, MT

On 7/18/21 2:06 PM, Mark Copper wrote:
Many thanks for responses.

I don't have SiTech.cfg in /home/debian/bin/SiTech/SiTechExe.

("debian" is the built in user on the Beaglebone Debian images so I use it). If anyone else sees this, it helps to modify SiTechBinDirectory definition in SiTechInstaller.sh so that the bin directory is written under one's home directory. Otherwise SiTech gets written under /root/bin which appears to be harmless.

Luckily running SiTechExe.exe the first time causes SiTech.cfg to be written to /usr/share/SiTech/SiTechExe/ before the unhandled exception occurs. So I changed IndiPortNum to 8078 which is free according to netstat, and I re-ran SiTechExe.exe. Unfortunately the program halts with the same exception.

Next I followed steps 1 and 2 above. The file SiTechDll.cfg did not exist, so it was created anew with the same permissions as SiTech.cfg. Again SiTechExe.exe halts with the same exception.

Currently "mono -v -v SiTechExe.exe" is running with the hope of gleaning more information. But it is either taking forever or stuck in a loop.

I'd like to emphasize that this exception does not happen with all Linux boxes. My friend has reported that SiTechExe.exe ran without exception on his Intel 32 bit box under Ubuntu.

Mark


Mark Copper
 

Ha! It worked.

"strace mono SiTechExe.exe" output contained the line

bind(8, {sa_family=AF_INET, sin_port=htons(8000), sin_addr=inet_addr("0.0.0.0")}, 16) = -1 EADDRINUSE (Address already in use)

so I changed PortNum to 8001 in SiTechDll.cfg and the display screen for SiTechExe.exe came up.

Thank you. Thank you.

So much to learn. Next stop: INDI driver.

Mark