Topics

WSJT-X Decodes Limited Number of FT8 Messages


dcurrie51
 

I have my RigPi working just fine for SSB HF operation using the RigPi Audio Board 3.5 jacks with homemade cables. The problem I'm having is with WSJT-X in FT8 mode. When I compare decoded signals from the RigPi setup to those I get on my ham shack computer running WSJT-X, I see 0-2 messages per cycle on RigPi but 1 to 2 dozen on the ham shack computer. Also, the contacts decoded on RigPi are almost exclusively CQ messages, which could be an important clue. The waterfall display shows lots of signals on both the RigPi and ham shack computer setups. In fact they look very similar. The RigPi radio control function from WSJT-X using Hamlib seems to work fine.

Here is what I have tried on my own so far.

Made sure the "CQ only" box in WSJT-X not checked
Made sure that Mumble was not running on RigPi.
Made sure RSS browser was shut down on RigPi desktop once the radio was successfully connected
Checked the clock timing. (compared displayed dt for CQ-ing stations on both setups)
Checked incoming RX audio level and tried lowering and raising.
Checked and compared the WSJT-X settings on both setups. 
Made sure AGC, Noise Blanker, Notch filter etc turned off on HF radio
Checked LSB selected and wide SSB filter selected on HF radio.
Tried interchanging HF radios and cables (to confirm problem is within the RigPi)
Set the Alsamixer settings per the Manual. 

Despite the limited decoding. I have completed a couple of FT8 contacts using the RigPi setup, so Tx Audio is passing through to the radio.

From what I've read, there could be a problem with the audio sampling rate not set to 48 KHz, 16 bits, but I don't know how to check or set this on RigPi. Also, I've read about resource constraints causing poor decoding, but the indicator at the top right of the RigPi desktop never show more than 20%.

Any help would be greatly appreciated.

Dave VE3RTL


Howard Nurse, W6HN
 

Hi Dave,

When you select the audio in/out devices, do you see snd_rpi_proto or audioinjector?  The latter will show if you have a RigPi that is over a year old and hasn't been updated per the manual.

--Howard


Dan Heather
 

Hi Dave,

I believe wsjtx likes to use use USB (on all bands). Have you tried that?

Good luck!

On Sun, Sep 13, 2020 at 1:22 PM dcurrie51 <dcurrie@...> wrote:
I have my RigPi working just fine for SSB HF operation using the RigPi Audio Board 3.5 jacks with homemade cables. The problem I'm having is with WSJT-X in FT8 mode. When I compare decoded signals from the RigPi setup to those I get on my ham shack computer running WSJT-X, I see 0-2 messages per cycle on RigPi but 1 to 2 dozen on the ham shack computer. Also, the contacts decoded on RigPi are almost exclusively CQ messages, which could be an important clue. The waterfall display shows lots of signals on both the RigPi and ham shack computer setups. In fact they look very similar. The RigPi radio control function from WSJT-X using Hamlib seems to work fine.

Here is what I have tried on my own so far.

Made sure the "CQ only" box in WSJT-X not checked
Made sure that Mumble was not running on RigPi.
Made sure RSS browser was shut down on RigPi desktop once the radio was successfully connected
Checked the clock timing. (compared displayed dt for CQ-ing stations on both setups)
Checked incoming RX audio level and tried lowering and raising.
Checked and compared the WSJT-X settings on both setups. 
Made sure AGC, Noise Blanker, Notch filter etc turned off on HF radio
Checked LSB selected and wide SSB filter selected on HF radio.
Tried interchanging HF radios and cables (to confirm problem is within the RigPi)
Set the Alsamixer settings per the Manual. 

Despite the limited decoding. I have completed a couple of FT8 contacts using the RigPi setup, so Tx Audio is passing through to the radio.

From what I've read, there could be a problem with the audio sampling rate not set to 48 KHz, 16 bits, but I don't know how to check or set this on RigPi. Also, I've read about resource constraints causing poor decoding, but the indicator at the top right of the RigPi desktop never show more than 20%.

Any help would be greatly appreciated.

Dave VE3RTL







--
Dan Heather
Middleboro MA


Rod Mollise
 

I think Dan nailed it, OM. You MUST use upper sideband for FT8, not lower sideband.

73,
W4NNF


dcurrie51
 

My apologies Dan. I meant to say that I ensured the radio was set to USB.


dcurrie51
 

Hi Howard. In Alsamixer, the selected soundcard shows audioinjector-pi-soundcard and yes the RigPi is over a year old. The RSS version is 1.05. I have used the "Update RSS files" button in the browser and it comes back with "You are using the latest version of RSS."  Is there another update process I should follow? I didn't see another update process in the manual. The WSJT-X version within the RigPi is v2.0.1, so not the latest version. Thanks, Dave


Howard Nurse, W6HN
 

Hi Dave,

You will see a big improvement in WSJT-X decoding with the correct audio device tree.  Open Help in RigPi (do not use online Help) and go to the RigPi Audio Update topic in Advanced settings for instructions on how to fix the issue.

--Howard


dcurrie51
 

Hi Howard.

I followed the RigPi Audio Update process as you suggested and that has made a world of difference. I'm getting all sorts of FT8 decodes now. And the Mumble audio is much better too. I had not come across this update procedure because I was looking in the PDF Manual posted on the web. Perhaps this update could be added to that document. It's a valuable piece of information for us guys that have an older RigPi without this update done. Are there any other core updates I should consider? Thanks for your help in resolving this.

Dave VE3RTL


Howard Nurse, W6HN
 

Hi Dave,

Glad you were able to make the change.  We are releasing RigPi 2 soon, and I will try to track down all online manuals at that time to update them.

The audio tree update could not be done by the built-in RigPi updater.  All other updates through 1.05 were automatic.

--Howard