Topics

Same questions about Audio and RigPi #rigpi #audio


Peter Bruins
 

Hello from Germany,
 
at first tnx for this RigPi to all  developer.
 
I have config the  RigPi  in tow days but I have same questions.
We will use the RigPi on the club station  we have one K3 install. When one User is on the Server remote and a second user connect the RigPI no user can see that the other  user is connected. The problem is when both user push the PTT Button that can makes trouble .
Is it possible that you can see on the RigPi screen witch user are on the Server. Did I make an config mistake?  That only one user  the first one can works with the K3 the other only look?
We use a K3 only the audio connect are withe the USB Sound card that works perfect with mumble.
When I put the TX in and RX out direct in the RigPI audioboard  TX RX  witch source must I choose from the mumble server
I see on the Audio at the Raspi a audioinjector-pi-soundcard  is this on the audiobord in the Rigpi ?
I think I have knowledge gap please can you help me how did the audio hardware function under K3

73 Peter DH4JQ


Jan Blomquist / SM5SUH
 
Edited

I have the rigPi and an IC-7300 setup for my personal use and for others who need to use it via a second account. We are using the mumble/plumple to see if there is another connected at the same time and you can talk or chat with the user via mumble/plumple. Sometimes there are more than one user that will talk on the same time on the same frequency and then the other users just mute their microphones when it’s not their turn. And of course, keep the hand of the PTT button :-) There are no problem controlling the IC-7300 as all can do this at the same time but it going to need some discipline from the users of course.

It works well for us.

I can’t give you any answer regarding your audio question because I just us the USB cable between the Raspberry and the IC-7300.


Jan / SM5SUH


Howard Nurse, W6HN
 

Hi Peter,

Jan is right about Mumble.  You can also see which accounts are connected in the SETTINGS>Accounts window.  See the "On" column.

73, Howard W6HN


Peter Bruins
 

Hello Howard ,

thanks for the info i think I need new glasses 

can you give  me same info's about the audio board .
Is it possible to use  mumble  withe the audio board  tX rX plugs  when yes  witch audio device must I set in mumble
and can I use the audio board with WSJT  over the tx rx plugs  when yes witch devise must I selekt in WSJT.

Thanks for your time and help
Peter DH4JQ


Howard Nurse, W6HN
 

Hi Peter,

Yes, you can use the RigPi Audio board with Mumble and WSJT-X through the RX IN/TX OUT connectors.

1. In the Raspberry Pi Desktop, right-click the Speaker Icon.  In Audio Outputs and Audio Inputs select snd_rpi_proto.
2. In Mumble>Configure>Settings>Audio Input and Audio Output select [sysdefault: CARD=sndrpiproto] snd_rpi_proto, WM8731 HiFi wm8731-hifi-0 Default Audio Device.
3. In WSJT-X File>Settings>Audio select sysdefault: CARD=sndrpiproto for Input and Output.
4. In Fldigi Configure>Config Dialog> Soundcard>Devices select Port Audio, Capture=snd_rpi_proto: WM8731 HiFi wm8731-hifi-0 (hw:0,0)

Note 1: Mumble must be closed when using the audio device for Fldigi or WSJT-X.
Note 2: After making any changes to Mumble settings, click Apply, OK, then exit and restart Mumble for the seetings to stick.

--Howard


Peter Bruins
 

Hello Howard

I make an right-click   on the speaker only a  audioinjector-pi-soundcard (alsa mixer) how can I change it i have look in the manual but I found nothing
please what must i do to change it . I am not a linux specialist same times a little suse linux.

TNX

73 Peter DH4JQ


Peter Bruins
 

Hello Howard
I found it 

73 Peter DH4JQ


Peter Bruins
 

Hello Howard

in FT 8 the signal cams in but when I push the tune button the K3 switch to send but   no power go out
in the WSJT Setup the input is on the  left  
I put the right  also on the  left
For the Lin in I tick the Lin In on the Audio Divice Setup then it works
must I any confirm for the Output
TNX for your Help
Peter


Howard Nurse, W6HN
 

Hi Peter,

Here are some things to check.

  1. Close Mumble if the Mumble window is open.
  2. In the Raspberry Pi Desktop, right-click the Speaker icon and select either snd_rpi_proto (if using the RigPi Audio Board) or CODEC (if using a CODEC from the radio for audio).
  3. Choose the same audio options in WSJT-X.
  4. Check the Input level on the right side of the WSJT-X window.
  5. If using a CODEC for audio, make sure it is selected in the Menu for the radio.
Tell us more about what radio you are using if none of these suggestions work.

--Howard


Peter Bruins
 

Helllo Howard

at first thank for the excellent fast support


  1. Close Mumble if the Mumble window is open.  don
  2. In the Raspberry Pi Desktop, right-click the Speaker icon and select either snd_rpi_proto (if using the RigPi Audio Board) or CODEC (if using a CODEC from the radio for audio). I have connect a K3 before I use the Audio Board I us an exten USB Soundboard everything work fine with ten sound card in this config. 
  3. Choose the same audio options in WSJT-X. This device are install in Input Output sysedfault.CARD=sndpiproto
  4. Check the Input level on the right side of the WSJT-X window.    the imput level 40-60 db           WSJT decoded QSO wit the normal signal strong it works                       
  5. If using a CODEC for audio, make sure it is selected in the Menu for the radio.        I think we must need it wen we change the radio to a 7300
Config that I make
right kick on audio select Audio Device Setup.  Under switches, Lin in select   if it is not select on the WSJT screen you QSO  -20 -24 db all.
Boothe plugs for audio are selecte on left .

For your info I have by it from a anther ham I think he has work withe a IC 7300 I don´t now what he has config

if it s possible for you you can directly sow on my RigPic I can send you the date via a private mail

TNX for your time and help

73 Peter DH4JQ


Howard Nurse, W6HN
 

Peter, please send the sign on information for VNC by private email and I will log on.  Note port 5900 must be open in your router.

--Howard


Peter Bruins
 

Hello Howard

tnx for your time and help yesterday .

I have make same test

If I connect the TX out with may headset and start audio city and play a  wav file nothing.
hen I put may USB sound cart in   the RigPI conncet may Headset I hear audio.

And I don´t understand this:
I have put the TX out from K3 into RX in from the RIgPI  look to wsjt  calls are cam in rapport  ok -4 -5 -10

the I unplug and put the TX out from the K3 to the TX from the RigPi server
look to wsjt and calls came in rapport --23 db -22  -19

what can we do next

73 Peter DH4JQ

at this moment i get the rx in with the audio board  and TX out withe the USB Soundboard  its only for Test

I think I have an demage Audio board ???




then I cange the driver in WSJT to may soundcard  that works  100%


Peter Bruins
 
Edited

Hello Howard
I have a problem withe the   electrical   circuit diagram  it see that the diagram  is differnt  as the orginal mfj bard  is it possibel that mfj has make a  change off the board ? The pin off the board is 862 1234 A R0 from 2019.
On the diagram  862 1234 A6  from 2019
73 peter dh4jq


Howard Nurse, W6HN
 

Hi Peter,

There is only one minor difference between the production board and the online schematic.  I believe a pull-up resistor was removed from the board.  The pads are there, but no resistor.

--Howard


Peter Bruins
 
Edited

Hello howard

The sr nr not   equal
73  DH4JQ


Peter Bruins
 

HI Howard


I have still tested something it behaves like this when the internal sound card is addressed I see no output signal in Audacity
and it cannot be heard. With the usb card, the signal is displayed and also audibly played
It may be that there is a possibility to switch off the audio output by software
I have no idea anymor

73 Peter
DH4JQ




Howard Nurse, W6HN
 

Hi Peter,

When I logged into your RigPi from here we concluded that there may be a problem with your RigPi Audio board.  Have you been able to confirm that?  If you order a new board you can use an external USB audio sound card until it arrives.

--Howard


Peter Bruins
 
Edited

Hello Howard

I have  last days working with the RIGPI  I cannot fix the problem , withe  the internal soundboard.
Nothing Audio out from the internal soundboard.
I have open the case and see  that on the small Audio board withe the rj45 plug  same
solder points are not have the solder I fix it but the problem is the same.
Then I  have be fed up I bay a new version from the  MFJ homepage and it works I hear audio on the intern soundboard  on the lest Earphone withe audiocity .  I will config now the system then I will test it with the K3 the test withe the IC7300 end of the week
no no no what  a hell of crab and I must second pay for the software a bit frustrating.

73 Peter DH4JQ


Peter Bruins
 

Hello Howerd

just I have test the K3 funkion 100 % it works direkt with FT8
later I test the IC7300

73 Peter