Topics

Rig PI VER 2 Bug ?


radiorusso
 

I noticed that RIG π VER 2 seems to change my mic gain on its own.  If it is set to 10 on the slider the mic gain is set to 30 on the radio. I usually run the radio mic gain around 14 to keep from over driving  it. If I set the slider to 4 or so the Radio mic gain is now at 14 or so. I  move off the mic gain slider and over the next few seconds the slider slowly increments to 10  raising the radio  mic gain to 29.. IF I go to a non ham freq (WWV)  the power slider goes to zero and the mic gain  is also now showing  zero on the  mic gain slider. Move back to the ham bands and suddenly the Power  shows 39 on the  slider  and the mic gain jumps to  10. The radio is a FTdx 3000.  Another question about VER 2 when you double click on the Rig π icon a window opens asking what do you want to do as there is an executable script trying to  run Options execute, open in terminal  window  and I or 2 other choices . ? this normal or just something new . BTW have never been able to figure out why the mumble client  disconnects  after about 1 to 2 minutes when running  on the π4 and doesn't do this when running on theπ π 3B+  

Thanks in advance
Russ W4PGT


Howard Nurse, W6HN
 

Hi Russ,

The Mic gain creep you describe is most likely an issue with Hamlib related to the FTdx-3000, and is something we can fix.  First we need to collect some data to pass along to the Hamlib maintainers.  It might be simplest for me to log in to your RigPi to run some commands.  If that would be OK, please send your Internet IP via private email to me, including any passwords you have changed.  I will log in using VNC, so port 5900 must be open.

To fix the "executable script" issue, open File Manager>Edit>Preferences.  In the General pane, put a check in the option "Don't ask options on launch executable file."

--Howard