Topics

PTT


hazzle
 

Hi all
I am trying to set up the RigPi and would like to know if it can be set up to press the PTT button once for it to stay on transmit untill pressed again.
I need this facility as i am a disabled operator and can not use my hands.
I use a head mouse which only allows me to either press the button once and realise it straight away or double tap rapidly.
There are no options to press and hold. If this is not a option I will have to look for other ideas.
Can anyone help me with this.
Thanks 
Dave G4WB


Steve_KE4LC
 

Hi Dave,  please try using the macro command !T/R to toggle PTT on and off.  It should already be on one of the default macro (black) buttons.  It works well with my FT450D.  Using the macro editor, I have moved it in the upper right of the Tuner page for convenient mouse access (macro 25 position),  right under the PTT button.   Please let me know if it works for your needs. 

73,  Steve KE4LC 


hazzle
 

Hi Steve
Tried it and it worked fine so i can now go ahead and get my radios connected and my aerials set up.
I can finally get back on the air after 3 year's of not being able to get any help.
Thanks again for all your help and i look forward to being back on the air.
Best 73
Dave G4WBB

On Sun, 30 Aug 2020, 19:25 Steve_KE4LC, <sfwright101@...> wrote:

Hi Dave,  please try using the macro command !T/R to toggle PTT on and off.  It should already be on one of the default macro (black) buttons.  It works well with my FT450D.  Using the macro editor, I have moved it in the upper right of the Tuner page for convenient mouse access (macro 25 position),  right under the PTT button.   Please let me know if it works for your needs. 

73,  Steve KE4LC 


Steve_KE4LC
 

Hi Dave - that's great to hear!   The active RigPi forum is very good for solving problems.   We learn from others and pass our knowledge forward!   RigPi is perfect for automating rig functions.  Its strong macro capability really let you take control of the rig using your own custom/bespoke designs.    I use my RigPi to allow my 93 year-old dad to keep active in his life-long hobby.   He is in Wisconsin about 600 miles away from the station here in Tennessee.   It works very well for us.   If I can be of any help in the future, please let me know.
73,  Steve KE4LC


On Mon, Aug 31, 2020 at 2:03 AM hazzle <hazzle1@...> wrote:
Hi Steve
Tried it and it worked fine so i can now go ahead and get my radios connected and my aerials set up.
I can finally get back on the air after 3 year's of not being able to get any help.
Thanks again for all your help and i look forward to being back on the air.
Best 73
Dave G4WBB

On Sun, 30 Aug 2020, 19:25 Steve_KE4LC, <sfwright101@...> wrote:

Hi Dave,  please try using the macro command !T/R to toggle PTT on and off.  It should already be on one of the default macro (black) buttons.  It works well with my FT450D.  Using the macro editor, I have moved it in the upper right of the Tuner page for convenient mouse access (macro 25 position),  right under the PTT button.   Please let me know if it works for your needs. 

73,  Steve KE4LC 


Jan Blomquist / SM5SUH
 

Hello. I can also tell you that the ordinary PTT button will be toggled in the upcoming version of the system that are under beta testing now.

Jan / SM5SUH


Don Melcher
 

I understand the same will be true for the + - buttons as well. That will be a welcomed improvement. 


We’re all waiting with breath like bait. 
--
73
Don
W6CZ
DM07bk


G8HAV
 

I have a problem with both these methods. Using FT857 and when I click the PTT button on the RigPi it turns red and puts the FT857 into transmit. I click it again and the PTT button goes black but the rig is stuck in transmit. Have to turn it off and on again to clear. I get the same effect with the T/R macro. Any ideas?
thanks


Karl Heinz Kremer
 

Does the same happen when you dial your power back? I've had this happen in the past when RF got into the serial port connection to the radio, but only on certain bands, and with higher power levels. 

Karl Heinz - K5KHK


G8HAV
 

Thanks for the reply.  I am using 10W, which is my normal power on FT8. Checked on Windows and no problem up to full power using WSJT-X
Trying to resolve this before taking on thhe rest of the problems in setting RigPi up. Not for the faint hearted.


Steve_KE4LC
 

Howard Nurse would be better to answer this, but as a beta tester of the new RigPi RSS 2.00 software, I can tell you that significant work was focused around resolving various PTT issues, so hopefully, moving to 2.00 (see RigPi website) will solve your PTT sticking problem.  

73, Steve KE4LC 


G8HAV
 

Hi, Thanks for the replies. I have downloaded and installed Ver2 and now the PTT or T/R will not put the FT857 into Transmit. Been into the advanced radio settings and changed various PTT settings but nothing has changed.
Also the S meter seems stuck at a fixed value S6, irrespective of the S value on the FT857. On V1.05 it did show the same value on the RSS as shown on the rig.
Now got Mumble working with a external USB sound fob.
Ver2 has sorted out all the screen sizes so I can adjust settings in Mumble WSJT-X  etc.

Still a few niggles, will keep trying with help from this group.


Howard Nurse, W6HN
 

Since the  FT-857 supports PTT by CAT, RigPi should do fine toggling it.  In Advanced Radio Settings, set CAT PTT to 'ON when transmitting.'  Set PTT Cmd to 'default.'  Restart the radio connection to have any changes registered.  If the radio doesn't respond,  there are additional tests we can run to isolate the problem.

Let's solve the PTT issue, then go on to the other problems you are having.  Since RigPi 2 uses the latest Hamlib library, there is always a possibility something needs further tweaking in Hamlib.  If that turns out to be the case, the Hamlib maintainers are very responsive with fixes once an issue has been reported.

--Howard


G8HAV
 

Hi Thanks for the reply. I have followed the instructions but it won't toggle on/off with the PTT button and neither using the T/R. 
Also I downloaded the Radio Won't connect rtf document and ran the php hamlibDo.php and got a list of lines under 'Undefined index'
They were line 6, lines 14-23. also got 'cannot create /var/log/rigpi-log' permission denied. Also got 'Unknown Rig No. and error cannot read frequency.
I do get RSS TUNER declaring it has connected FT857 and reads the frequency, but in FT8 it sometimes gets he frequency but drops it quickly.
FT8 also cannot read the audio card  I'm using 'default device as there are some eight variations of sound card listed.
When I click the speaker icon and it now saysUSB Pnp and is PCM (On V1.05 it was analogue)
Using RPI 4 2 GB.
Apologies for the list but I know it isn't easy as my linux knowledge of responses is limited. trying not to give in.


G8HAV
 

Hi Howard,
I have reloaded the SD card with the Pi2 image after formatting the card and now PTT works along with FT8. 
When moving to any band below 30 M when the TUNE on FT8 is pressed, RF must be getting into the RPI4 and it goes off.
Rebooting brings it back but the radio won't connect. I powered down the RPI4, waited 20 secs and powered up, but again the radio won't connect.
I guess the software must be corrupted as well. I need to get the RPI4 in a metal box and ground everything going in/out. I was running 10W and the RPI4 and radio are over a metre apart.
I had completed a J69 contact on FT8 with 10W from UK on 20 M.
Cheers