Topics

FLRig and RSS


KC9CBX
 

I'm trying to set up RSS to use FLRig for rig control. Being that I can see those settings under Basic and Advanced radio settings, I'm assuming that this is possible. However, I can't find any details on how to set this up, in RigPi Help or searching trough messages here.

I have FLRig working with my radio, no issues there. Now, how do I get RSS to talk to FLRig? Under radio settings in RSS, I can set Manufacturer to FLRig, Model to FLRig, and I'm assuming that's what they are supposed to be. Is RSS then supposed to communicate to FLRig via IP or some other way? What should be the port? Do I need to start FLRig manually before this will work or will it start automatically?

If all this is explained somewhere and I missed it, if you could point me in that direction, I'd appreciate it.

73,
Laris
KC9CBX


Howard Nurse, W6HN
 

Hi Laris,

Yes, Hamlib in RigPi can communicate with FLRIG.  Here is how to do that:

  1. Start FLRIG so it is controlling your radio.
  2. In Rigpi>SETTINGS>Advanced Radio set Manuf to FLRig, Radio to Flrig and R Port to 127.0.0.1:12345 and it should connect.

--Howard


KC9CBX
 

Thank you Howard! That worked!

However I did find a potential bug with this.

When the R Port is set to 127.0.0.1:12345, "Test Radio" button works and reports all the details about radio. Then, navigating over to "Tuner" tab I'm able to control the rig. So far, all this works well and as expected. Now, after all this is working, if I go back to the "Advanced Radio" under Settings, an error message pops" Radio Port Error" - "Radio port has been set to "None'. The specified port, 127.0.0.1:12345, was not found." Clicking OK, completely wipes out port settings. It looks like the whatever validation is done on the "R Port" filed, it does not recognize the IP:PORT format as a valid port.


Howard Nurse, W6HN
 

Here is a fix for the issue you found (127.0.0.1:12345 not recognized by Advanced Radio settings):

Open Terminal on the Raspberry Pi desktop.
cd /var/www/html
sudo nano settingsAdvanced.php
Scroll down to the line "if (response1.indexOf(response)==-1" ...
Change the last part of that line so it reads "if (response1.indexOf(response)==-1  && !parseInt(response)){
ctrl+o to write and ctrl+x to exit.

--Howard


KC9CBX
 

Hi Howard!

I'm assuming that you are referring to line 539 in that file.

In the version here, that line has another condition, checking if response is longer than 4, but that shouldn't matter since its all "and" and it looks like the goal was to add a condition that will return false and prevent that if statement from executing and subsequently error message from displaying.

I did add that extra condition that you suggested, but it didn't make any difference, I'm still seeing the same behavior, with the same error message, across two different browsers.

The final line looked like this:
if (response1.indexOf(response)==-1 && response.length>4 && !parseInt(response)){

Laris


Howard Nurse, W6HN
 

Hi Laris,

It turns out that parseInt(response) doesn't return a Boolean value if response is not a number.  Here is the entire revised line (527) that is working here.

if (response1.indexOf(response)==-1 && isNaN(parseInt(response))){

--Howard


KC9CBX
 

That one works! Thank you!