Topics

Connects if PTT is Red and can't turn off transmit #ic-7300


Andy
 

Rig - IC7300
Interface - USB Rate -115200
RPort /dev/tty/usb0
PTT - doesn't matter what is selected -None, ON on transmit or ON on Power On

Problem - Tuner GUI has PTT Red (Transmit Status) ON continuously 
Meter is pegged to the right 
Prior to connection, during connection and after disconnect

When connecting to the 7300, It will connect successfully but the PTT is RED 
and then the Rig is lock on transmit and will not go to receive. The RigPi reads the 
frequency and can change frequency. 

When status is disconnected, the T/R macro can toggle the PTT to OFF (black) & meter to left,
but will go to immediately go RED when Connect Radio is enabled and lock on the Transmitter.
The T/R macro will not turn off the transmitter or change the PTT GUI Status  
A disconnect has to be performed to turn off transmit but the PTT GUI remains red. 

Access can only be made via browser as the PI shortcut is not available on the Desktop.
(Same unit from a earlier thread - I was able to restore the admin acct)  

Any ideas?
Andy




Alex Cochran <jacj@...>
 

I have had this occur with my IC-7300 when the RigPi browser GUI was open on BOTH the local RigPi Linux system AND an external remote browser such as Safari, Firefox, or whatever.  To access RigPi from a remote browser, ensure that your local browser on your RigPi Linux system is NOT open.  Also, reboot your RigPi just to make sue everything is cleared.


Andy
 

Hi Alex, 

Thanks for the tips and will keep them on mind when I get back to it
For some reason the "PI" shortcut is not on the desktop so I've only been accessing from a remote session. 
Didn't think to just open the Chromium session on the RigPi itself.  
Tried Rebooting a few times, found that a reboot tended to make a configuration change work but not on 
this case.. 

Something might be up with this unit.
Thanks again . 


Andy
 

Follow-up. - Here's the situation and what got it working for this system.
Hope it helps if anyone is having the same problem.
The RED PTT button problem appears to be associated with a conflict when using the 
USB port for Audio and CAT Control 
This situation followed the rig to another RigPi. 
When using the CAT Control on the Remote CI-V Port at 19200 and disconnecting 
the USB Cable, the transmit problem went away AND the ability to establish a connection to the radio and control was achieved.
Here's what is working on this particular situation 
The following settings were used RPort /dev/ttyUSB0 (if that is what your USB > CI-V used)  Baud 19200 RRTS - HI, RDTR - Low all others were default or none. 
The RTS/DTR seems to have solved another transmit locking problem.  

Once the 7300/Rig Pi Command session is established then Mumble can be configured 
Plug in the USB port connecting the RigPi and 7300 
Open Mumble > go to Configure  > Settings > select [SysDefaultCard=CODEC] USB Audio Default Audio Device.
Use for both Input and output 

Not sure if this is a Version issue or not. 
Rig Pi - 1.05 
7300 - CPU 1.3, Front CPU 1.01, DSP 1.07, DSP Data 1.0, FPGA 1.13

If Powered Down or loss of connection the process that works is as follows...
Shutdown RigPi and turn off 7300 disconnect the USB Cable 
Turn on Rig Pi, then the 7300 
Start RigPi Software locally or with VNC, Log into your account and connect
to the radio. 
Connect the USB cable and start Mumble 
You can log out of the RigPi session and close if you want 
 - Don't forget to allow access to your microphone in the device's settings 
Start Mumble on your remote device
 - log into the RigPi Mumble server 
 - go to Self-Mute and then Un-mute, this will allow your session to stream
audio from your remote device back to the RigPi Mumble server.

Tried using WSJT and when Testing the CAT - The rig hangs up in Transmit 
a similar set up (separate CAT/ TR switching) might be needed as well. Might get a chance to test it but other stuff has come up 

73 
Andy

work out the issue but




 





Howard Nurse, W6HN
 

Hi Andy,

Your description suggests that RTS is enabled for PTT in your IC-7300. To prevent this from happening you can disable PTT via RTS/DTR in the radio, or change the RTS/DTR settings in RigPi (as you have done).

—Howard


Andy
 

Hi Howard 
Thanks for the info on RTS. 
Is there some reason why the CAT and Audio are not supported
together on the USB interface in this case?
The Connection Settings appear to match what has been published. 
Version? Missed something?
It is a loaner rig, didn’t want to go too far changing settings. Doing this development for my club. There is a 706mk2g on the RSS running WSJT as well using the RigPi CODEC.
Thanks 
Andy


Howard Nurse, W6HN
 
Edited

Hi Andy,

I don't know of any problems with support for radios that carry CAT and Audio on the same USB cable.  All is well here with my IC-7300 as well.

You mentioned in your first message that the radio goes into transmit once the cable is connected.  If the RTS line is high on the cable when you plug it in and the RTS option for PTT in the IC-7300 is enabled, what you are seeing is consistent.  In RigPi you have the option of setting RTS low permanently.  That should prevent the 7300 from going into transmit via RTS when radio's RTS PTT (Send) is enabled.

--Howard


Andy
 

HI Howard, 

We are on-line! 
The RSS/RigPi and 7300 are working with the USB interface on 
Audio & CAT. Came across the 7300's RTS setting buried in the Menu and it was
Enabled.  CW is working as well from the Key Output to the Key Line In on the Radio.  
Look forward to running the system. Nice Job. 
Thanks for the help. 
Andy 


Fernando .
 

Hello Andy, I'm having the same issue with the PTT and cannot TX audio either, did you find the issue?

thanks
fer