Topics

sticky Connecting Icom radios to RigPi


Howard Nurse, W6HN
 
Edited

Here are steps to take to connect to most Icom radios for CAT control.  These steps do not cover audio, which will be covered in a separate Topic.

  1. In the Icom radio menu, turn OFF CI-V Transceive.
  2. In the Icom radio menu, turn OFF AutoBaud and set it to the highest possible value.
  3. If your radio has a USB connection, check the radio menu options for anything to do with setting the CAT to the CI-V port or the USB port and make sure it is set to USB.
  4. In RigPi use the Basic Radio settings to try to connect.
  5. If Basic Radio doesn’t connect, try Advanced Settings and use the Test Radio button.
  6. In the resulting report, check the -r argument to make sure it is the USB port used by the radio.  Normally this is /dev/ttyUSB0
  7. If no connection, try setting the Baud rate to the value you used in the radio menu.
  8. No other changes to the default settings should be necessary.

If you continue to have problems, reboot and try again.

Make note of the radio model number you see in the Test Radio report, it is -m xxx where xxx is the Hamlib radio model number.  It will be used next.

  1. Next, reboot and open Terminal (black icon, top left) in the Raspberry Pi desktop. You can get to the desktop by connecting a monitor, keyboard and mouse to RigPi.
  2. In Terminal, type:  rigctl -m xxx -r /dev/ttyUSB0
  3. If you see the prompt Command:, type f.
  4. You should see the radio frequency returned, and the Hamlib library is working.
  5. If you se an error, type Q to quit.
  6. Restart using the command: rigctl -m xxx -r /dev/ttyUSB0 -vvvvv (the v’s start rigctl in the debug mode)
  7. Use f and look at the report to see if any clues are provided.

  1. If all else fails, can you control the radio with any other software.  You are welcome to download the 30-day free demo version of CommCat for Windows, http://commcat.com/ccldownloads.php, or use any other program (such as HRD) to make sure the radio settings, cable and radio functioning are OK.
  2. Try resetting the radio.

This topic will be updated as we learn more.  You will also find flow charts in the Files section that show you the steps to take in a different format.  RigPi Help has a Troubleshooting section that will also help connecting radios.

73, Howard W6HN


Manuel Maseda
 

Radio CI-V number in advanced settings has to be entered in decimal not hex.


w4jcb
 

I just purchased a Valley Enterprises ICOM CI-V CT-17 cable that requires me to load different ftdi driver than ftdi_sio and usbserial which are default. Can someone point me to the correct CI-V cable that will work with RigPi /Linux?

Trying to connect an IC-7000 or RigPi.

73, W4JCB Carlton


Frank VE3FBZ
 

My list, from MFJ website says MFJ-5713DI
13 pin DIN Accessory Port Connector. List ic-7000 among others.
Check link under MFJ-1234  listing.


 Regards and 73s
VE3FBZ
London Amateur Radio Club




On Jul 6, 2019, at 15:17, carlton@... wrote:

I just purchased a Valley Enterprises ICOM CI-V CT-17 cable that requires me to load different ftdi driver than ftdi_sio and usbserial which are default. Can someone point me to the correct CI-V cable that will work with RigPi /Linux?

Trying to connect an IC-7000 or RigPi.

73, W4JCB Carlton


w4jcb
 

Hey Frank,

Thanks for the reply. What I am needing is the CT-V cable that turns USB to TTL for my IC-7000. I do already have the MFJ-5713DI cable and it seems to do fine with the audio. What I am looking for is rig control.

73 W4JCB Carlton


Mark Weisheimer
 

Carlton,

I am no expert on Icom cables, but I would have expected the Valley Enterprises CT-17 to be recognized.
It says that it is a FTDI based cable and the FTDI drivers are in RigPi.
I have used several FTDI based cables (though not CI/V) and they were always recognized as /dev/ttyUSB0 when they were the only USB serial cable plugged in.
Have you tried using the USB ID app that is located on the desktop of the Raspbian RigPi?
That app sets the identity to Radio1 (and moves up the number chain for each new instance) and is handy for finding "lost" serial USB ports.

https://rigpi.net/help/

Look under Other Programs, then USB ID.

There are users here who have used the RT Systems CI/V cable without drivers or difficulty, so that one is known to work.
Setting the Icom ID (varies with radio model) and matching the baud rate of the USB device to the baud of the radio are necessary.

--
73 - Mark - K8MHW
'A RigPi Enthusiast...since April 23, 2019!' - I am not otherwise affiliated with MFJ or RigPi


w4jcb
 
Edited

Hello All, 

My RigPi is now working. I am ashamed to say this hopefully it will help others. This cable WILL work just like it is without any Linux mods. I did not want to reset my IC-7000 because of not having a backup. But that is what fixed my problem. 

Thanks to all that reached out to me.

73 W4JCB Carlton


H2orescuemedic@...
 

ERROR: Rig control not started.

 I received my MFJ1234 today and so far the only problem I have is getting it to connect to the radio.  I am running a ICOM-7000, And I am using the MFJ-5713DI cable that was shipped with the unit. So far I have

 Turned off the CI-V Transceive on the OTH menu of the ic7000

  1. Set the Baud rate from 9600 to 19200 to auto, and set the same on RigPi trying all setting
  2. The R Port always says “None” Its like it can’t see the radio.
  3. K Port showed “/dev/ttyS0
  4. I have tried to use the USB ID button on the desk top but it never returns a message of any kind, Make me wonder if its seeing my radio.
  5. I typed in the command line : Rigctl -m IC-7000 -r /dev/ttyUSB0 r says

Rig_init called
Dummy:  _init called
rig_register called
rig_register: rig)register (1)
rig_register called
rig_register: rig)register (2)
rig_register called
rig_register: rig)register (3)
rig_register called
rig_register: rig)register (4)
rig_register called
rig_register: rig)register (5)
Unknown rig num 0, or initialization error.
Please check with  --list

 

I am stuck at the moment, Looking for any tips or tricks to get this connected to the radio. Is there a way on raspberry pi to see the comports or reset them I am wondering if by hitting the usb id button its made the 5 registers, If so how do I delete them and start over?  

 

Thanks for any help

KE0LKV


Howard Nurse, W6HN
 

Welcome to the forum!

Form your description I'm wondering if you have connected a CAT cable from the radio to RigPi?  Your IC-7000 provides a jack for a CI-V cable.  You will need a CI-V adapter cable that has a USB connector on the other end.  Several have been suggested here on the forum, but they are available from many sources.  Here is one from Amazon that seems to be highly rated:

https://www.amazon.com/Valley-Enterprises-Chipset-Control-Programming/dp/B003OJAXWY/ref=sr_1_4?keywords=ci-v+cable&qid=1565996080&s=gateway&sr=8-4

(I've had no experience with any CI-V cables, so check carefully.)

73, Howard W6HN


H2orescuemedic@...
 

You were 100% correct, I missed that part in the directions. I had that cable from my signal link box and it connected great once I plugged it in, as of right now it is connected and transmits no audio, it has no audio on transmit and receives has 0 volume so I am sure I got a plug in the wrong spot. Thanks again you help me a ton, I am sure this box is going to be a ton of fun.  I am beginning to think my 1/8 jack stereo cable needs to be switched out for a mono cable. I have double checked and even flipped them to make sure they are in the right spot but as of now its so close to working.

thanks again

KE0LKV


Bo Barry <bobarr@...>
 

99% sure ECHO ON has to be set in the Icom. One of my programs maybe Wiin4Icom turns it off. 
Bo W4GHV


Mac Jedi
 

Just wondering if anyone has figured out how to make the IC-7000 work with RSS especially if one can use USB to the 1/8 mono programming adapter cable?  Or if a signal link cable can be used with the RJ45 ans what jumper settings would do the trick.  Control and audio would be nice if they both could be performed through USB.  Anyone with success yet?


Mac Jedi
 

Let me answer my own question as it stands so far...   Use a USB to 1/8 in mono jack into the radio and the other end to the Rigpi.  The audio will not work on the USB as the radio does not have an internal CODEC.  So the next step is trying to get the right step for audio.  So far it is said that a Signal link cable RJ45 to din 6 should work and supposedly the MFJ 1204 manual has jumper setting that should work.  With that idea I have gotten audio from radio but no squelch on the signal and no transmit yet.  Not looking good for the din 6 port.


Kelehigh@...
 

See my message re: similar problem w/ Icom ic-718 ; upshot is that I was told by MFJ I needed to purchase a usb/rtso1 programming cable to go from the back of the radio to a usb slot on the rigpi. The cable I that I needed  was not provided in the original kit.


richard_sudweeks@...
 

We are trying to connect an Icom IC-775DSP to a RigPi using the MFJ-5708P cable. The cable came with a jumper chip, which looks like the one listed for the IC-775 in this document (https://groups.io/g/RigPi/files/RigPi%20Documentation/RadioPinConnectorsSheet.pdf). We placed the jumper chip in the slot on the audio board in the RigPi, attached the MFJ-5708P to the MIC jack on the radio and the other end into the Audio jack on the RigPi. We connected a cord from the headphones jack on the radio to the RX in plug on the RigPi. The RigPi is connected by ethernet cable to out internet router. We can pull up the rigpi.local setup screen using a laptop on the same network. When trying to set up the radio we picked SETTINGS>Basic Radio and selected Icom 775. Then pushing "Connect radio" we get two arrows that spin for a few seconds and then nothing. Usually no error message (some settings we see a pop-up screen that says "RigPi says" and there is no other message) or anything else appears, but at the bottom of the browser screen in red it still says "No Radio". We have tried going to SETTINGS>Advanced Radio and setting the CI-V to off, tried using every possible Baud speed but still can't get any connection. Here are the current results of the "Test Radio" function:


Mark Weisheimer
 

You have selected /dev/ttyUSB0 for the serial port that will handle CAT via a CI-V cable.
Which CI-V cable are you using, you don't mention it?
What is the CI-V baud rate? Baud needs to match in both the RigPi and in the radios menu settings.


--
73 - Mark - K8MHW
'A RigPi Enthusiast!' - I am not otherwise affiliated with MFJ or RigPi


Perry Ogletree
 

You need a CI-V cable from the RPi to the radio for CAT control (usually a 1/8” phone plug or RCA type plug).  You can get USB to CI-V cables from many sources but the “gold” standard is the cable by RT Systems.  I’ve had mixed luck with the cheap Chinese versions. Some work, some don’t…

The cable you have is only for audio I/O and PTT between the RPi and the rig.

 

Perry K4PWO

 

From: RigPi@groups.io <RigPi@groups.io> On Behalf Of richard_sudweeks@...
Sent: Saturday, November 16, 2019 02:36 PM
To: RigPi@groups.io
Subject: Re: [RigPi] Connecting Icom radios to RigPi

 

We are trying to connect an Icom IC-775DSP to a RigPi using the MFJ-5708P cable. The cable came with a jumper chip, which looks like the one listed for the IC-775 in this document (https://groups.io/g/RigPi/files/RigPi%20Documentation/RadioPinConnectorsSheet.pdf). We placed the jumper chip in the slot on the audio board in the RigPi, attached the MFJ-5708P to the MIC jack on the radio and the other end into the Audio jack on the RigPi. We connected a cord from the headphones jack on the radio to the RX in plug on the RigPi. The RigPi is connected by ethernet cable to out internet router. We can pull up the rigpi.local setup screen using a laptop on the same network. When trying to set up the radio we picked SETTINGS>Basic Radio and selected Icom 775. Then pushing "Connect radio" we get two arrows that spin for a few seconds and then nothing. Usually no error message (some settings we see a pop-up screen that says "RigPi says" and there is no other message) or anything else appears, but at the bottom of the browser screen in red it still says "No Radio". We have tried going to SETTINGS>Advanced Radio and setting the CI-V to off, tried using every possible Baud speed but still can't get any connection. Here are the current results of the "Test Radio" function:

Radio Connection

OK

TEST MODE Radio: 1
User: KE7XP
Radio: 1
User: KE7XP
Radio from settings: 1
Port from settings: /dev/ttyUSB0
ID from settings: 330
RigDo.php rigDoPID from settings: 4681
service_port: 4532
To see any error details, click Disconnect Radio then start rigctld in Terminal with this line:

rigctld -m 330 -r /dev/ttyUSB0 -t 4532 -s 19200 --civaddr off > /dev/null 2>&1 &

rigctld processes running:

www-data 2080 0.0 0.3 14728 3696 ? S 12:00 0:00 rigctld -m 330 -r /dev/ttyUSB0 -t 4532

Error connecting to radio (RPRT -5)(0). Check radio connection and settings. Is the radio powered up? Please try again.


Any suggestions from anyone on setting this up on an older Icom rig?



Neil K6NCX
 


I understand that "most Icom radios" means most Icom radios. But specifically, does that include IC-7100?And what physical cable do I need?


Ken N3KF
 
Edited

I have an Icom 756pro2. Thought it was a 3 but it's not. Should be the same Cat or CI-V  wise. Anyway the settings done and the rig indeed connects. Frequencies are shown. However, the radio sits there switching VFOs. It's like I would be continually hitting the VFO button to swap them. Anyone have any ideas? Short of that, is there a place I can see the CI-V commands that are being passed down? I'm assuming that hamlib is polling the rig continuously and maybe swapping VFOs to read the non main one?????  Never saw this in any other software. Thanks...

Should note settings on the radio are correct and CI-V transceive is off...


Howard Nurse, W6HN
 

Hi Ken,

Go to SETTINGS>Advanced Radio and put a check in Disable Split Polling. Disconnect/Connect your radio and all will be well.

73, Howard W6HN