Topics

sticky Configuring Mumble for radio CODEC audio with specifics for the Icom IC-7300


Howard Nurse, W6HN
 
Edited

This is a modified version of the message I posted several weeks ago to help with setting up a radio that has internal CODEC's for use with RigPi.  Specific instructions are provided for the Icom IC-7300, including CAT settings.

Special thanks to Harold, W5ZZT, whose sleuthing and testing contributed greatly to the IC-7300 and CODEC/Mumble settings recommendations listed below.

Using a Radio Audio CODEC in RigPi

Log into the Raspberry Pi Desktop by connecting a monitor to the HDMI connector on RigPi along with a USB Keyboard and Mouse, or use VNC Viewer from another computer.  If the latter, here are the settings to use on VNC Viewer:

  • VNC Server: 192.168.xx.yy  (You can get the correct IP from the LAN IP 1 box on RigPi>SETTINGS>System.)
  • Name: RigPi
  • Username: pi
  • Password: 7388
You will see the RigPi Mumble client window. In the caption bar you will see Mumble -- 1.2.18-1+deb9u1.  This window is the client that connects your radio to the Murmur server in RigPi.  If you don't see the window, open Mumble from the (Raspberry top left) Program menu>Internet>Mumble.

  1. Click Configure>Settings from the Menu bar on Mumble.
  2. Put a check in the Advanced checkbox in the bottom left side of the window.
  3. In the Audio Input Device box you will see the Injector device.  Change that setting to [default].
  4. Click Apply
  5. Click Audio Output in the Mumble settings list on the left.
  6. Select [default] in the Device list.
  7. Click Apply, then OK
  8. Close Mumble by clicking the X in the upper right corner of the Mumble window, or from the Mumble Menu bar, Server>Disconnect.
Now choose the device to be the RigPi Default device by right-clicking the Speaker icon, top right on the RigPi Desktop, and selecting the device you want to use.  If your radio has internal CODEC's and the USB cable is connected to RigPi you will see USB Audio CODEC in the list. Select USB Audio CODEC.

RigPi and Mumble will work with any valid Audio CODEC data coming over a USB cable.  If you don't see it by right-clicking the RigPi Speaker icon, something else is wrong.  RigPi should work with the Elecraft K3S, Icom, Kenwood or any other newer radios that have internal CODECs.  Expect additional settings required in your radio's menu to route SSB audio to/from the USB cable...there will be differences from one radio model to another.

Additional Mumble Settings

Jitter in data timing over the Internet can create scratchy sounding transmit audio.  Mumble has a way to reduce the effects of timing jitter.

  1. Open Mumble>Configuration from the Mumble Menu bar.
  2. Put a check in Advanced at the lower left corner of the Mumble Configuration Audio Input window.
  3. Open the Audio Output settings window from the list on the left.
  4. Note the two sliders, Default Jitter Buffer and Output Delay.

The slider settings for your setup may differ, but start with the Default Jitter and Output Delay set to 50 ms.  Test your transmit audio.  If it sounds good, you can try reducing the two sliders, one at a time, until you start to hear distortion.  Increase the slider levels one at a time and try again.

You may have to adjust the USB CODEC Playback level if your transmit audio is too hot.  The easiest way to do that is by right-clicking over the Speaker icon on the RigPi Desktop and selecting USB Device Settings... If the sliders don't appear, click Select Controls... and see if you can add them.

Mumble was designed for online gaming and noise suppression is built-in.  To turn off noise suppression (we hams love noise, after all!), open the Mumble Configuration window and make sure the Advanced option is checked.  In the Audio Processing group, set the Noise Suppression slider all the way to the left to turn off this function.  If you are listening to audio that is all noise with no signals, the audio may sound "watery." This is a peculiarity of Mumble that hints that noise suppression is not completely off even though the settings indicate otherwise.  Remember to restart Mumble to have any settings made permanent.

IC-7300 Radio Settings to use for CAT and CODEC's

  1. Tap MENU>Set>Connectors on the radio
  2. DATA OFF MOD> MIC/USB or USB
  3. DATA MOD>USB (for digital modes Fldigi, WSJT-X, etc.)
  4. CI-V
  5. CI-V Transceive>OFF (to prevent unrequested data)
  6. CI-V USB Port Unlink from [REMOTE] (to allow higher Baud rates)
  7. CI-V USB Baud Rate>115200 (fastest possible)
  8. CI-V USB Echo Back>ON (RigPi required for RigPi CAT control)
  9. Leave all other settings at their default level.
RigPi Settings for the IC-7300

The Hamlib library normally defaults to the highest Baud rate supported by the radio.  In the case of the IC-7300, the Baud default must be changed.

  1. In RigPi, open SETTINGS>Advanced Radio
  2. Make the following selections
  3. Manuf: Icom
  4. Radio: IC-7300
  5. R Port: /dev/ttyUSB0
  6. Baud: 115200
  7. Leave all other settings on their defaults
  8. Click Connect Radio
  9. Enjoy!

73, Howard W6HN


gkimbler@Columbus.RR.com
 


Hi Howard,
I followed your instructions including having USB Audio CODEC selected at the speaker icon and I still do not have receive audio on my 7300 and the transmit audio sounds very scratchy. I even restored the radio to its factory settings and it is still a no go!


Howard Nurse, W6HN
 

In summary, you changed the two settings in Mumble to CODECs and selected CODEC in the Speaker dropdown, correct?  Try rebooting RigPi from the system settings window.

 

Perhaps one of the other 7300 users has gone through the same route and has had success.  Let’s see who we hear from.

 

73, Howard W6HN

 

From: RigPi@groups.io [mailto:RigPi@groups.io] On Behalf Of gkimbler@...
Sent: Thursday, May 23, 2019 3:37 PM
To: RigPi@groups.io
Subject: Re: [RigPi] Configuring Mumble on RigPi for alternate audio devices

 


Hi Howard,
I followed your instructions including having USB Audio CODEC selected at the speaker icon and I still do not have receive audio on my 7300 and the transmit audio sounds very scratchy. I even restored the radio to its factory settings and it is still a no go!


gkimbler@Columbus.RR.com
 

I have already tried rebooting both the RigPi and the 7300. It is likely something very simple. Hopefully one of us will find the answer.


gkimbler@Columbus.RR.com
 

BTW, your instructions say to change the audio input and output devices in Mumble to default. That is where I am at now.


jlwyke@...
 

I really hope someone with an IC-7300 can give us step-by-step instructions on how to get rx and tx audio working... I am at wits-end!  THANKS IN ADVANCE! 
Howard... we appreciate your work and your efforts to help us. 

73 from Jeff, KJ7EFF


Howard Nurse, W6HN
 

Hi Jeff, and welcome!

Have you been able to follow the steps in the first message in this thread?  If so tell use what you are (or are not) seeing.

73, Howard W6HN


jlwyke@...
 

Howard, I have been trying to follow your suggestions - along with so many of the other ones, too.  The bottom line is just NO audio! I spent the best part of the day working with it.  I get to the point where I feel like I've tried everything possible, but no luck. The sound issue is the only thing I am having trouble with.  It seems to be a common issue on this thread. 

Jeff


Howard Nurse, W6HN
 

Hi Jeff,

 

We’ve just learned through the careful work of a user that the main culprit in the 7300 audio issue is the two settings in the Mumble client.  I assume you have tried changing those two settings to [default].  This has worked for several users, but there may be other settings in the 7300 that are getting in the way.

 

Since I just put up the detailed list this morning, there hasn’t been a chance to get feedback from many others.

 

--Howard

 

From: RigPi@groups.io [mailto:RigPi@groups.io] On Behalf Of jlwyke@...
Sent: Thursday, May 23, 2019 5:06 PM
To: RigPi@groups.io
Subject: Re: [RigPi] Configuring Mumble on RigPi for alternate audio devices

 

Howard, I have been trying to follow your suggestions - along with so many of the other ones, too.  The bottom line is just NO audio! I spent the best part of the day working with it.  I get to the point where I feel like I've tried everything possible, but no luck. The sound issue is the only thing I am having trouble with.  It seems to be a common issue on this thread. 

Jeff


jlwyke@...
 

Thanks, Howard.  I will get back into it tomorrow after I clear my head... lol... and maybe some other 7300 users will chime in.  I appreciate your help. Can't wait to get this working!  73 and have a great evening! 
Jeff


Barry WØIY
 

I found that after making alsamixer and Mumble changes (using VNC to access the pi), it is necessary to MINIMIZE these window (do not close them or the process gets killed).
--
Barry w0iy


jlwyke@...
 

Was finally able to get receive audio working fro IC-7300, but transmit audio is a mess.  Anyone know the settings for Mumble and/or the 7300 to produce acceptable transmit audio from the remote device?  Thanks! 
Jeff, KJ7EFF


Howard Nurse, W6HN
 

Jeff, we are really close.  I have it working with my 7300, and Harold, W5ZZT has been working with me on his.  It appears mostly to be a matter of settings in the 7300.  Details to follow once we have it nailed.

 

73, Howard W6HN

 

From: RigPi@groups.io [mailto:RigPi@groups.io] On Behalf Of jlwyke@...
Sent: Sunday, May 26, 2019 6:19 PM
To: RigPi@groups.io
Subject: Re: [RigPi] Configuring Mumble on RigPi for alternate audio devices

 

Was finally able to get receive audio working fro IC-7300, but transmit audio is a mess.  Anyone know the settings for Mumble and/or the 7300 to produce acceptable transmit audio from the remote device?  Thanks! 
Jeff, KJ7EFF


jlwyke@...
 

Thanks, Howard.  I tinkered with the 7300 settings, but apparently not enough... lol.  Will be patient and look forward to hearing from you.  73.
Jeff

On Sun, May 26, 2019, 8:23 PM Howard Nurse, W6HN <hlnurse@...> wrote:

Jeff, we are really close.  I have it working with my 7300, and Harold, W5ZZT has been working with me on his.  It appears mostly to be a matter of settings in the 7300.  Details to follow once we have it nailed.

 

73, Howard W6HN

 

From: RigPi@groups.io [mailto:RigPi@groups.io] On Behalf Of jlwyke@...
Sent: Sunday, May 26, 2019 6:19 PM
To: RigPi@groups.io
Subject: Re: [RigPi] Configuring Mumble on RigPi for alternate audio devices

 

Was finally able to get receive audio working fro IC-7300, but transmit audio is a mess.  Anyone know the settings for Mumble and/or the 7300 to produce acceptable transmit audio from the remote device?  Thanks! 
Jeff, KJ7EFF


Jeffrey Wyke <jlwyke@...>
 

Thank you, Harold.  I emailed you.  I appreciate your help.
Jeff

On Sun, May 26, 2019, 11:33 PM Harold Rosee <wa5zzt@...> wrote:
Jeff,

See my post to Alex.  I can get you going offline by email or phone if you still need help but read my reply to him first,

Harold
W5ZZT


From: RigPi@groups.io <RigPi@groups.io> on behalf of jlwyke@... <jlwyke@...>
Sent: Sunday, May 26, 2019 8:19 PM
To: RigPi@groups.io
Subject: Re: [RigPi] Configuring Mumble on RigPi for alternate audio devices
 
Was finally able to get receive audio working fro IC-7300, but transmit audio is a mess.  Anyone know the settings for Mumble and/or the 7300 to produce acceptable transmit audio from the remote device?  Thanks! 
Jeff, KJ7EFF


Barry WØIY
 

Harold
Please provide a message number for the reference in #514.
Thanks
barry w0iy

--
Barry w0iy


Tony Lipari
 

I must be missing a step I can hear the radio key up but it still wont show up as connected. I am I missing a setting from somewhere else?
--
Tony k2fpc


Howard Nurse, W6HN
 

Tony, have you set Transmit settings in Mumble in both RigPi and your mobile device to “Continuous?”

73, Howard W6HN


Tony Lipari
 

I  am not sure how I did this but Mumble is trying to connect to a proxy server / but it keeps failing . I do not know the program at all I have read the posts still not clear. Looking for a the address and detailed steps. I read the quick start manual it helped but my problem is not listed.
--
Tony k2fpc


Harold Rosee <wa5zzt@...>
 

Tony,

Can you be a little more specific?   It this the client on the RigPi itself or when you are connecting from s phone/pc.  


On Jun 24, 2019, at 6:57 AM, "tlipari@..." <tlipari@...> wrote:

I  am not sure how I did this but Mumble is trying to connect to a proxy server / but it keeps failing . I do not know the program at all I have read the posts still not clear. Looking for a the address and detailed steps. I read the quick start manual it helped but my problem is not listed.
--
Tony k2fpc