Topics

Getting my FT-857 working again without Alsamixer, now with Pulse Audio only, #ft-857d #yaesu #alsamixer #pulseaudio #version 2 #yaesu #ft-857d #pulseaudio #version #alsamixer


Mark Schroeder, W7KHZ
 

Right or wrong, here is information how I have my new version 2 (downloaded 12/8/2020) of RigPi configured for receive audio. To note, its easy to get a lot of audio pushed by using "MIC BOOST", but it creates an obnoxious amount of noise. Please see the attached screenshots for my settings. I am using the data jack on the radio as the I/O.
  

I am always looking for better settings......


Kent K9EZ
 

On the 857, the mic cable... is it s straight through RJ11?  I have yet to find the correct pin outs.  Thank you!

Kent K9EZ


On Wed, Dec 9, 2020 at 7:58 AM Mark Schroeder, W7KHZ <w7khz@...> wrote:
Right or wrong, here is information how I have my new version 2 (downloaded 12/8/2020) of RigPi configured for receive audio. To note, its easy to get a lot of audio pushed by using "MIC BOOST", but it creates an obnoxious amount of noise. Please see the attached screenshots for my settings. I am using the data jack on the radio as the I/O.
  

I am always looking for better settings......


Mark Schroeder, W7KHZ
 

But, alas, I am stuck with trying to get audio out of the Mumble server on the Pi and through the audio card in the Pi, using the PulseAudio application. I could sure use some help on this one.
I know I have audio out of my local Mumble client(s) and over to the RigPi Mumble server/client as I am getting a response on the client screen under my client name.
The Mumble client Audio Output config on the RigPi is still only showing the "OSS" and "ALSA" options. Have attempted to use all the device options to see if I could get lucky.
Anyone have helpful advice?


Mark Schroeder, W7KHZ
 

No, I am using the data cable on the back of the radio and run the radio in packet mode. It works for FM radio comms without any problem. You have to make sure that you have your radio menu set for 1200 and not 9600 packet data.
Here is a link to a good article about this:
https://pa1ejo.wordpress.com/2019/06/30/mfj-rigpi-station-server/
>Mark<


Mark Schroeder, W7KHZ
 

Additional information / update on my progress.
Going through the threads led me to one that describes loading up a new app and rebooting the Pi. (reference Bruce N7GXR, post # 7557 on 12/7).

The terminal command to load the app is: sudo apt-get install pavucontrol paprefs

After a reboot, this now bring Pulse in as one of the manageable options in Mumble (still using v 1.3.0). 

But, I am not seeing the same type of setting options that Bruce is describing. Hopefully this modification to the RigPi platform is likely the next change in the 2.0 release or it is listed as a required step(?). I have not been successful yet in getting my Mumble client on the RigPi to mange the audio card yet either way, so it will be trial and error for now. Hopefully the trials will win out. I will post up snapshots of how I was able to configure each screen, if successful. At any point, if someone has a clear configuration roadmap to success, I would greatly appreciate it. I literally need left turn and right turn directions to take me to the right spot as I do not have a diagram that lays out how all the audio devices and paths are mapped out.

Thanks!


Bruce N7XGR
 

Mark,  Are you seeing this?
Now onto the Mumble config, I found for my setup the following, Configure>Settings.
For the Input and Output select System ALSA and [pulse] Pulse Sound Server in the dropdown.
On the Audio input setup, Transmission, select Voice Activity and move all three sliders
all the way to the LEFT, Click apply then shut down Mumble then restart Mumble.
Doing this eliminated very bad chopping in the RX audio because of the slider settings.

Bruce  N7XGR

On Wed, Dec 9, 2020 at 1:27 PM Mark Schroeder, W7KHZ <w7khz@...> wrote:
Additional information / update on my progress.
Going through the threads led me to one that describes loading up a new app and rebooting the Pi. (reference Bruce N7GXR, post # 7557 on 12/7).

The terminal command to load the app is: sudo apt-get install pavucontrol paprefs

After a reboot, this now bring Pulse in as one of the manageable options in Mumble (still using v 1.3.0). 

But, I am not seeing the same type of setting options that Bruce is describing. Hopefully this modification to the RigPi platform is likely the next change in the 2.0 release or it is listed as a required step(?). I have not been successful yet in getting my Mumble client on the RigPi to mange the audio card yet either way, so it will be trial and error for now. Hopefully the trials will win out. I will post up snapshots of how I was able to configure each screen, if successful. At any point, if someone has a clear configuration roadmap to success, I would greatly appreciate it. I literally need left turn and right turn directions to take me to the right spot as I do not have a diagram that lays out how all the audio devices and paths are mapped out.

Thanks!


Glenn VE9GJ
 

Hi Mark
 
I haven't tried out the new Raspberry PI OS myself yet but have used Pulse Audio with raspbian in the past
In a terminal what does
apt policy alsa-utils
say?
If it is not installed you can do a
 
sudo apt install alsa-utils
 
This will install alsamixer for you.  Not sure if this will make an icon in the menu or not but you will be able to run it from a terminal.
 
73
Glenn VE9GJ
 

On 2020-12-09 08:58, Mark Schroeder, W7KHZ wrote:
Right or wrong, here is information how I have my new version 2
(downloaded 12/8/2020) of RigPi configured for receive audio. To note,
its easy to get a lot of audio pushed by using "MIC BOOST", but it
creates an obnoxious amount of noise. Please see the attached
screenshots for my settings. I am using the data jack on the radio as
the I/O.

I am always looking for better settings......
Links:
------
[1] https://groups.io/g/RigPi/message/7570
[2] https://groups.io/mt/78828035/164950
[3] https://groups.io/g/RigPi/post
[4] https://groups.io/g/RigPi/mutehashtag/pulseaudio
[5] https://groups.io/g/RigPi/mutehashtag/version
[6] https://groups.io/g/RigPi/mutehashtag/ft-857d
[7] https://groups.io/g/RigPi/mutehashtag/yaesu
[8] https://groups.io/g/RigPi/mutehashtag/alsamixer
[9] https://groups.io/g/RigPi/editsub/164950
[10] https://groups.io/g/RigPi/leave/defanged


Mark Schroeder, W7KHZ
 

Thanks Glenn. It shows:

alsa-utils:
  Installed: 1.1.8-2
  Candidate: 1.1.8-2
  Version table:
 *** 1.1.8-2 500
        500 http://raspbian.raspberrypi.org/raspbian buster/main armhf Packages
        100 /var/lib/dpkg/status
 
It looks like I have access back to the Alsamixer after installing the Pulse audio thingamajig that Bruce described earlier. But since "they" appear to be dumping Alsamixer, I was hoping to get the Pulse audio and GUI working. Looking forward to hearing what Howard or others may have going on in the background on this.....


Glenn VE9GJ
 

You can still check alsamixer levels with pulse installed.  It is kind of like a set and forget. Pulse Audio still works with alsa, it jsut "sits" on top of it and normally you do not need to deal with alsa just pulse.  That said I have had to set alsamixer levels in the past on occasion when Pulse levels just couldn't go high enough.
Glenn
 

On 2020-12-09 15:27, Mark Schroeder, W7KHZ wrote:
Thanks Glenn. It shows:

alsa-utils:
  Installed: 1.1.8-2
  Candidate: 1.1.8-2
  Version table:
 *** 1.1.8-2 500
        500 http://raspbian.raspberrypi.org/raspbian buster/main armhf
Packages
        100 /var/lib/dpkg/status
  It looks like I have access back to the Alsamixer after installing
the Pulse audio thingamajig that Bruce described earlier. But since
"they" appear to be dumping Alsamixer, I was hoping to get the Pulse
audio and GUI working. Looking forward to hearing what Howard or
others may have going on in the background on this.....
Links:
------
[1] https://groups.io/g/RigPi/message/7578
[2] https://groups.io/mt/78828035/164950
[3] https://groups.io/g/RigPi/post
[4] https://groups.io/g/RigPi/mutehashtag/yaesu
[5] https://groups.io/g/RigPi/mutehashtag/ft-857d
[6] https://groups.io/g/RigPi/mutehashtag/pulseaudio
[7] https://groups.io/g/RigPi/mutehashtag/version
[8] https://groups.io/g/RigPi/mutehashtag/alsamixer
[9] https://groups.io/g/RigPi/editsub/164950
[10] https://groups.io/g/RigPi/leave/defanged


Mark Schroeder, W7KHZ
 

So, after stepping aside to work on the RigPi Macros for a different radio, I finally returned to this problem. Important to note that:
  • When selecting Pulse for both Audio Input  in Mumble Client, the Mumble client locks up and the RigPi required a reboot in order to restart the Mumble client. Selecting audio Output seems to work OK.
  • The Alsamixer is still the tool that needs to run in order to get audio properly through the card. Thanks for the info about getting it reinstalled and previous config info purged.
  • For my FT-857and also for my FT-847, the "winning" settings are in the snapshots below, using the packet/data interface on the radio for audio and a CAT connection






Hopefully some of this info is helpful to users and developers while going through this experience with my recent download and upgrade of my RigPi (3B). It seems to be working now as well as before. I am looking forward to exploring other options now.


Mark Schroeder, W7KHZ
 

FYI. The pictures in my message (that can not really be seen in the message) are much more visible in the notes I have added in two different FILES groups for the
FT-847 and FT-857
( https://groups.io/g/RigPi/files/FT-847%20Config%20and%20Macros/FT-847-857%20notes%20on%2012082020%20V%202.0%20upgrade%20with%20Alsamixer%20and%20Pulse%20Audio%20problems.pdf