Topics

RigPi Audio Driver "autoinjector" Not Appearing in Pi or Mumble setup - 2nd RigPi to show this.. #rigpi #audio #multiple


Steve_KE4LC
 

Hello group.  I'm a reasonably experienced RPi user, however I am having a very difficult time setting up my RigPi audio drivers on the RPi and Mumble server as instructed.   I have have swapped for new SD cards as well as a completely new RigPi.  This project is to support a remote access rig for my 93 year old dad AA2F so he can maintain his lifelong hobby.

Here is the problem:  The listed input/output driver programs in all RigPi setup instructions are [hw:CARDautoinjectorpi, DEV=0]autoinjector.   This autoinjector driver set does not show up in the pull downs, anywhere even after rebooting the Pi as instructed.   Instead, we are presented with the default firmware RPi audio drivers AND a completely new CARD driver set entitled [plugh:CARD=sndrpiproto,DEV=0], snd_rpi_proto.   There are four versions of this sndrpiproto CARD driver - 1.) hardware device with all software conversions, 2.) direct sample snooping device, 3.) Direct hardware device without any conversions and 4.) Default audio device.   When I choose the sndrpiproto driver with option 1,  I do indeed get audio from the RigPi custom sound card.  Still not sure if I am missing something and/or using the wrong driver setup.  Audio is choppy at best. 

So, after all of this, my questions are:   
1.) if autoinjector driver is required,  how/where do I access it?
1.) have the manufacturers changed the required audio drivers without documenting it on online and PDF manuals?  Is sndrpiproto correct? 
2.) if sndrpiproto driver is correct, which version (1-4) should I choose?     

Thanks in advance for your help and 73's,  Steve / KE4LC


Howard Nurse, W6HN
 

Hi Steve,

Welcome to the forum.

The correct driver is sndrpiproto.  Please refer to the 1.05 Help contained in RigPi in the Help menu for details.  You will also find early discussions here in the forum about the change from audioinjector.

The correct device selection is:

[hw:CARD=sndrpiproto,DEV=0] snd_rpi_proto. Direct hardware device without any conversion

There are settings that affect quality.  Turn Noise Suppression in the Audio Input Audio Processing group all the way down to Off.  In Audio Output, set Default jitter buffer to 30 or above (will take some experimentation).  After making changes to Mumble, click Apply then OK.  Restart Mumble to have the changes stick.

73, Howard W6HN


Blaine Kubesh
 

Hi Steve (ke4lc),

I just went through similar issues as you are describing.

If you look in the RigPi Help files online (launch help from the RSS menu), you may notice in the sound section they have changed to using a new driver called “sndrpiproto”.  This is the correct one to be using.  Some of the older docs still refer to autoinjector which is confusing, but the sndrpipro is correct.

It may take some tweaking using alsamixer to get the proper audio levels.  Make sure you select sndrpiproto as the default sound device by right clicking the speaker icon on the desktop.

Im not an expert…, but hope that helps. 
-Blaine
k5kub



On May 20, 2020, at 8:54 PM, Steve_KE4LC <sfwright101@...> wrote:

Hello group.  I'm a reasonably experienced RPi user, however I am having a very difficult time setting up my RigPi audio drivers on the RPi and Mumble server as instructed.   I have have swapped for new SD cards as well as a completely new RigPi.  This project is to support a remote access rig for my 93 year old dad AA2F so he can maintain his lifelong hobby.

Here is the problem:  The listed input/output driver programs in all RigPi setup instructions are [hw:CARDautoinjectorpi, DEV=0]autoinjector.   This autoinjector driver set does not show up in the pull downs, anywhere even after rebooting the Pi as instructed.   Instead, we are presented with the default firmware RPi audio drivers AND a completely new CARD driver set entitled [plugh:CARD=sndrpiproto,DEV=0], snd_rpi_proto.   There are four versions of this sndrpiproto CARD driver - 1.) hardware device with all software conversions, 2.) direct sample snooping device, 3.) Direct hardware device without any conversions and 4.) Default audio device.   When I choose the sndrpiproto driver with option 1,  I do indeed get audio from the RigPi custom sound card.  Still not sure if I am missing something and/or using the wrong driver setup.  Audio is choppy at best. 

So, after all of this, my questions are:   
1.) if autoinjector driver is required,  how/where do I access it?
1.) have the manufacturers changed the required audio drivers without documenting it on online and PDF manuals?  Is sndrpiproto correct? 
2.) if sndrpiproto driver is correct, which version (1-4) should I choose?     

Thanks in advance for your help and 73's,  Steve / KE4LC