Topics

Connect old non listed radio


zl2ba@...
 
Edited

Hi all, 

I am new to this but been trying to get my MFJ1234 working on radio not listed as has no serial or USB connection. I just want to use remotely on the one frequency so only need TX/RX audio and PTT.
I have set up the Rigpi program and it will transmit but no audio out from the Rigpi.. Using the Mumble app or in my case Plumble as I have a android phone, I can receive audio from the radio to my phone but can't get the radio to transmit on plumble even thou I can hear audio coming out of the TX Out port on the Rigpi using a headset to listen. I have tried using a iphone and I do hear the audio from that phone to my android and it also will receive audio out from the radio but as I cant get the plumble program to make the Rigpi transmit, no audio goes out over the air. If I use the Transmit button on the Rigpi program then on my phone push the Press to Talk, then audio comes out on the radio so there is an audio path there just need to get Plumble to make the pi transmit.
Is there something I am missing to get the TX Out PTT to work as I shouldn't have to use the Keyer PTT.

As I can't use the USB connections due to the type of radio, I have to use the Audio board connections. I am so close to getting it working but just cant get over the last hurdle. 
Any ideas.

David ZL2BA


Howard Nurse, W6HN
 

Hi David,

PTT comes from the remote browser, not from Plumble or Mumble.  You can set up the Hamlib Dummy radio in RigPi, then connect from your remote device.  Assuming you have thre PTT settings correct, you should be all set.

73, Howard W6HN


zl2ba@...
 

Hi Howard,
thanks for getting back to me.
Yes I can use the PTT on the web page and it works ok no audio out to radio but can receive as Plumble is also running. If I use Plumble alone, the PTT does not work. If I use 2 phones and use the web page on one to activate the PTT then use Plumble on the other and activate the PTT, audio will come out on the radio so there is a path through. I am so close. And yes I am using the dummy radio.

Thanks David ZL2BA


Howard Nurse, W6HN
 

Hi David,

Even though there is a PTT feature on Plumble, it is not connected to RigPi PTT.  That means you always have to use a browser to control PTT.  The Transmission option in Plumble should be set to Continuous so Plumble PTT is "always on."

--Howard


zl2ba@...
 

Hi Howard

I changed Plumble from PTT to continuous and all works.
Thankyou for your help and what a fantastic device. Keep up the great work.

thanks David ZL2BA