Topics

Dummy Not Disconnecting

Frank Wroblewski
 

My RigPi used to work with my Icom IC-7000, but has not stopped working.  I put all the correct values in the Advanced Settings, select CONNECT and get the result listed below.  Rebooting, updating, upgrading all had no effect.  Strangely enough, I have no problem getting FLRig to work.  WSJT-X also works, but without CAT displaying the proper frequency.  If I go to terminal mode and put in the rigctl commands, it tells me I have a communication bus error.  Any ideas anyone???
73,
Frank W2XYZ
TEST MODE Radio: 1
User: admin
Radio: 1
User: admin
Radio from settings: 1
Port from settings: None
ID from settings: 1
RigDo.php rigDoPID from settings: 4681
service_port: 4532
Hamlib Dummy radio 1 start attempt.
To see any error details, click Disconnect Radio, then start rigctld in Terminal with this line:

rigctld -m 1 -t 4532 > /dev/null 2>&1 &

rigctld processes running:

www-data 3689 0.0 0.2 5200 2364 ? S 22:34 0:00 rigctld -m 1 -t 4532

Now starting RigPi radio control link.
Congratulations, Dummy is connected!

Main frequency is 145.000.000 mHz

RigDo Processes:

www-data 3695 21.0 2.2 69616 21000 ? S 22:34 0:00 php /var/www/html/RigDo.php admin radio1 4532

RigDoPID: 3695; Radio: 1; User: admin; Keyer: rpk; CW Port: /dev/ttyS0

Now starting RigPi CW control link.
Now starting RigPi TCP remote control link on port 30001.
Now starting RigPi UDP server on port 12060.
Now starting RigPi Rotor control link on port 4533.

Now starting RigPi Rotor control link on port 4533.

Rotor: 1 (Dummy)
Rotor port: 4533
Rotor ID 1 (Dummy) start attempt.
To see any error details, click Disconnect Radio, then start rotctld in Terminal with this line:

rotctld -m 1 -T 127.0.0.1 -t 4533 > /dev/null 2>&1 &

rotctld processes running:

www-data 3707 0.0 0.2 5164 2372 ? S 22:34 0:00 rotctld -m 1 -T 127.0.0.1 -t 4533

Howard Nurse, W6HN
 

Hi Frank,

After entering the correct data for your radio, try clicking the Cloud icon at the top to save the settings.  Then when you try Test Radio, does it continue to connect to the Dummy radio?

—Howard

Frank Wroblewski
 

Howard,

Thanks for your help.  I wasn't clicking the cloud.  I didn't know about clicking the cloud, but that;s no one's fault but my own as I see that info is published in the manual and I missed reading it.  Everything working fine now, thanks for the great product and the phenomenal support your provide.

Frank