Remote operatiion: RigPi == USB=> IC-7100 no audio (TX or RX) #rigpi #ic-7100 #audio #remote

Neil K6NCX

I have posted on this previously and gotten useful suggestions. That's the only way I've gotten this far. Thanks to everybody! I had to leave the project aside for a while and I'm ready to get back into it. Starting a new thread so my request for help now, and the current status information, don't get buried under all the old stuff.

I want to do remote operation of my home IC-7100 when I'm on the road. (I may also do some in-the-house-but-not right-at-the-rig operation, i.e., on-LAN. I'm actually testing on-LAN first for each function.) Control works, both through VNC and through browse,r and both from phone and from laptop. But no audio in either direction.
Please note that across the board, results are exactly the same whether on-LAN or through WAN, so I don't want to get into discussions of port forwarding and so. That's not it.
Mumble client is installed in both phone (iPhone SE iOS 12.3.1) and laptop (Lenovo Flex running Windows 8.1.)  Both clients can connect to Mumble server and log in successfully (using different user names than pi.) Both clients hear some noise upon connection, and if both clients are connected at the same time they hear each other. The RigPi apparently hears the RX audio (right now I forget how we got to that, but the onscreen meter in Mumble moves with RX.) But no audio gets from phone or laptop to radio, or from radio to phone or laptop.

Howard Nurse, W6HN

Hi Neil,

It sounds like you are quite close with Mumble.  Once you have confirmed that audio from the receiver is making it to Mumble (bar graph movement) the Transmission settings in all running Mumble clients must be set to Continuous.  Once you do that the Mumble lips should turn red.


Tom Thomas <w7tct@...>

The four things that got me past the audio hurdles were:
1. For the RigPi's sound card, have the right pins connected on the jumper block for your radio. The jumper module that I got had the notch marked on the opposite end of where the jumper block had its notch. I purchased the module from Signallink as, while it works with my Signallink and the diagram was the same, so it seemed, the notches were not on the same end. (This caused the red Tx/Busy light on my Yaesu FT-891 to flash)
2. I made a "tomt" account on my MacBook's Mumble client and did not rely on the 'pi' or built-in Mumble accounts.
3. From Howard, (thanks!) do not connect the Mumble server to the SuperUser account but rather just use the 'pi' account.
4. Make sure that both client and server Configure : Settings : Audio Input transmit settings are set to 'Continuous'.

If the lips (a hideous icon, IMHO) on the Task bar are still not red, reboot the RigPi and reload the client. If still not red, then something is still off.
Note: I got WSJT-X working first as it was the 'simplest' test of making sure the codec and CAT was working.

Final note for FT-891 users, 38,400 Cat Rate works fine. I found that 19,200 caused RSS to connect and disconnect over and over within a few seconds. 

Hope this helps.

Neil K6NCX

Thanks, Tom.
1. I'm not using the sound card. USB from Pi to IC-7100.
2. Seperate Muble accounts.
3. Yes.
4. Set to continuous.

Neil K6NCX

Thanks, Howard. Lips are red. But I am blue because I have no audio. to or from radio.