Topics

Icom 7200 (was "Your help needed!")


Alex Charyna
 

Bob,

I just saw this message - my apologies.

Regarding Mumble & RigPi....
I totally understand about stopping WSJT-X to use Mumble, and stopping Mumble to use WSJT-X.

My problem is the connection from my iPhone to the mumble server running on the RigPi.
The Mumble app on the phone will connect correctly, but sound is never heard.

If the Mumble client is running on the RigPi, while I connect from my iPhone mumble app, they will get into a battle of dueling disconnections.  One disconnects the other, the other then reconnects and disconnects the first.  
So I think I have to also kill the Mumble client on the RigPi. When I do that - the iPhone's Mumble stays connected - but still no sound.

Initially, I thought that the mumble configuration was incorrect - but I am able to record sounds from the Mumble client which runs *on* the RigPi. (It's attached for reference) - so I'm pretty confident that the Mumble on the RigPi is correct.  (screenshots of that configuration are attached also)

The iPhone app doesn't have much configuration beyond IP address, user & password. So I'm kind of at a loss here.
A native Mumble app on my laptop exhibits the same behavior.

It's like I have to configure the Mumble service running on RigPi in someway, that I cannot seem to figure out / access.  Google tells me it's murmur, running as murmurd as a service.  The only config file for that is /etc/mumble-server.ini.... and within that, there is no obvious configuration that says "use this USB device a sound source" - it looks like mostly login configurations.

So I'm kind of stuck here.  

It's not a total loss, I did manage to WAS on ARRL's LotW on FT8 using RigPi, so I'm very happy about that.

-alex


Mark Weisheimer
 

Hi Alex,

You don't say which user name you are using for the iPhone user when connecting to the Mumble server.
It should be a different username than what you are using on the RigPi's Mumble client.
It can be any name, so long as it is different. The password will be the same for all users on any given Mumble server.

Also, the recording shows that receive audio is present so the selected device seems to be correct.
Was that recorded on the RigPi from the AlsaMixer input using USBaudioCODEC?
Your images are too blurry for me to read but suggest that you have chosen the USBaudioCODEC for the input and output device on the RigPi Mumble client.
Please cut and paste that text entry into your next message.
This Groups.io shrinks image attachments to the point that they are nearly useless.
--
73 - Mark - K8MHW
'A RigPi Enthusiast!' - I am not otherwise affiliated with MFJ or RigPi


Alex Charyna
 

Mark,
I was using the "pi" user on the Mumble iPhone app.  It never occurred to me to use a different one.

So I edit the connection on the Mumble iPhone app to something different.  I change the username to my call kb3qfc (this is not what I log into the rigpi.local webpage), and it looks like the password is optional.  It connects successfully, then bumps off the logged in mumble user that's showing on the rigpi desktop.  It goes into the same back and forth kicking the other guy off.

If I try the user account I log into the webpage with, same thing.  

Mumble on the RigPi says "Server Connection Failed: The remote host closed the connection"... when it kicks off the iPhone, it tells me "Connection Closed. The operation couldn't be completed (MKConnection error 0.)"

As far as I can tell, the mumble server is configured to handle 100 concurrent users.

I recorded the audio from within the Mumble client running on the rigpi.  I dont have speakers on it, so it was the only way I could think of to hear anything. I then copied that file off onto my laptop.

Re: rigpi mumble client configuration -

Audio Input device is as follows:
Interface System: ALSA. 
Device: [sysdefault:CARD=CODEC] USB Audio Codec, USB Audio Default Audio Device

Audio Output device is as follows:
Interface System: ALSA. 
Device: [sysdefault:CARD=CODEC] USB Audio Codec, USB Audio Default Audio Device

It is the same for both input and output.

thanks.
-alex


Mark Weisheimer
 

Alex,

Your settings look fine. Murmur should not knock another user offline and I do not know why it is doing that.
Did you make a back-up of your microSD card?
If so, this would be a good time to test with it to see if you have the same issue.

--
73 - Mark - K8MHW
'A RigPi Enthusiast!' - I am not otherwise affiliated with MFJ or RigPi


Alex Charyna
 

Backups of my SD card before using it? What am I? A responsible computer user? ;)

I'm 99.9% certain it's a murmur configuration - but it doesn't seem like a very hard thing to configure.  It seems to just "be"


Mark Weisheimer
 

Alex,

I looked back over this thread and realized that I didn't address your original comments entirely.
Mumble client on the RigPi does need to be connected to the Murmur server on the RigPi.
That client is the one that will route the TX and RX audio to and from the radio to the server.
Then, you talk and listen to the radio via the Mumble client on whatever remote device you are using, such as your iPhone.

The Mumble logs are located in /var/logs/mumble-server where you will find the current file mumble-server.log along with archived logs from the past.
You can look at the current log using cat mumble-server.log
Does the log file point to anything?

And If you are going to make any changes, now is a good time to make that back-up of your microSD.
You might also want to export your wsjt-x logs before making changes.

--
73 - Mark - K8MHW
'A RigPi Enthusiast!' - I am not otherwise affiliated with MFJ or RigPi


Alex Charyna
 

Mark,
Here's the log file output.

<W>2019-12-02 23:51:10.105 1 => <60:(-1)> New connection: 192.168.2.91:60138

<W>2019-12-02 23:51:11.064 1 => <60:(-1)> Client version 1.2.18 (X11: 1.2.18-1+deb9u1)

<W>2019-12-02 23:51:11.108 1 => Starting voice thread

<W>2019-12-02 23:51:11.153 1 => <60:pi(1)> Authenticated


<W>2019-12-02 23:51:22.288 1 => <61:(-1)> New connection: 192.168.3.6:55541

<W>2019-12-02 23:51:22.506 1 => <61:(-1)> Connection closed: The remote host closed the connection [1]

<W>2019-12-02 23:51:22.665 1 => <62:(-1)> New connection: 192.168.3.6:55542

<W>2019-12-02 23:51:23.101 1 => <62:(-1)> Client version 1.2.4 (iOS: Mumble for iOS 1003001001)

<W>2019-12-02 23:51:23.143 1 => <62:pi(1)> Disconnecting ghost

<W>2019-12-02 23:51:23.166 1 => <60:pi(1)> Connection closed:  [-1]

<W>2019-12-02 23:51:23.219 1 => <62:pi(1)> Authenticated


<W>2019-12-02 23:51:33.218 1 => <63:(-1)> New connection: 192.168.2.91:60228

<W>2019-12-02 23:51:33.421 1 => <63:(-1)> Client version 1.2.18 (X11: 1.2.18-1+deb9u1)

<W>2019-12-02 23:51:33.473 1 => <63:pi(1)> Disconnecting ghost

<W>2019-12-02 23:51:33.499 1 => <62:pi(1)> Connection closed:  [-1]

<W>2019-12-02 23:51:33.536 1 => <63:pi(1)> Authenticated


You can see where I started the mumble client on the rigpi (168.168.2.91) @ 23:51:10; my iPhone connected (192.168.3.6) @ 23:51:22 and kicked off the rigpi; and finally you can see where the rigpi reconnected (on it's own) again; disconnecting the iPhone.

I added the line breaks for clarity.

-alex


Mark Weisheimer
 

Alex,

It appears to be a cert problem. You can use the client to create a new cert,
Here is a link to a discussion about that:
https://github.com/mumble-voip/mumble/issues/2200

--
73 - Mark - K8MHW
'A RigPi Enthusiast!' - I am not otherwise affiliated with MFJ or RigPi


Alex Charyna
 

THAT WAS IT!!!!!!!

It works!

thank you! thank you!!!!!!