Topics

Rigpi ptt led stop lighting up. Kenwood TS 590s

Loic SM5VFE
 

I noticed now PTT that ptt cannot be switched off. Only on. 
1. The red PTT led on Rigpi doesn´t light up. 
2. When I starts Rigpi I noticed a 30 second sound. 
I didn´t have this Before. 

I´m trying to search the help but without sucess. 

Thanks in advance, 
Regards from Loic, SM5VFE

Howard Nurse, W6HN
 

Hi Loic,

Please try a simple test.  In SETTINGS>Radio, select the Hamlib (Manuf) Dummy (Radio) instead of your radio.  Disconnect your radio by clicking the Disconnect button, then click Connect Radio.  Does the PTT button work now?

From where do you hear the sound?  From your radio?  From RigPi?  Can you describe the sound?

--Howard

Loic SM5VFE
 

Hi Howard, 

Radio: Dummy on 145.000.000 MHz
I can press PTT in Rigpi. But the PTT led on Rigpi is not light up. 
The sound is like a warning sound around 30 seconds when I reboot Rigpi.

Regards from Loic, SM5VFE

Loic SM5VFE
 

 I tried today with Android phone and Plumble. Works very good in receive.  A Ptt press  makes the radio go in TX but stays in TX. Not possible to have radio in RX mode. 

Howard Nurse, W6HN
 

Hi Loic,

If you are using a RigPi browser on the Raspberry Pi desktop, please close the browser to see if the PTT lockup stops.  If so, that is a known issue and will be fixed in the next RigPi release.  When you are operating away from home, don't leave the Raspberry Pi browser open.

--Howard

Loic SM5VFE
 

Hi Howard, 
Ptt lockup on TS 590s doesn´t stop if I log out of Rigpi or even reboot remotely via Android or computer. I had to drive home to press the off button on TS 590s to stop the PTT. :-) 
I don´t know what you mean about leaving brower opened? 
I always Close VNC Viewer when operation from Remote and I have only one RigPi window opended. Either in the phone or in the portable computer. 

When I press ptt the led on Rigpi is not lighing up. Is this normal? 
Thanks. 
Regards from Loic SM5VFE

Howard Nurse, W6HN
 

Hi Loic,

You can open a Chrome browser on the Raspberry Pi Desktop connected to RigPi.  You can see it via VNC.  Closing VNC doesn’t close that browser, it remains open and connected.  That is the browser that must not be left open when you are operating remote.

Please try the T/R button in the Macros on the CW Keyer window.  Tap it once to go into transmit, and again to go into receive.  Does that one work correctly?

—Howard

Loic SM5VFE
 
Edited

Hello Howard, 
I have never opened a browser on Raspberry Pi Desktop (I Think). The only program  opened  is Mumble. 

T/R in the CW Keyer Window makes PTT transmit on radio BUT not possible to go in receive mode again. I have to turn off the TS 590s by the Power button in front of the radio. 
The only thing I did with RigPi was to but in the programming for Power ON function and I receive an error message. I don´t know if that has caused the problem with the PTT issue? 

I have tried also to clear the radiolist according to Wiki. But without sucess. 
Regards from Loic, SM5VFE

Howard Nurse, W6HN
 

Hi Loic,

Here are a few things to try.  Rather than the TS-590S, try the TS-570S to see if it makes a difference.

Check out this link:

http://g3nrw.net/TS-590/?page_id=256

There is a second link on the g3nrw page that shows how to use FreeDV (VoIP plus Hamlib) to control the TS-590S.  You will see PTT settings in the second link along with radio menu recommendations.

—Howard

Loic SM5VFE
 
Edited

Hi Howard, 

TS 570s or TS 570d cannot connect. Radio can be read but not connected. 
"How to set up the Kenwood TS 590s for digital Data and Digital Voice Operation" gives me nothing than if USB port is choosen. Then a Macro should be in the program for PTT on and Ptt off. Ptt on is ok and tx audio a bit delayed but Ptt off is impossible. 

Strange is that Ptt tx/rx worked at first and not working anymore. 
Regards from Loic, SM5VFE

Howard Nurse, W6HN
 

Hi Loic,

Two more things to try:

1) Create a "receive" macro, *0w RX;  Does that work?
2) Disconnect the radio and set the serial port to None. Set up a new account in SETTINGS>Accounts.  Log out and back in to the new account.  Set up the radio is that second account.

You  have mentioned the red PTT light is not coming on.  That is controlled by the RigPi Keyer.  To have it work you need to assign the RogPi Keyer to the radio you are using.  In Advanced Radio, set PTT to ON when Transmitting.  In Keyer settings, put a check in Enable Keyer PTT.  When you use Test Keyer, the Keyer sends two CW V's and the PTT light should turn on.

--Howard

Loic SM5VFE
 
Edited

Hi Howard, 
1. "receive" macro, *0w RX;  doesn´t work. 
2. When I set up a new account the PTT work. I will do some more tests during the day. I had som problems to connect radio on account 2. RigPi had to be rebooted to have a Connection to radio. I noticed also when I created the new account date became 1970-01-01 but after login again the date was correct. 

3. I still have the 30 second "tone" when I start up Rigpi. Tone is not present at reeboot. Only at startup. I have tried to see the boot up process but I cannot see anything strange. I Noticed also sometimes the boot up function at settings doesn´t work. I have to remove the Power from Rigpi. 

Loic SM5VFE
 
Edited

PTT problem came back. Radio worked fine for around an hour.  Not possible to turn PTT off. Something with the account? 
It happened I Think when I rebooted the remote computer. 
I cannot get it to work as last time with a new account. 
Below message when I try to create a new account with a diffent Username. 

/dev/ttyUSB0 is already in use in the account for radio TS-590S.


It is not possible to connect TS 590s on acount 2. Seems that something is not stable. Start blinking between 00000 and for exemple 28.500 MHz. 
I have never had any trouble to connect to Account nr 1 except for the PTT issue. 
Regards from Loic, SM5VFE

Howard Nurse, W6HN
 

Hi Loic,

Several of the problems you are having continue to be a mystery.  The tone, for example...  (The only tone RigPi emits is from the Keyer, it isn’t clear why the radio would be complaining with a tone.)

To set up a second account with the same radio, you must set the port to None on the first account, and save that by clicking the up-arrow/cloud.

—Howard

Howard Nurse, W6HN
 

Loic, several of the Kenwood radios require Hex codes to be used in macros rather than ascii.  For the *w RX; macro, please try *w \0x52\0x58\0x3B. This format would also apply to *w TX1;, use the Hex equivalents.

—Howard

Loic SM5VFE
 
Edited

Howard, 
The 30 seconds  tone is when I power on RigPi. Tone is coming from RigPi not from the radio.

I have only the admin account now and radio start to change between 28.500 MHz and 0000000. Not stable at all. 

But now *0w RX; Ptt off. Works a few CQ calls then PTT (*0w RX.) doesn´t work anymore.     Normal PTT in acount doesn´t work. Cannot turn off PTT. 

Your above text I really don´t how to use it. 

Regards from Loic, SM5VFE

Howard Nurse, W6HN
 

Hi Loic,

Is the tone from the Keyer?  When you power up RigPi, you should hear the CW ‘R’ character to indicate that the Keyer is alive and well.  Do you hear that?  You previously said the Red Keyer PTT light no longer works, is the light on during the long tone?

As RigPi is booting, does the red power light blink at all (is it on continuously)?

You created a macro *0w RX;.  In place of *0w RX;, enter the following macro as it is shown here:  *0w \0x52\0x58\0x3B. (no period at end) Is this more stable?

For the radio instability, please go to Advanced Radio settings.  Click Disconnect Radio.  Then click the Test button.  Please send along a copy of the report.  (If you set up a second account for the same radio, make sure the port for that radio is set to None.)

—Howard

Loic SM5VFE
 

Hi Howard, 
Thank you. 
I don´t know where the sound is from but I don´t hear CW R at boot up of RigPi. I hear a 30 seconds like a warning tone. 
When powering up RigPi. Red Power light next to the green is blinking and when RigPI is on both leds are red. 

I entered on Macro 25 *0w RX;
I entered on Macro 26 *0w \0x52\0x58\0x3B ( The ptt is not working any better) 

Radio Connection

OK

TEST MODE Radio: 1
User: admin
Radio: 1
User: admin
Radio from settings: 1
Port from settings: /dev/ttyUSB0
ID from settings: 231
RigDo.php rigDoPID from settings: 4681
service_port: 4532
To see any error details, click Disconnect Radio then start rigctld in Terminal with this line:

rigctld -m 231 -r /dev/ttyUSB0 -t 4532 > /dev/null 2>&1 &

rigctld processes running:

www-data 5981 0.0 0.2 5200 2400 ? S 20:46 0:00 rigctld -m 231 -r /dev/ttyUSB0 -t 4532

Now starting RigPi radio control link.
Congratulations, TS-590S is connected!

Main frequency is 28.488.040 mHz

RigDo Processes:

www-data 5987 27.0 2.1 69608 20508 ? S 20:46 0:00 php /var/www/html/RigDo.php admin radio1 4532

RigDoPID: 5987; Radio: 1; User: admin; Keyer: non; CW Port: None

Now starting RigPi CW control link.
Now starting RigPi TCP remote control link on port 30001.
Now starting RigPi UDP server on port 12060.
Now starting RigPi Rotor control link on port 4533.

Now starting RigPi Rotor control link on port 4533.

Rotor: 1 (Dummy)
Rotor port: 4533
Rotor ID 1 (Dummy) start attempt.
To see any error details, click Disconnect Radio, then start rotctld in Terminal with this line:

rotctld -m 1 -T 127.0.0.1 -t 4533 > /dev/null 2>&1 &

rotctld processes running:

www-data 5999 0.0 0.2 5164 2384 ? S 20:46 0:00 rotctld -m 1 -T 127.0.0.1 -t 4533

Report is complete. Select the text in this report, copy, then paste it to a destination (such as an email).

 

Howard Nurse, W6HN
 

Loic, the red power light should never blink. Do you have another power supply you can try?

—Howard 

Loic SM5VFE
 

I tried another Power supply. The tone is still there at startup.