Topics

IC-7610 woes

Jim Kravetz - KK5VG
 

Hey, Bo. Yes, pick the IC-7300 as the radio on the left and change the name to IC-7610 on the right. 

Howard Nurse, W6HN
 

Hi Bo,

The CI-V address should be \0x98, using a backslash.

The Power macros must start with *1w<space> for Icom radios.  There is a possibility the 7610 has a slightly different command to set power levels.  Please check the CAT programming manual for the 7610.  You will see a popup message since the Icom sends back a Hex code, but it shouldn't disconnect the radio.

I'm not clear on what you are asking in your left/right question.

I agree, a bit of wine is always a fun project!  :-)

--Howard

Jim Kravetz - KK5VG
 

I’m sure Bo will be saying thanks soon but let me toss mine in there too. Thanks, Howard. That works. 

Howard Nurse, W6HN
 

Bo, to fix the Power On/Power Off problem in Hamlib for the 7610, select the IC-7300 instead of the IC-7610.  In Advanced Radio settings, change the Radio Name to IC-7610.  Change the CI-V from default to \0x98.  RigPi will think it is controlling a 7300 which does support P On/P Off, but the CAT controls are the same for both radios.

Let us know how that works for you.

73, Howard W6HN

Howard Nurse, W6HN
 

Hi Bo,

After looking at the 7610 capabilities in RigPi Advanced Radio settings, I see that power off/on is not currently supported by Hamlib.  I'm surprised, but it is a feature I hope they will add.

Once you initialize the Keyer it will be happy.  It also works with a paddle even though you aren't using a radio.  (That's one thing the speed pot is for.)

I've owned two SB-200's through the years, nice amp!

--Howard

Howard Nurse, W6HN
 

Hi Bo,

Power on/off should work the same for the 7610 as for your 7300.  It can take up to 10-20 seconds to switch, could that be the issue?

RigPi Tune closes the CW Keyer output for tuning purposes, it does not tune the radio.  A macro would be required for that.

PTT is supposed to be momentary, PTT should stay on as long as you are tapping the PTT button.

All Icom radios required that “Disable split polling” be ticked in Advanced Radio settings.  Put a check there, then disconnect/connect the radio.  That should fix the VFO jitters.

Yes, the macros should be the same except for the CI-V Radio Number, as you’ve stated.

The Radio LAN connection is not used by RigPi.

—Howard