TS 2000 no PTT


Don Domina
 

Greetings,

I have a TS 2000 working fine with Remote Hams.  I have installed MFG1234 and set up the program.  I have connectivity with the TS2000 from RIgPi run from the RasPi environment.  I can turn the radio ON/OFF.  I can change bands and frequency.  I can not engage PTT.  I also can not engage TUNE.  The RSS creates a tone but not PTT.  I have not tested other functions. 

I looked through comments and could not find info on TS2000/PTT.  Any suggestions would be appreciated.  The data on the install of the radio follows:

User: KC0DE (admin)

13:31z

Radio Connection

TEST MODE Radio: 1
User: admin
Radio: 1
User: admin
Radio from settings: 1
Port from settings: /dev/ttyUSB0
ID from settings: 214
RigDo.php rigDoPID from settings: 4681
service_port: 4532
To see any error details, click Disconnect Radio then start rigctld in Terminal with this line: 

rigctld -m 214 -r /dev/ttyUSB0 -t 4532 > /dev/null 2>&1 &

rigctld processes running:

www-data 1883 0.5 0.2 5200 2344 ? S 09:31 0:00 rigctld -m 214 -r /dev/ttyUSB0 -t 4532 

Now starting RigPi radio control link.
Congratulations, TS-2000 is connected!

Main frequency is 18.105.000 mHz

RigDo Processes:

www-data 1889 8.0 2.0 69544 19392 ? D 09:31 0:00 php /var/www/html/RigDo.php admin radio1 4532

RigDoPID: 1889; Radio: 1; User: admin; Keyer: rpk; CW Port: /dev/ttyS0

Now starting RigPi CW control link.
Now starting RigPi TCP remote control link on port 30001.
Now starting RigPi UDP server on port 12060.
Now starting RigPi Rotor control link on port 4533.

Now starting RigPi Rotor control link on port 4533.

Rotor: 1 (Dummy)
Rotor port: 4533
Rotor ID 1 (Dummy) start attempt.
To see any error details, click Disconnect Radio, then start rotctld in Terminal with this line: 

rotctld -m 1 -T 127.0.0.1 -t 4533 > /dev/null 2>&1 &

rotctld processes running: 

www-data 1900 0.0 0.2 5164 2344 ? S 09:31 0:00 rotctld -m 1 -T 127.0.0.1 -t 4533 

Report is complete. Select the text in this report, copy, then paste it to a destination (such as an email).

Cheers

Don KC0DE

 


Don Domina
 

One additional bit of info, the RED PTT light is ON whenever the radio is connected (Via RSS).  If I disconnect the radio, the light goes out.  Also, I am, at present, only operation on the RSS and not remotely,

Cheers

Don KC0DE


Howard Nurse, W6HN
 

Hi Don,

There is a setting in SETTINGS>Advanced Radio for PTT.  One of the options is to set PTT 'ON when radio connected.'  That option should be set to 'ON when transmitting.'  Please confirm.

The TUNE macro sets the CW Keyer to key-down.  The tone you hear is from the Keyer and is normal.  You can create a Tune macro that starts the antenna tuner in your radio.  More on that later after the PTT issue is solved.

73, Howard W6HN


Don Domina
 

Howard,

Thanks for the response.  I confirm the setting is "ON when Transmiting".  I saved the setting and then rebooted the RSS.  I rechecked and the setting was correct.  The PTT light was off at this point.  When I touched the PTT switch, the PTT light became RED, the TS2000 DID NOT key.  When I released the PTT the PTT light remained RED.  I touched the PTT again and let off, and there was no change.  The RED PTT light on the RSS remained on.

Cheers.

Don KC0DE


Howard Nurse, W6HN
 

Don, when the PTT light is on, does it release if you press ESC on your keyboard?  Does it release if you tap the Space bar?

What are thee settings for these options in Keyer settings?  PTT ON when Radio Connected; Enable Keyer PTT.

--Howard


Don Domina
 

Howard,

I have the following information per your note:
ESC and SPACEBAR has no impact on the RED PTT light.  It remains on.
Under KEYER, the following are ticked:  PTT ON when radio connected, Enable Keyer PTT, Enable Sidetone.  With this condition, there was no change after a reboot.
I unticked Enable Sidetone and rebooted, the condition did not change.  I returned it to the ticked position.
If I DISCONNECT RADIO, the light goes off.  As soon as I CONNECT RADIO, the light comes back on.  The light is off immediately after a reboot, but comes on as soon as I touch PTT.

I am set on 40M SSB for this testing.

Thanks

Don KC0DE


Howard Nurse, W6HN
 

Don, uncheck the PTT ON when radio connected box in the Keyer settings window.  That option forces the Keyer PTT to be engaged whenever the radio starts.  It is there to allow the Keyer PTT to be used for other control purposes.

—Howard


Don Domina
 

On Wed, Aug 28, 2019 at 09:42 AM, Howard Nurse, W6HN wrote:
Don, uncheck the PTT ON when radio connected box in the Keyer settings window.  That option forces the Keyer PTT to be engaged whenever the radio starts.  It is there to allow the Keyer PTT to be used for other control purposes.
Howard,

I unchecked as noted.  Progress.  It appears that the PTT GUI on the screen and the SPACE BAR will cause the RED PTT light on the RSS to illuminate.  When I let off the GUI or the Space Bar there is a delay in the light going off ( 2-3 seconds).  In some cases the light does not go off.  I will wait 20 seconds and key again and release, and the light goes off.  I don't think this is internet latency...it is far too long.

In all cases, the RSS is not keying the TS2000.  It remains in receive mode and never in transmit.

Of note, I have an ethernet cable plugged into the RSS for internet.  It is a hard wire (shared through ethernet switches) to a 1 GB Fiber Internet service.  I am using a wireless mouse keyboard.  I have the TS2000 attached to the audio in on the RSS and to a USB via a USB serial adapter.

Thanks

Don KC0DE


 

Hello Don,
I had a similar PTT problem with my TS-2000.  I'm not sure what fixed it since all I did was completely remove and do a new install of Mumble.  Follow all of the setup instructions as listed in the help instructions.  Be sure you accept the certificate when asked by the program.  I also changed the baud rate in the TS-2000 menu and the advanced radio settings to 57,600.  Also change the PTT to ON when transmitting while in the advanced radio screen.  I also remember changing Transmission setting to Voice Activated and adjust the Voice Activity Configuration in one of the Mumbles I installed.
Make the other changes Howard suggested and give it a try!  Can't hurt but might help???
Good luck,
Don
N3BMT


Don Domina
 

Howard and Don

Thanks for the suggestions.  I am still not able to key the TS2000.  The changes made in #2594 seemed to improve the ability to get the PTT light on the RSS to illuminate, but it does not happen every time I touch the PTT GUI or the space bar.  Sometimes I get no light; sometimes a light that stays on; sometimes a light in sync with touching the PTT/Spacebar.  It is not consistent. The time lag is seconds...sometimes 20 seconds and sometimes not at all.   In no case has the RSS actually keyed the transmitter.   I also tried the suggestions in #2618.  I uninstalled and reinstalled Mumble.  I checked to see that the TS2000 (menu 56) is set at 57,600.  I changed the Mumble transmission setting to Voice Activated.  It has had no impact.

At this point, I have followed each item.  I can POWER ON/OFF, change the frequency, band and mode.  I just can not key.

Other ideas?

Don KC0DE


Tom W5KUB <Tom@...>
 

Don sorry I had not been following all the thread on this post.  Just a couple quick questions .
1. are you having the same problem with a mouse connected directly to the RSS ( when you hit the ptt button on the local browser does if function?
2. are you accessing the RSS from internal meaning a device across your local lan?
3. Are you accessing the RSS from outside via the internet?
Thanks Tom W5KUB
Host of live weekly ham radio show called Amateur Radio Roundtable every Tuesday night at 8:00 PM central on W5KUB.COM .  Please join our ham radio facebook group at https://www.facebook.com/groups/w5kub/


On Sat, Aug 31, 2019 at 10:51 AM Don Domina <stl_deli@...> wrote:
Howard and Don

Thanks for the suggestions.  I am still not able to key the TS2000.  The changes made in #2594 seemed to improve the ability to get the PTT light on the RSS to illuminate, but it does not happen every time I touch the PTT GUI or the space bar.  Sometimes I get no light; sometimes a light that stays on; sometimes a light in sync with touching the PTT/Spacebar.  It is not consistent. The time lag is seconds...sometimes 20 seconds and sometimes not at all.   In no case has the RSS actually keyed the transmitter.   I also tried the suggestions in #2618.  I uninstalled and reinstalled Mumble.  I checked to see that the TS2000 (menu 56) is set at 57,600.  I changed the Mumble transmission setting to Voice Activated.  It has had no impact.

At this point, I have followed each item.  I can POWER ON/OFF, change the frequency, band and mode.  I just can not key.

Other ideas?

Don KC0DE


Don Domina
 

Tom,
1. If I use the mouse on the RSS (and the GUI image of the PTT switch) or the keyboard space bar, the RSS acts the same.  The response is erratic - hit or miss.  In no case does it actually key the TS2000.
2. I am hard wired into my lan, it is not via wireless.  I have accessed the device via VNC from another computer on my network with similar results.
3.  I have not attempted to access the device from outside my LAN.
 
Any ideas appreciated.

Cheers.

Don KC0DE


Andrew, K7UL
 

Hi Don
I am wondering where on the radio you connecting the audio lines to the TS-2000.  I use the rear connector so I don't have to fiddle with taking the mic on and off.  I am going to guess you might be using the front mic connector.  It has 8v on one of the pins, and that is the only thing I would think that would effect the rigpi when you plug in the cable.  You indicated a change in the led when you plugged in the cable.  If this is the case, double check your wiring on the radio end.  

Best of luck.
Andy, K7UL


Don Domina
 

Andy,

Thank you.  I am getting the audio from the 13 Pin connector on the back of the TS2000.  I use this radio for Winlink as well and use this same cable (in the Winlink case) through a Signalink.  It is the same cable that terminates in an RJ 45 which plugs into the RSS.  For clarity, the cable is direct from the TS2000 to the RSS.  What is puzzling to me is that the TS 2000 works fine for Winlink with the Signalink, and it does not with the RSS.   Of note I am also using a USB Serial Adapter between the RS232 on the TS2000 and  USB on the RSS.  It uses a Prolific 2203.

Thanks again....still looking for a solution.

Cheers.

Don KC0DE


Tom W5KUB <Tom@...>
 

Don, I dont know if this is your trouble or not. But on the ts-2000 if you are using the data din plug on the back for audio, you will not get transmit audio in unless you key a PTT pin to ground on that data din plug. Keying the mic PTT will not allow transmit audio to go in via the data plug. Im not sure about cat PTT.  You might check this.


Host of live weekly ham radio show called Amateur Radio Roundtable every Tuesday night at 8:00 PM central on W5KUB.COM .  Please join our ham radio facebook group at https://www.facebook.com/groups/w5kub/


On Sun, Sep 1, 2019 at 10:58 AM Don Domina <stl_deli@...> wrote:
Andy,

Thank you.  I am getting the audio from the 13 Pin connector on the back of the TS2000.  I use this radio for Winlink as well and use this same cable (in the Winlink case) through a Signalink.  It is the same cable that terminates in an RJ 45 which plugs into the RSS.  For clarity, the cable is direct from the TS2000 to the RSS.  What is puzzling to me is that the TS 2000 works fine for Winlink with the Signalink, and it does not with the RSS.   Of note I am also using a USB Serial Adapter between the RS232 on the TS2000 and  USB on the RSS.  It uses a Prolific 2203.

Thanks again....still looking for a solution.

Cheers.

Don KC0DE


 

Don,
You said you are using the same cable that you use on your Signalink.  Did you also install the jumper board on the audio card inside of the RSS?
I know, I'm pulling straws here but this has to be something simple unless you actually do have a faulty unit????
I'll keep digging!
Don
N3BMT


Don Domina
 

Don and Tom,
Sounds like you might be on to something.  I did not make any adjustments inside of the RSS.  I did not add any jumper.  I'm going to go over the instruction manual for the RSS and see if I can figure out where the jumper goes for my particular radio.  I know that in the Signalink, there is a jumper set that is coded to the TS2000.  Thanks for the lead on this one.  I will report my results as soon as I have any.
Thank you!

Cheers.
Don KC0DE


Andrew, K7UL
 

Don,

Because you are using a known good cable, used before with a signalink, I would open the both the signalink and the 1234 and verify the jumpers are the same.  While you are there, grab a jumper and briefly short out the ptt line at the jumper block and see if the radio keys up.  That will test the jumper block to the radio.

To test the 1234, I would bring up a command shell, either ssh in it, or using VNC and opening one up there, and at the prompt type 'gpio toggle 0'
That should make the 1234 key the PTT line.
Same command again to unkey.
That should indicate the basic hardware of the 1234 is working.

If all of that seems to work, I would start to check the power available to the pi.  Are you running a local monitor on the 1234, and if so, does the little lighting bolt appear?  If you do not have a monitor connected to the pi, you many not know you are having brown outs.  I believe these messages are being logged in /var/log/messages
use the command 'tail /var/log/messages' to see that tail end of the log file.

Andy.


Don Domina
 

Tom, Don and Andy,

I am still unable to key the rig.  As I have said, the PTT switch on the GUI screen and the spacebar does illuminate the RED PTT light but does not key the TS2000.  The action of getting the RED light to come on and turn off is erratic at best....sometimes a delay of 20 seconds after taking action.  Sometimes never.

One by one.
Tom -- I am using the Data pin on the back.  I am not keying the radio with the mic on the front of the radio.  It is not attached.  I have tried to key from the PTT GUI and the spacebar with no luck.
Don -- I did not install a jumper board.  When I opened the RSS, I find that a jumper has been installed on JP1 between pins 2 and 3.  I moved the jumper to pins 1 and 2 with no success.  I have returned them to pins 2 and 3.
Andy -- I need a bit more instruction to do what you asked.  You said "grab a jumper and briefly short out the ptt line at the jumper block".  What is the PPT line?  Is that pin 2?  What is the jumper block?  Do I remove the jumper before I test this way?  I did enter the terminal mode and typed "gpio toggle 0".  Nothing happened.  No light came on.  I was returned to the command prompt.  I am using a Raspi power supply I had earlier from a Canakit Pi 3B+ I had purchased earlier.  It is hooked to a separate monitor that I have used with other Raspi projects.   It does not display the "lightning bolt" at start up.  I am familiar with that.  The image remains constant.  I checked the /var/log/messages and got the following report:
=====
pi@rigpi:/var/www/html/programs $ tail /var/log/messages
Sep  2 09:03:16 rigpi kernel: [   26.897394] Bluetooth: HCI UART protocol Three-wire (H5) registered
Sep  2 09:03:16 rigpi kernel: [   26.897527] Bluetooth: HCI UART protocol Broadcom registered
Sep  2 09:03:17 rigpi kernel: [   27.158118] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
Sep  2 09:03:17 rigpi kernel: [   27.158131] Bluetooth: BNEP filters: protocol multicast
Sep  2 09:03:17 rigpi kernel: [   27.158153] Bluetooth: BNEP socket layer initialized
Sep  2 09:03:17 rigpi kernel: [   27.240701] Bluetooth: RFCOMM TTY layer initialized
Sep  2 09:03:17 rigpi kernel: [   27.240735] Bluetooth: RFCOMM socket layer initialized
Sep  2 09:03:17 rigpi kernel: [   27.240760] Bluetooth: RFCOMM ver 1.11
Sep  2 09:03:21 rigpi lightdm[716]: Error getting user list from org.freedesktop.Accounts: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Accounts was not provided by any .service files
Sep  2 09:03:33 rigpi kernel: [   43.628230] fuse init (API version 7.26)
pi@rigpi:/var/www/html/programs $ 
I am not Linux proficient, even marginally.  I notice that there is an error noted towards the end, but I do not know what to look for.
Further,  I did have the following when I ran php hamlibDo.php (which I found on page 111) of the RSS User Manual.
=====
pi@rigpi:/var/www/html/programs $ php hamlibDo.php
PHP Notice:  Undefined index: test in /var/www/html/programs/hamlibDo.php on line 5
PHP Notice:  Undefined index: radio in /var/www/html/programs/hamlibDo.php on line 12
PHP Notice:  Undefined index: keyer in /var/www/html/programs/hamlibDo.php on line 13
PHP Notice:  Undefined index: user in /var/www/html/programs/hamlibDo.php on line 14
PHP Notice:  Undefined index: port in /var/www/html/programs/hamlibDo.php on line 15
PHP Notice:  Undefined index: rotorPort in /var/www/html/programs/hamlibDo.php on line 16
PHP Notice:  Undefined index: tcpPort in /var/www/html/programs/hamlibDo.php on line 18
PHP Warning:  socket_connect(): unable to connect [111]: Connection refused in /var/www/html/programs/hamlibDo.php on line 199
<h3c>The Radio control startup process failed. <br><br>Make sure the radio is on and connected. <br><br>Learn more by using Test Radio in Advanced Radio Settings.</h3c>pi@rigpi:/var/www/html/programs $ 
=======
On the Advanced Radio page, the following is the message from "TEST RADIO":
======
TEST MODE Radio: 1
User: admin
Radio: 1
User: admin
Radio from settings: 1
Port from settings: /dev/ttyUSB0
ID from settings: 214
RigDo.php rigDoPID from settings: 4681
service_port: 4532

TS-2000 is already connected.
==========
It appears to be refusing a connection even though the I am controlling ON/OFF, frequency and band change.  The test radio functions shows the rig connected.

That is the extent of my research to this point.  All of your help is amazing and I am hopeful that I can get to resolution soon.

Cheers
Don KC0DE


Mark Weisheimer - K8MHW
 

Don,

JP1 is not the jumper folks are referring to.
The jumper that they are referencing is located on the very top board inside the RigPi, and is on the bottom of that board.
It is a 16 pin jumper (can be done with wires too) and its purpose is to route the audio TX, RX, GND and PTT to the RJ45 connector which in turns take those signal to your radio.
It looks like these:

https://groups.io/g/RigPi/photo/0/15?p=Created,,,20,2,0,0
and
https://groups.io/g/RigPi/photo/0/19?p=Created,,,20,2,0,0

Since you don't seem to have a jumper, here is a pointer to how they are wired for the various radios.
https://groups.io/g/RigPi/files/RigPi%20Documentation/audiodipconnections.pdf

You can either use the jumper that is in your SignaLink or make up wire jumpers for the positions.
I have used 24 ga insulated solid copper wires for that.
Such as you might find from an ethernet cable or as was used for home telephone wiring.

--
73 - Mark - K8MHW
'A RigPi Enthusiast!' - I am not otherwise affiliated with MFJ or RigPi