Topics

FT-857 No Audio


Jeffj51@...
 
Edited

I have established rig control and Mumble from my remote iPhone, but cannot get audio to work. Strangely, I can get receive audio when pressing the up arrow or the push to talk button on the pop up window with Alsamixer loaded. Went through all configuration steps, rebooted, even reset to defaults. I’ve tried the steps as recommended in the forum and help files.

I’m reaching a high level of frustration now since I expected a plug and play device for the cost of this unit. Many of us are not networking literate and struggle with these things. I’ve been trying to get this unit working for weeks (not full time). Any help you can give that hasn’t already been discussed in the forum would be greatly appreciated. I’m using the MFJ 5706MD cable for the interface. Has anyone got RSS working with a FT-857?

73, Jeff


Howard Nurse, W6HN
 

Hi Jeff,

I'm glad to see you here on the forum, I'm sure we can get you going.

Please tell me a bit more.  I'm not clear on what up arrow button you are pressing.  Am I correct in understanding that you hear receive audio with the PTT button pushed?

Please confirm that the 5706MD cable came with a jumper block, and that you have plugged the block into the RigPi Audio daughter board. 

In Mumble on your Raspberry Pi desktop, open the Configure>Settings>Audio Input window.  In the Transmission drop down list, select Voice Activity.  Do you see activity on the bar graph?

What Device shows at the top?

73, Howard W6HN


Terrence Redding
 

Hi Jeff,

I feel your pain. I have the MFJ-1234 and would like to set it up to work. I thought the hardest part of the process would be to buy the right cable to connect the device to the radio. But then I discovered just finding that list of connecting cables and radios was not easy.

I have the FT-857d and so might simply watch what you do, and then duplicate your effort once you are successful.

It might help if those in the group that have successfully remoted their station with the MFJ-1234 RigPI server would post what radio they used and what connections they made between the radio and the RigPI.

Terry - W6LMJ


Jeffj51@...
 

Hi Howard-

The arrow keys are on the keyboard used to navigate DOS programs. I am running alsamixer when the audio comes on when I press the key. Yes - I plugged in the jumper block when I received the cable. I do see voice activity on the bar graph, so there is audio input. Also, it is set to sndrpiproto ( default) for the device for both input and output. It feels like I am so close, but can’t quite find the final setting. It is probably something very simple, but is beyond me. Thanks for your help- hopefully you will have a solution. 

73, Jeff


Jeffj51@...
 

Hi Terry - 
This has turned out to be a marathon, but I’m getting there step by step. My initial trouble connecting the rig was actually the baud setting on the radio itself. Once it was corrected, RSS could connect. I also had some self-inflicted wounds from having both wi-for and Ethernet connected. Then my router failed and I had to replace it. Remote connection was solved with a DNS account that is included with my new Netgear router. I’m sure Howard is getting a workout from all the low tech hams like me, but he is steadily working through the issues. 
73, Jeff


Howard Nurse, W6HN
 

Hi Jeff,

At this point I’d like to log in to your RigPi from here using VNC to see what is going on.  If you have port forwarding set up for VNC, and you don’t mind my logging in, please send your WAN IP to me by private email.

—Howard


Terrence Redding
 

Hi Jeff,

I am keen to see how you get your IC-7300 to work with MFJ-1234, RigPI. I watched the early videos from the public announcement of the RigPI with the promise of an and comprehensive, nearly universal solution for the widest possible array of rigs.

Now, after reading this group for that past few weeks I see getting RigPI to work and provide remote access to a station is more difficult than initially thought. My initial guess would have been that the IC-7300 would be one of the easiest rigs to remote using RigPI.  Now I suspect that may not be true.

I would be interested in seeing a list of rigs that work with RigPI.  I have several rigs that I might use to include Yaesu, Kenwood and Icom rigs.  My first two choices would be the TS-2000 and the FT-857d because they provide the widest selection of bands which might be used.

Who has successfully use RigPI with either the TS-2000 or the FT-857d?

Terry - W6LMJ

On Aug 21, 2019, at 11:54 AM, Jeffj51@... wrote:

Hi Terry - 
This has turned out to be a marathon, but I’m getting there step by step. My initial trouble connecting the rig was actually the baud setting on the radio itself. Once it was corrected, RSS could connect. I also had some self-inflicted wounds from having both wi-for and Ethernet connected. Then my router failed and I had to replace it. Remote connection was solved with a DNS account that is included with my new Netgear router. I’m sure Howard is getting a workout from all the low tech hams like me, but he is steadily working through the issues. 
73, Jeff


Howard Nurse, W6HN
 

Hi Kerry,

I want to assure you that getting the IC-7300 integrated with RigPi is normally straightforward.  (I have one sitting right here.)  The 7300 has much documentation and step-by-step instructions in the Forum Files area.  One of our users, Harold, W5ZZT, created a file which you can load into your 7300 to take care of all radio menu settings if you don't want to change settings manually..

https://groups.io/g/RigPi/files/Rig%20Configuration%20Information/ICOM

There is a list of supported radios in the Forum File area here:

https://groups.io/g/RigPi/files/RigPi%20Documentation/Hamlib%20Radio%20List%205-7-19.pdf

There are notes for each radio that indicates testing status.  I've found these notes to be unreliable.

I know of several who are using the TS-2000 successfully.  The FT-857d is a bit more difficult since you have to patch into the Mic connector to take advantage of DSP and other radio audio options.

73, Howard W6HN


Jeffj51@...
 

Hi Terry - 

Howard was able to access my RigPi and found that the Mumble app was set to push to talk for the audio input setting. It should have been set to continuous for it to work properly. I am now fully functional using RigPi remotely and ready to make some contacts. Howard is an amazing resource for resolving issues like this and I encourage everyone to keep trying if you have any problems getting RigPi to work. Good luck with your system and let us know how it turns out. 

73,
Jeff KB5CT 


Terrence Redding
 

Excellent. Glad to hear it. Are you LAN or also remote via the web?


On Aug 22, 2019, at 10:16 PM, Jeffj51@... wrote:

Hi Terry - 

Howard was able to access my RigPi and found that the Mumble app was set to push to talk for the audio input setting. It should have been set to continuous for it to work properly. I am now fully functional using RigPi remotely and ready to make some contacts. Howard is an amazing resource for resolving issues like this and I encourage everyone to keep trying if you have any problems getting RigPi to work. Good luck with your system and let us know how it turns out. 

73,
Jeff KB5CT 


Jeffj51@...
 

Both LAN and remote - works great!


goyboytoy@...
 

I've been working on getting my FT-857d running, but it's fallen to the back burner for a couple of months.

Are you using audio from the mic connector and speaker connector, or via the data plug on the back?
I ask because I never managed to get sufficient audio through the data plug.  The mic/speaker connections don't fit
my preferred setup.


Jeffj51@...
 

I am using the data connector for audio. When Howard used VNC to access my server, he made several adjustments to fix the audio. I don’t know what he did. I’m hoping HamLib will update the FT-857 interface to add more functionality- It is limited right now.


Howard Nurse, W6HN
 

Hi Jeff,

Additional radio control functionality is planned for the future.  Much can be added with Hamlib commands already available.

Another way to get receive audio from the 857 is by running a separate cable from the rear panel audio output on the 857 to the RX INPUT connector on RigPi, bypassing the DATA connector for receive audio.  That allows more of the radio’s signal processing to be used than is available through the DATA connector.

The main change I made in your Mumble client was to set the Transmit drop down to Continuous.  I made other level changes, including setting the Noise Suppression to 0.  I left the levels pretty much as they are shown in RigPi Help in the Mumble screenshots.

I’m glad your 857 is playing nicely with RigPi!

73, Howard W6HN


goyboytoy@...
 

Excellent.  I'll give it another try soon with the data connector.  Too many other projects in the shack at the moment.
Thanks
Wayne W5GIE


Jeffj51@...
 

I may have spoken too soon- it seems the transmit audio isn’t working properly. PTT is working and I can key the transmitter, but audio is not getting through. Verified with the local repeater. I’m going back through all the setup instructions.

Also, I’m having to reboot the RigPi after I disconnect remotely because it it will not reconnect. Mumble works and I hear audio, but RigPi won’t load. I get a message saying Safari can’t connect to the server. At the RSS, it incorrectly thinks there is no internet connection. I don’t have RigPi running on the server when I connect remotely. 


Terrence Redding
 

Hi Jeff,

It appears you are busy learning for both of us.  I am considering hooking the RigPI up to the FT-857d, and possibly an IC-7600, if I don’t go the TS-2000 route.  But I can’t have a remote base need a reboot each time I use it.  That would be a non-strater.

Reading along and following your adventure.

Terry - W6LMJ

On Aug 27, 2019, at 8:15 AM, Jeffj51@... wrote:

I may have spoken too soon- it seems the transmit audio isn’t working properly. PTT is working and I can key the transmitter, but audio is not getting through. Verified with the local repeater. I’m going back through all the setup instructions.

Also, I’m having to reboot the RigPi after I disconnect remotely because it it will not reconnect. Mumble works and I hear audio, but RigPi won’t load. I get a message saying Safari can’t connect to the server. At the RSS, it incorrectly thinks there is no internet connection. I don’t have RigPi running on the server when I connect remotely. 


Howard Nurse, W6HN
 

Hi Jeff,

On the connection problem, does RigPi disconnect and reconnect properly without requiring a reboot when you are connected locally through your LAN?  When you reboot, log in, and the Tuner window appears, are you seeing an error that says Internet not found?  Does that happen when connecting locally?

Tell me a bit about the path from RigPi to the outside Internet.  Is only one router in the path?

On no transmit audio, have you run the tests in RigPi Help to make sure audio is present at TX OUT?  (Troubleshooting>No Audio.)

--Howard


Jeffj51@...
 
Edited

HI Howard,

This may be a false alarm. I just connected/disconnected using DNS and the RSS terminal did not give me an error message. Maybe I was doing something out of sequence. The following except for the TX audio was a response to your earlier questions that may be moot.

The Rigpi is disconnecting and reconnecting properly when I'm on the LAN. I am using a DNS account to connect even if I am home. There is only one router. When I disconnect (I assume you mean disconnect the radio on the tuner screen) and then go to the RSS terminal, I get the Internet Not Found message. I have to reboot to clear the message. (Seems to work ok now)

I ran the tests but heard no audio on the earbuds. The following is the test readout. Should I have Rigpi shut down to run the test? 

speaker-test 1.1.3
 
Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
Using 16 octaves of pink noise
Playback open error: -16,Device or resource busy
pi@rigpi:~ $ speaker-test -t sine -f 2000 -c2
 
speaker-test 1.1.3
 
Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
Sine wave rate is 2000.0000Hz
Playback open error: -16,Device or resource busy
pi@rigpi:~ $ speaker-test -t wave -c2
 
speaker-test 1.1.3
 
Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Playback open error: -16,Device or resource busy

Sorry to keep bugging you on this, but we must be very close to solving the issue. I would have set up direct cables, but the 857 has the RJ-45 mic connector and I don't have tools or desire to do that.

73,
Jeff
 


Howard Nurse, W6HN
 

Hi Jeff,

Only one program can use the audio device at a time, so shut down Mumble for the tests.

Restating your Internet connection, if you are at home, when you log out of RigPi and log back in, you do/don't get the error message?

You are using the DATA port, for audio, correct?

--Howard

--Howard