Topics

Mumble connected on audio

Steve Smith <wb9hbh@...>
 

Mumble looks like it's connected but there is no audio in or out of the radio (KX3)
Interface cables check good
Did the speaker-test -c2 test and only get audio out of side 0/left side (I think)
Did the dmesg | grep audio test with no results back. Did not seem to work at all.
Did just dmesg  test and it came up with 3.662510 ( snd-rpi-proto soc:sound: ASoc: CODEC DAI wm8731-hifi not register ) and in several other address lines
I do have full control of the KX3 just no audio in/out Suggestions?
Thanks Steve

Mark Weisheimer
 

Steve,

You don't say which interface cables and just how you have them connected, so in guessing mode here...

If you use the RJ-45 to 3.5mm MFJ-5700KX3, did you receive a 16 pin jumper board with the cable?
If so, did you install that inside the RigPi, on the bottom of the top board?

If you don't use that cable you can ignore the above.

Your tests are interesting, but what did you see with a green check mark when you right click the speaker in the top right of the Raspbian desktop?

--
73 - Mark - K8MHW
'A RigPi Enthusiast...since April 23, 2019!' - I am not otherwise affiliated with MFJ or RigPi

Steve Smith <wb9hbh@...>
 

snd_rpi_proto

I made my own RigPi using a new Pi3+ and the MFJ audio board. Yes I got the MFJ cable, no jumper plug but made my own.
Using the test info in Howard"s manual and it looks like the Audio board may be bad.

Made my own RigPi using a new PI3+ 7in Pi display, keyboard, mouse and MFJ audio board.
Everything works but the audio section I'm thinkg the MFJ board is bad.
Steve

Mark Weisheimer
 

Steve,

I got the same "no results returned" for:
dmesg | grep audio


Below is copied the lines pertaining to audio from my DMSEG on a working RigPi:
[    4.563772] snd-rpi-proto soc:sound: ASoC: CODEC DAI wm8731-hifi not registered - will retry
[    4.615891] wm8731 1-001a: Assuming static MCLK
[    4.615925] wm8731 1-001a: 1-001a supply AVDD not found, using dummy regulator
[    4.615999] wm8731 1-001a: 1-001a supply HPVDD not found, using dummy regulator
[    4.616053] wm8731 1-001a: 1-001a supply DCVDD not found, using dummy regulator
[    4.616105] wm8731 1-001a: 1-001a supply DBVDD not found, using dummy regulator
[    4.621692] snd-rpi-proto soc:sound: wm8731-hifi <-> 3f203000.i2s mapping ok

As I recall, only the left channel is used, so audio from only the left may be a normal result for:
speaker-test -c2 test and only get audio out of side 0/left side

However, Howard will be able to answer more definitively when he comes online.

--
73 - Mark - K8MHW
'A RigPi Enthusiast...since April 23, 2019!' - I am not otherwise affiliated with MFJ or RigPi

Howard Nurse, W6HN
 

Hi Steve,

RigPi Audio provides mono output on the  left channel.  You should see several lines in dmesg that refer to snd-rpi-proto.  Only the last one is significant, the first several showing "not register" say that the attempt did not register, but the last one shows OK.  Since the audio test works we have to assume that it registered correctly.

I recommend running a test with a 3.5 mm cable.  Plug one end into the Phones output on the radio.  Plug the other into the RX IN (center jack) on the audio board.  In Mumble, open the Configure>Settings>Audio Input window and select Transmission>Voice Activity.  Does the bar graph show audio activity?

If not, start Alsamixer from Terminal (alsamixer<enter>) and confirm that the settings are correct using RigPi Help as guidance.

Try the same audio test you described below.  Does it show as audio activity in the Mumble bar graph?

Let us know what you find.

--Howard

Howard Nurse, W6HN
 

Steve, what audio device have you selected in Mumble?

--Howard

Steve Smith <wb9hbh@...>
 

Yes it does show activity.
I guess its working correctly.

Off to work now back after midnight
Thanks Steve

HERB KEATON N2GEW
 

Hi Howard:
I have been working on getting the audio settled as my first effort I noticed I was
producing substantial carrier, even though the PTT amd Mode were set to LSB.
The power meter saw a continuous 60 watt carrier and a remote  SDR heard a loud rumbling and
negligent audio. Just a loud blast and ugly.

I decided to check the settings in Alsamixer and found them to be much off of the recommended
shown in RigPi Help. Master Gain set to 30, Sidetone to 100 and Mic Boost 0, for starters.
I have the Input Mux set for Mic thinking this to be correct since I am taking the audio from
the Radio Mic connector on the ICOM 756 PRO. Yes?

I will report back tomorrow now that I have the Alsamixer settings where RigPi Help recommends.
Hopefully, the charm since the settings were so far off.

73 / Herb / N2GEW

HERB KEATON N2GEW
 

Hello again:
I apologize: what I thought was an audio issue involving the Mumble VOIP and Alsamixer appears now to
be unrelated. Newbie error on my part.

I started the ICOM and connected to the RigPi cleanly. I DID NOT start the Mumble software. When I went to the PTT whether on a WIFI computer or the iPhone, the radio goes into transmit.
I have the frequency set on 80 meter LSB, I assume this is all normal. 
But listening on an out-of-state SDR and seeing my power meter deflect/stabilize at 100 watts is not. On the SDR, it sounds like a solid grumbling sound showing clearly on the waterfall for the length of the transmission.

I, of course, will not repeat this except on a dummy load: until I can resolve.

Left to my own resources, I would say now the issue is probably with the MFJ-5708P cable OR the MFJ-1204P8 jumper. I was one who bought the cable at HRO and it did not have the jumper in the package. I called MFJ and waited a week. I was presuming they sent me the correct jumper to install in the socket on the RigPi board. Back to the drawing board?

Any thoughts and assist is very much appreciated. 

73 / Herb / N2GEW

Howard Nurse, W6HN
 

Hi Herb,

Time for some sleuthing.  For example, pull out the cable connected to TX OUT.  Does the problem go away?  What you are seeing could be a feedback loop.  Check that the 756 MON function isn’t turned on.  By process of elimination you can isolate the cause.

—Howard

HERB KEATON N2GEW
 

Howard:
Thanks for the response and what you do for the group.
Sleuthing:  "to carry out a search or investigation in the manner of a detective".
Ouch!
I don't have any cable plugged into TX Out on the RigPi. I am using the cable (RJ45) to audio card to the Mic connector on the front of the radio.
Should I disconnect this?
Cat control is from 1/8" plug CI-V port on the radio back to RigPi USB.
The 756 PRO 3 has a light when the radio has the Monitor function on: That's pretty hard to miss.
I take it the suggestion that the jumper block maybe the culprit you don't consider likely.
I will keep snooping.

73 / Herb / N2GEW


HERB KEATON N2GEW
 

Howard
I disconnected the audio cable from the Radio Mic to the RigPi. As you would suspect, the
radio goes into transmit when I engage PTT but no power output is present. I was into a
dummy load. Nothing on the power meter.
I also noticed the S-Meter on the RigPi tuner display is pinned at 60 db during transmit/PTT.

I plugged the RJ45 back into RigPi. With RF Power on the radio set to full, the
power meter reads full-power out constant carrier. However, I am noticing a 
sound like a relay clicking from the back of the radio. Very rapid pulses.

When I turn down RF power to 1/2 on the radio, I don't hear the rapid clicking.
But I do notice the power meter "pulses" about 1 time a second from 50 watts to 0 and back.  Very 
repeatable, timed pulses. 

BTW, the SWR/Power meter is outside the radio.
The investigation will continue.….

73 / Herb / N2GEW

Howard Nurse, W6HN
 

Herb, try plugging a set of earbuds into TX OUT on RigPi.  When you go into transmit do you hear anything?  (A cable plugged into TX OUT bypasses the RJ-45 connector.)

The RigPi S-meter in transmit shows a static level that can indicate maximum power out as et in your radio.  There are settings in RigPi to calibrate that as described in RigPi Help.  Unfortunately Hamlib does not provide a relative power out signal during transmit.

—Howard

HERB KEATON N2GEW
 

Howard:
I hope I understood this correctly and I can report the following results:

1) I plugged in the "receive" headphone side of a Sennheiser headset into TX Out on the RigPi.
2) I connected to the RigPi via my iPhone using Safari. Connected to the IC-756PRO3
3) I started Mumble on the iPhone. Connected to the server
4) Listening on the headset, I could hear myself talking in the presence of the iPhone.
5) When hitting PTT, I could continue hearing my broadcast. The radio went into transmit,
but no audio/RF went out. My meters recorded no output. Never-the-less, I could hear myself
when I went into transmit.  A slight hum from the cellphone when PTT, but no difference
in the headset. 

There were no issues as previously reported of the radio "clicking" or otherwise: of course, I had no RF out.

If I did this correctly, does this tell you anything about my issues?

Thanks/Regards:

73/Herb/N2GEW

Howard Nurse, W6HN
 

Hi Herb,

All good news in your report.  When you plug in headphones to TX OUT, no audio is sent from the RJ-45 since it is bypassed by the headphones.  You didn't hear excessive hum or clicking I assume.

Since the headphone test appears to be OK, that leaves the jumper block, cable, or a radio setting.  There are two similar Accesssory connectors on the 756.  ACC1 is the one to use.  The manual states that the radio must be in SSB Data Mode for the audio to be accepted through the Accessory connector rather than the mic.  I don't see anything in the menu system that changes that requirement.  If you are using ACC1 and the radio is set to SSB Data Mode, and there still isn't rf when you use PTT and talk, our next teest will require shorting a pin on the jumper block with a clip lead to turn on PTT.  I'll send steps if necessary.

--Howard

HERB KEATON N2GEW
 

Howard:
Thanks for responding and all the support.

There were two reasons I decided on the front radio mic connector and MFJ-5708P cable from the IC-756PRO3:

1) The cable, MFJ-5708D, for the ACC (1) 8-pin Din connector was not available, on back order. (All HRO locations remain out-of-stock
yoo date on this cable, 7-weeks since my original order)
2) Guide in the files section of this RigPi site recommends the front Mic connection for better flexibility versus ACC (1) .

I am still concerned about the jumper block that MFJ sent in after my purchase of the MFJ-5708P cable.
But that becomes moot if I abandon and go to the other DIN cable. If it is still back ordered,
I will now make the cable. And I will go to 24 ga. insulated wires as an alternative to the block,
which I assume is also back ordered.

I assume we are in agreement now that this would be the best path to success.

Thanks,

73/Herb/N2GEW

Howard Nurse, W6HN
 

OK, I missed that you are using the Mic connector.  Yes, that should work fine.  Can you pull out the mic connector and use clip leads/headphone to listen for audio on the mic pin, or do you have a 'scope?  As marked on the board, pin 7 on the jumper socket is audio to the radio.  You can use an ohmmeter (after shutting down power on RigPi) to check from pin 7 on the jumper connector to pin 8 on the mic connector.  Pin 8 is the center pin.

--Howard

HERB KEATON N2GEW
 

Howard:
Good afternoon to you.
Thank you for helping me play detective on this effort. Unfortunately, I don't have a scope. 
But permit me to bring you up-to-date on my findings so far.

I did a factory reset on the Icom radio as a precaution. I went back over the correct settings in the radio.

I removed the jumper board from the internal socket in the RigPi to verify that the board did indeed 
prove identical to the RigPi jumper schematic as shown for the 8-pin round mic connector and
specific to the Icom 756PRO3. With an ohmmeter, the paths are identical to the schematic in the files
section of RigPi documentation.

I then removed the jumper board and plugged the 8 pin round connector/RJ-45 cable into the RigPi.
I put one test lead onto the center of the Mic connector (Pin 8) and the other lead to pin 7 on the jumper socket.
I DID NOT have continuity to that location. I DID have continuity from the socket on Pin  8 to the center pin of
the mic connector, Pin 8

I checked this several times.'

I replaced the jumper board and read continuity from Pin 1, Pin 6,
Pin 7, and Pin 8 to the Pin 8 of the mic connector.

Can you tell me what's next?

Regards,

Herb / N2GEW 

HERB KEATON N2GEW
 

On Wed, Sep 4, 2019 at 04:50 PM, Howard Nurse, W6HN wrote:
As marked on the board, pin 7 on the jumper socket is audio to the radio
Howard:
Good Morning to you,
I was hoping you would explain this to me. Sorry if it's obvious and I am not understanding.

The jumper socket that I am looking at shows Pin 7 as a ground.
Where is it marked audio to the radio?
I am missing something here.

73 / N2GEW

Howard Nurse, W6HN
 
Edited

Herb, here is a photo showing pin 6, which is the PTT connection.  The Mic connection is pin 7, as marked on the "top" side of the board.

--Howard