Topics

No RF Output in FT8 on my 7300 all of the sudden (would 1.0.5 have caused a problem?)


Adam Hosa
 

Hi Folks,

So for the majority of the day I was running FT8 remote, no problems. Towards the end of the work day, I saw the message come out about the update to 1.0.5 so I updated via the browser, PI restarted and I went home. I got to my rig, and was going to mess around with the audio settings (my other post out there) but figured Id make a few Q's first. When I started tx sitting in front of the radio, the rig was keying up but I didnt see any RF out on the meter of the rig or my auto tuner. Tried other modes (CW, FM, SSB with a mic) and have no problems - full power blasting away.

I even reset my 7300 to the default settings that I used from the doc in our files section, everythings been working fine all along, until today.

Any thoughts?

Thanks :)

Adam N1AH


Adam Hosa
 

Well scratch that, for some reason my PCM setting was all the way at zero. I guess thats what sends audio out? Weird that I didnt mess with it - but it seems to be working now.

Sorry for the false alarm!


Harold Rosee <wa5zzt@...>
 

Adam,

Glad you got it working.  I will tell you my secret that keeps me from having the audio issues that I see a lot having is I never set any of the audio setting in Mumble or the digital programs to "Default".  The default as you probably know picks up whatever you have checked as the system default under the speaker icon.  Since the RigPi came out I have always hardcoded from the drop downs the correct device I wanted to use.  Either the CODEC or the Soundcard.   I saw many guys including the beta testers complaining about watery audio.  When I was helping Beta testing 1.05 all the guys except me were complaining of the watery audio.  Howard and I finally found it was caused by taking the system default.

So in Mumble and WSJT=X I always hard code what I use and never have a problem.  I use the Codec for my USB connection but the same holds true if I am using the audio board.  I hope all this makes sense.  My main point is I don't recommend choosing "Default" even though I write up all my Radio setup instructions that way.  I did that because it was just easier to get someone going/  Then if they have problems I suggest the other way.  

Anyway glad you are working.

73's
Harold
W5ZZT


Adam Hosa
 

Hi Harold! Good working you on FT8 the other day, haha.

One thing I am noticing, Im watching the browser while FT8 sends out a CQ - sometimes, it says transmitting in WJSTX, however, the rigpi browser shows nothing is keyed up. 15 seconds later, when it goes for the next transmit window, I see it key up. This sporadically goes back and forth. Maybe I dont everything tweaked exactly the way they should be in the 7300? Im new to the radio, so I dont know a whole lot yet. Like, when I up the PCM setting on the Pi, how about the 7300? What would i want to tweak there?

Also, I was interested in seeing the SWR when I transmit, via the rigpi browser. I set the advanced setting menu to SWR, but the meter under the frequency readout doesnt seem to really change.

(Im also using an LDG autotuner with the 7300, tunes my antennas much better than the internal tuner...also trying to figure out how I need to set the internal tuner so as to not interfere with the external one, but that might be for another forum, hihi)

I'll quit rambling now :)

Adam


Harold Rosee <wa5zzt@...>
 

Adam,

Sounds like you are hooked on FT8 like me.  I don't run it much from the RigPi except when I used to do Beta testing.  I run it on my PC with my Flex 6500.

I am not sure why you even have the browser going when running FT8 other than to set the frequency to 14.074 or whatever band you are on.   On the 7300 all the setting you will mess with are under the connectors menu.  So Menu>SET>connectors.  The second setting from the top, ACC/USE AF Output is for the speaker audio to your phone or whatever you are listening to.   Then you have 2 TX level settings depending on if you are using the ACC or USB.  They are on the second page of settings in the 7300. ACC Mod level and USB MOD Level.   Just set both to 50 percent and leave them alone. 

Once you get the frequency set with the browser just close it.  Also you can't have Mumble running during any digital modes.  You should shut it down before you even start up WSJT.  Go into the mumble menu and do Server>Quit Mumble.  When you are done you can start Mumble back up from the applications menu under Internet.  Just grab it by holding the left mouse button down on the selection and slide it onto the desktop.  That way it's easy to get to.  In fact you can do that on any program you want on the desktop.  As far as the level in the mixer (PCM) just put it at about 70-80 percent and that will work fine with the 7300 settings.

As far as the tuner in the 7300 just leave it off when using your external tuner.  If your tuner needs a carrier to tune just switch modes in the browser to AM and hold the PTT for as long as you think it takes for the tuner to tune.

The meter in the RigPi just pegs out in transmit making it difficult to see what going on in transmit.   All the radio control is handled but the Hamlib program that the RigPi calls to control the various radio.  Howard most likely just passes it parameters and it does the rest but I feel certain it can read the meter and return various readings like power output and SWR but that is something Mr. Howard would have to answer.  Hopefully he will see us talking about him and answer this.  We at least need Power Output or a ALC reading to see what's going on.  Right now it's anybody's guess.  When I am out and about I can't never remember where I set my power level.  I have 3 HF rigs so I usually can't remember.  I set up a macro to put the power at 100 percent.  I usually just press that macro before I transmit the first time so I know I am at 100 watts.  Not ideal but it serves the purpose.


Make sure you read what I wrote here:  https://groups.io/g/RigPi/message/1909

I always select my audio choices from the menus.  I never use the "default" setting.  It just works better and there is no guessing where you are.  Unless Howard fixed it in V1.05 we found during testing that if you select "default" in the Mumble settings you get some terrible audio.  Selecting the correct device in Mumble and WSJT always gives the best audio.

OK, I rambled more than you and not in any order of your questions.  I probably missed something so if I did feel free to ask again.

Harold
W5ZZT



From: RigPi@groups.io <RigPi@groups.io> on behalf of Adam Hosa via Groups.Io <Ifone@...>
Sent: Thursday, July 25, 2019 9:33 PM
To: RigPi@groups.io <RigPi@groups.io>
Subject: Re: [RigPi] No RF Output in FT8 on my 7300 all of the sudden (would 1.0.5 have caused a problem?)
 
Hi Harold! Good working you on FT8 the other day, haha.

One thing I am noticing, Im watching the browser while FT8 sends out a CQ - sometimes, it says transmitting in WJSTX, however, the rigpi browser shows nothing is keyed up. 15 seconds later, when it goes for the next transmit window, I see it key up. This sporadically goes back and forth. Maybe I dont everything tweaked exactly the way they should be in the 7300? Im new to the radio, so I dont know a whole lot yet. Like, when I up the PCM setting on the Pi, how about the 7300? What would i want to tweak there?

Also, I was interested in seeing the SWR when I transmit, via the rigpi browser. I set the advanced setting menu to SWR, but the meter under the frequency readout doesnt seem to really change.

(Im also using an LDG autotuner with the 7300, tunes my antennas much better than the internal tuner...also trying to figure out how I need to set the internal tuner so as to not interfere with the external one, but that might be for another forum, hihi)

I'll quit rambling now :)

Adam


Adam Hosa
 

Thanks Harold - as soon as I get out of work today, I'm heading over to the rig to try the settings you mentioned above.

I was under the assumption that if I running ft8 from the rigpi i needed to have the browser open and connected in the backround, is that not the case? oops.

Im on 20 meters now trying to call a JA station, and I can see that the PTT Button on the rigpi browser only keys up once in a while, while the FT8 program shows transmit every time. Is it safe to assume that if FT8 keys the rig, the PTT button on the browser would turn red each time? If thats the case, then something weird is going on and im not transmitting every time it says i am... (i did manage to just snag the JA though just now)

Adam


Adam Hosa
 

I know - its just nice to have everything running on one pi (so i can go voice or cw if i want to) in addition to running wjstx. I guess i could always set up another pi with JUST wjstx and vnc into it if i really wanted to.

Adam