Topics

yaesu ft-891 #mfj-1234

kc9flu@...
 

anyone know the settings I should be doing on the Yaesu ft-891 ? for audio.. i have control of radio with USB cable   and  have 6 pin din to rj45 on RSS .. i also have plumble installed on my android phone .says Pi connected.. and welcome to the RigPi sever running Murmur.. and I also did the jumpers on the audio board  for Yaesu radios.. I can key up radio but no audio out.. and no receive..?

Howard Nurse, W6HN
 

I just took a look at the Yaesu FT-891 advanced user manual, and it looks like the only menu that needs tweaking for transmit audio is #11.  There is a setting in that group to transfer SSB mic audio to the rear (RTTY/DATA), but you didn’t mention whether or not you were having transmit and receive audio issues.  There very well could be another menu item for SSB receive audio from the speaker to the rear connector, so check the menu setting carefully.

73, Howard W6HN

kc9flu@...
 

found the setting ( SSB mic select) changed to to rear .. still no audio... and also i have no transmit audio .. on my phone i can push PTT and radio will key up but no audio out.. and no receive... too. not sure if its in the mumble on the RSS or plumble settings  on my phone.. i can type back in forth to mumble to plumble... just no audio   out and no transmit audio out? something  not set right?

Howard Nurse, W6HN
 

When you ordered the RJ45 cable, did you receive a jumper header compatible with your radio?  The header is installed on the audio daughter board which requires you remove the top cover (2 screws) and the 2 screws holding the daughter board to gain access.  If you did not receive the header you should contact MZFJ (or whoever you purchased from) to get one, make sure they know what radio it is for.

Without the jumper header installed you will not get audio to and from your radio.

—Howard


On Jul 20, 2019, at 9:01 PM, kc9flu via Groups.Io <kc9flu@...> wrote:

found the setting ( SSB mic select) changed to to rear .. still no audio... and also i have no transmit audio .. on my phone i can push PTT and radio will key up but no audio out.. and no receive... too. not sure if its in the mumble on the RSS or plumble settings  on my phone.. i can type back in forth to mumble to plumble... just no audio   out and no transmit audio out? something  not set right?

Harold Rosee <wa5zzt@...>
 

Keith,

Once you verify the jumper as Howard has mentioned above you can follow the mumble instructions in my Icom 756pro instructions.  They will be the same for any radio using the audio card like you are using.

Look here:
https://groups.io/g/RigPi/message/1778

Harold
W5ZZT

kc9flu@...
 

I installed jumper wires per Yaesu radios  6 pin 

pin 1 to mic
pin 2 to ground
pin 3 to ptt
pin 5 to spkr

Mark Weisheimer
 

Folks,

There was another message thread for this here:

https://groups.io/g/RigPi/message/1688

His audio cable is a SignalLink mini DIN6 to RJ-45 connector.
I said in that thread that I believed that the SignalLink cable is wired the same as MFJ-5706MD
I may be wrong...again...(and I'm sorry if I was, but well, it happens...)
Can you do some signal tracing to see if there is audio for RX and TX?
You have PTT, so I suspect that at least ground and PTT are wired as expected.

Do you have any kind of simple audio amplifier that you can use with some DIY test leads?
You just want to be able to "listen" to the audio at various points.
I use an old set of amplified PC speakers (about a buck for the set, with cables at the local thrift store) that I chopped the 1/8" plug off of one end and stripped the wires.
Then use the shield to ground and either the red or white wire to probe for audio with.
If you can take the cover off of the RigPi, you can probe on the 16 pin connector that you made the jumpers for.
You are wanting to hear RX audio on the Speaker pin.
There are other ways to use the RigPi to visualize whatever audio is present, using Alsamixer or Audacity apps on the RigPi.
But first, let us know if you have RX audio at the 16 pin connector.

My goal was to use the cable that you already had, and it CAN be made to work, it just might require that the jumpers be re-arranged.
I would normally recommend the MFJ-5706MD with the Yaesu jumper.

--
73 - Mark - K8MHW
'A RigPi Enthusiast...since April 23, 2019!' - I am not otherwise affiliated with MFJ or RigPi

kc9flu@...
 
Edited

I think Ill order the MFJ-5706MD cable .. I believe they are still on backorder..
from  MFJ   ...sorry not currently we are minus two on those, they are made overseas. we expect a new shipment august 7.

Mark Weisheimer
 

Do you have a continuity tester?
I have a new MFJ-5706MD here that I received about a week ago.
I can test here and post the results if you are able to do the same with the SignaLink cable.
A search today for the SignaLink cables and plugs seems to show that the MiniDIN6 is the same as the MFJ-5706MD.
But I am happy to ring this one out if it can help.
--
73 - Mark - K8MHW
'A RigPi Enthusiast...since April 23, 2019!' - I am not otherwise affiliated with MFJ or RigPi

Mark Weisheimer
 

I ran a continuity test of the MFJ-5706MD and it came out as Pin for Pin, IE, Pin 1 of the RJ-45 was Pin 1 of the Mini DIN 6 and followed each number down the line.
So, it was 1 to 1, 2 to 2, 3 to 3, 4 to 4, 5 to 5 and 6 to 6.
The RJ-45 is numbered with the spring tab down, the gold pins facing up and away from me, 1 is the farthest left pin.
There are no wires in position 7 and 8 of the RJ-45 connector.
The Male Mini DIN 6 is below, looking forward at the male pins:

--
73 - Mark - K8MHW
'A RigPi Enthusiast...since April 23, 2019!' - I am not otherwise affiliated with MFJ or RigPi

kc9flu@...
 

Ok i will check continuity of my signal Link cable .also in attachment   this is my Data port  on back of radio.




kc9flu@...
 

just did the test on the signal Link cable  identical ! to yours.

Mark Weisheimer
 

Yes, it verifies that the SignaLink cable and the MFJ cable use the same wiring standard.

Now, on to why you are not hearing audio.

Maybe the issue will be that the Mumble Client's audio setting will need tweaked.
An earlier post suggested testing the analog audio at the jumper block inside the RigPi.
It was not clear if you were able to do that or if it is not practical for you to do.
Either is fine, but we need to drill down to where the chain is broken. Is it a configuration setting or a lack of analog audio.

--
73 - Mark - K8MHW
'A RigPi Enthusiast...since April 23, 2019!' - I am not otherwise affiliated with MFJ or RigPi

kc9flu@...
 
Edited

Here are some screen shots of mumble  And as it's says : opening chosen ALSA  output failed 

Harold Rosee <wa5zzt@...>
 

You need to go into mumble and go to configure>settings and screen print the input tab and the output tab and post it here.  One of those is not loading and probably not set correctly.

Harold

Mark Weisheimer
 
Edited

There it is, you've found it.

Try these steps that Harold has written up. Let us know how it is after the reboot.

RigPi Audio Settings for Internal Sound Card Audio.

  1. On the RigPi desktop RIGHT click on Speaker icon in the top right hand corner of the screen.

    There should be a green check-mark next to snd_rpi_proto

  2. Your Mumble menu should be showing on the desk top. If not click on the lips at the top right of the screen. This will bring the main Mumble menu into view.

  3. On the Mumble menu go to Configure>settings>audio input tab on left. Verify the Device to the right is set to:
    [sysdefaultCARD=sndrpiproto] snd_rpi_proto, Default Audio Device If not, use the drop down menu to select it.  There are many selections but you want the one that ends in default audio. If you are unable to determine the correct setting please contact one of the experienced users for help. You can try them all one at a time without hurting anything to see which one sounds the best. If you are on V1.05 (not released as of 7/24/2019 this should already be done for you since the audio card is the default for the RigPi). Just make sure and press Apply each time you test another setting from the drop down menu.

  4. Press Apply at the bottom. Do NOT press OK yet.

  5. Now on the left hand side of the menu move down to the next menu by selecting "Audio Output" and as you did in step 3 verify the device is set to:
    [sysdefaultCARD=sndrpiproto] snd_rpi_proto, Default Audio Device If not, select it. This setting is for your transmit audio

  6. Press Apply. This time press OK. The configuration menu goes away.

  7. THIS STEP IS IMPORTANT To save your Mumble changes you must Quit Mumble and Reboot. To do this, on the main mumble screen now showing press Server>Quit Mumble. *Mumble menu will go away*

  8. Go to the Raspberry icon at the top left of the screen and after pressing on it select "Shutdown". It is the last selection and will bring up another menu usually in the middle of the screen. Please select "Reboot"

  9. When the system comes back up Verify any changes you have made are still there. If not start over and take your time.

 


--
73 - Mark - K8MHW
'A RigPi Enthusiast...since April 23, 2019!' - I am not otherwise affiliated with MFJ or RigPi

Harold Rosee <wa5zzt@...>
 

I do want to add something to my instructions.  If you use default as I say for both input/output tab in mumble and the audio sounds bad you need to override the default by selecting the correct setting in the dropdown inside mumble for the input(rx audio) and output(TX audio).  That will always ensure the best audio.  We figure out a few weeks ago when Beta Testing that this fixes that.

There are a bunch of settings that look alike.  You want the one for CODEC or Sound card that ends in "Default audio device".

Harold



 

Mark Weisheimer
 

Harold makes a good point.
For anyone who has implemented the recommended audio update at:

https://groups.io/g/RigPi/files/RigPi%20Documentation/RigPiAudioTreeUpdate.pdf

The favored audio device is named:

[sysdefaultCARD=sndrpiproto] and_rpi_proto, Default Audio Device

--
73 - Mark - K8MHW
'A RigPi Enthusiast...since April 23, 2019!' - I am not otherwise affiliated with MFJ or RigPi

kc9flu@...
 

Does this mean the audio update was already installed ?  I just received mine a few weeks ago

Mark Weisheimer
 

Yes, that is it.
The latest MFJ image included the audio update.
--
73 - Mark - K8MHW
'A RigPi Enthusiast...since April 23, 2019!' - I am not otherwise affiliated with MFJ or RigPi